LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2010, 09:12 PM   #1
halborr
Member
 
Registered: Aug 2009
Posts: 112

Rep: Reputation: 18
Latest pidgin update seems to have broken dock icon


Running 12.2 on fluxbox, it seems the latest pidgin update has messed with my dock icon- it's no longer the pidgin icon, now I believe it's a generic one. It's not REALLY a big deal, but it kind of bugs me...

Where is this set/how do I go about fixing it?
 
Old 05-22-2010, 09:34 PM   #2
koenigdavidmj
Member
 
Registered: Oct 2009
Posts: 73

Rep: Reputation: 25
Try moving ~/.purple aside and starting over. You'll need to re-add your accounts and such, but it may help.
 
Old 05-23-2010, 09:18 PM   #3
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
^^Thanks, but no dice. Starting from scratch gives the same icon.
 
Old 05-24-2010, 09:18 AM   #4
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Try reloading your icon cache.
 
Old 05-24-2010, 07:25 PM   #5
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
How would I go about doing that? I've tried googling but all I've found is stuff about rc.M... Can I just run the relevant block from that?
 
Old 05-24-2010, 08:31 PM   #6
Thursapr
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 44

Rep: Reputation: 18
I believe there's a minor bug with the Help > About dialog. Its width is bigger than it should be.
 
Old 05-24-2010, 09:19 PM   #7
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
/usr/bin/gtk-update-icon-cache should do the trick.
 
Old 05-25-2010, 09:37 PM   #8
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
^^ I tried
Code:
/usr/bin/gtk-update-icon-cache --force /usr/share/icons/hicolor
and
Code:
#!/bin/sh

	for theme_dir in /usr/share/icons/* ; do
			/usr/bin/gtk-update-icon-cache -t -f ${theme_dir}
	done
Didn't help. I'm ruther confused on this one :-S
 
Old 05-25-2010, 09:51 PM   #9
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
I just tried running pidgin as a different user on KDE, it gave a different icon, a little white page with a red X on it, whereas this one is dark with a light perimeter, if that makes any sense...

Probably due to using a different icon set? Although, now I know it's not related to where I'm running it...
 
Old 05-27-2010, 04:46 PM   #10
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
Bump... Any new ideas what it might be?
 
Old 05-27-2010, 05:17 PM   #11
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
Hrm... I found the icons in /usr/share/pixmaps/pidgin, and the relevant tray ones are there, but they don't show up.

EDIT: I think this is a configuration error on pidgin's part.

EDIT#2: Installing pidgin 2.6.6 instead (from old security updates) makes the icon work fine, but it breaks on 2.7.0.

Last edited by halborr; 05-27-2010 at 09:28 PM.
 
Old 05-28-2010, 01:40 AM   #12
botnet
Member
 
Registered: May 2009
Posts: 158

Rep: Reputation: 40
the new pidgin uses a different location for the icons

the new location for the tray icons is now:

Code:
/usr/share/pixmaps/pidgin/tray/hicolor/16x16/status
pidgin-tray-available.png  pidgin-tray-connect.png    pidgin-tray-offline.png
pidgin-tray-away.png       pidgin-tray-email.png      pidgin-tray-pending.png
pidgin-tray-busy.png       pidgin-tray-invisible.png  pidgin-tray-xa.pn

ran into this same problem the other day, putting those files in that location resolved the issue
depending on the size of your tray, you may need to do the same in each of 22x22/ 32x32/ 48x48/ under the hicolor parent directory, as well
 
Old 05-29-2010, 09:23 AM   #13
halborr
Member
 
Registered: Aug 2009
Posts: 112

Original Poster
Rep: Reputation: 18
That's weird, I install 2.7.0 and that directory and files are there, yet it still doesn't work. All directories are there (16x16, 22x22, 32x32, 64x64).

Code:
root@strider:/usr/share/pixmaps/pidgin/tray/hicolor/16x16/status$ ls
pidgin-tray-available.png  pidgin-tray-connect.png    pidgin-tray-offline.png
pidgin-tray-away.png       pidgin-tray-email.png      pidgin-tray-pending.png
pidgin-tray-busy.png       pidgin-tray-invisible.png  pidgin-tray-xa.png
EDIT: does this directory have to have an icon cache built for it?

Last edited by halborr; 05-29-2010 at 09:24 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhclient and dhcpcd broken after latest - current update em21701 Slackware 2 03-06-2010 10:02 AM
blackbox around pidgin icon. Daedra Slackware 1 11-14-2009 06:49 PM
Pidgin won't dock itself anymore! Ryupower Linux - Software 3 08-13-2009 12:47 PM
gFTP icon in WindowMaker dock taylor_venable Linux - Software 2 10-03-2005 11:16 PM
Beep media player dock icon VertX Linux - Newbie 9 05-04-2005 02:48 PM


All times are GMT -5. The time now is 01:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration