LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-15-2010, 08:35 AM   #1
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Rep: Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918
Latest current updates .gtkrc-2.0 doesn't appear to work.


Hi guys, little help please.

Since updating from current+Robby's xorg patches to Pat's latest current update this morning I've found that my gtk2 theme doesn't seem to be working any more. It seems to have switched to some ugly off-grey brown colour and looks very ugly indeed.

Up until now, I've set the theme with a ~/.gtkrc-2.0 as follows
Code:
gtk-theme-name = "Xfce-4.2"
gtk-icon-theme-name = "Tango"
The theme's gtkrc file still seems to exist under the appropriate directory in /usr/share/themes/...

This is under the lightweight window managers. I don't have KDE installed.

Running /usr/bin/xfsettingsd puts everything back how it should be, but I've not needed to run this in the past. The ~/.gtkrc-2.0 was enough on it's own and I'd prefer not to have to run a daemon if not necessary.

Is anyone aware of any changes in this area that would explain why my ~/.gtkrc-2.0 no longer takes affect?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-15-2010, 10:48 AM   #2
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Thumbs down

1. I am facing the same problem in fluxbox. The problem does not occur in xfce and kde (when launching gtk apps). [see screenshot]

2. Conky appears poorly aligned. [see screenshot]

the gtkrc file is not being read, i presume.

My .gtkrc file:
Code:
gtk-theme-name="Clearlooks Brave"
gtk-icon-theme-name="Faenza-Cupertino"
gtk-font-name="Ubuntu 11"
gtk-cursor-theme-name="Shere_Khan_X"
Any help would be appreciated.
Attached Images
File Type: jpeg snapshot8.jpeg (187.7 KB, 43 views)

Last edited by slackd; 11-15-2010 at 11:02 AM.
 
Old 11-15-2010, 03:56 PM   #3
speccy
Member
 
Registered: Dec 2008
Location: Portsmouth, UK
Distribution: slackware
Posts: 39

Rep: Reputation: 31
I have had the same problem, the icon theme still works, as does the font, but the "gtk-theme-name" doesn't.

Using:

Code:
include "/usr/share/themes/Xfce-dawn/gtk-2.0/gtkrc"
in the .gtkrc-2.0 file works for me.
 
4 members found this post helpful.
Old 11-15-2010, 05:31 PM   #4
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Original Poster
Rep: Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918
Thanks Speccy, looks like you're right. 'Include' works, and it seems it's the gtk-theme-name option that has broken. It was my understanding that the gtk-theme-name was the recommended way of doing this rather than using include, so the question now is: bug, or functional change?

Last edited by GazL; 11-15-2010 at 06:09 PM.
 
Old 11-15-2010, 06:52 PM   #5
speccy
Member
 
Registered: Dec 2008
Location: Portsmouth, UK
Distribution: slackware
Posts: 39

Rep: Reputation: 31
No problem, no one deserves to look at the default theme
 
Old 11-15-2010, 07:25 PM   #6
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Quote:
Originally Posted by speccy View Post
I have had the same problem, the icon theme still works, as does the font, but the "gtk-theme-name" doesn't.

Using:

Code:
include "/usr/share/themes/Xfce-dawn/gtk-2.0/gtkrc"
in the .gtkrc-2.0 file works for me.
Thanks, I'll test when i boot into slackware.
 
Old 11-15-2010, 08:18 PM   #7
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Thumbs up

Speccy,

The "include" option works. Thanks a Lot.
 
Old 11-15-2010, 09:47 PM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
There's no mention in the 2.22.0 tarball's ChangeLog about gtk-theme-name being deprecated/removed, so I suspect it was an accidental breakage.
 
Old 11-15-2010, 10:31 PM   #9
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Quote:
Originally Posted by rworkman View Post
There's no mention in the 2.22.0 tarball's ChangeLog about gtk-theme-name being deprecated/removed, so I suspect it was an accidental breakage.
I just saw this morning that a new GTK was released, but there is no mention of the "gtk-theme-name" "Bug?".

Quote:
Overview of Changes from GTK+ 2.22.0 to 2.22.1
==============================================

* Bugs fixed
563002 Doesn't call 'update-preview' on set_filename
609622 disappearing statusicon
613728 Rationalize GtkTreeView focus
624025 gdk_draw_rectangle bogged down by ColorSync
629722 save_entry_get_info_cb() doesn't behave correctly
630962 double click isn't catched
631332 gdk_pixmap_create_from_data();
631473 Fix GTK+3 documentation
631872 Please ship modules/input/README.multipress in tarballs
632894 Only show Desktop in file chooser button if there is one

Last edited by slackd; 11-15-2010 at 10:32 PM.
 
Old 11-16-2010, 11:34 AM   #10
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 495

Rep: Reputation: 81
What about that patch to bring the icons back? I saw only by passing eyes, but is it related?

And thanks for the tip.

Last edited by BrZ; 11-16-2010 at 12:58 PM.
 
Old 11-17-2010, 12:48 PM   #11
Fidori
LQ Newbie
 
Registered: Oct 2007
Location: Finland
Distribution: Slackware
Posts: 24

Rep: Reputation: 8
In /etc/profile.d/gtk+.sh, the environment variable GTK2_RC_FILES is set to value "$HOME/.gtkrc-2.0:/etc/gtk-2.0/i486-slackware-linux/gtkrc". If this variable is set, GTK applications read the configuration from the given files. Because the system configuration file /etc/gtk-2.0/i486-slackware-linux/gtkrc is specified after the configuration in home directory, it will override settings in .gtkrc-2.0. In /etc/gtk-2.0/i486-slackware-linux/gtkrc, gtk-theme-name is set to "GTK+", and overrides the one set in the users config.
 
4 members found this post helpful.
Old 11-17-2010, 01:43 PM   #12
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Original Poster
Rep: Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918
Ahh, that makes sense. Thankyou Fidori, I wasn't aware of that.

Sounds like it might be an idea for Pat to alter the order around so as to give the expected(*) behaviour of ~/.gtkrc-2.0 taking precedence.

"GTK2_RC_FILES="/etc/gtk-2.0/x86_64-slackware-linux/gtkrc:$HOME/.gtkrc-2.0" seems to do the trick.


(*) Well, that's what I'd expect anyway.

Last edited by GazL; 11-17-2010 at 02:00 PM.
 
1 members found this post helpful.
Old 11-17-2010, 07:57 PM   #13
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,569

Rep: Reputation: 426Reputation: 426Reputation: 426Reputation: 426Reputation: 426
it's fixed in the latest update
Code:
Thu Nov 18 00:05:34 UTC 2010
l/gtk+2-2.22.1-i486-2.txz: Rebuilt.
       Changed GTK2_RC_FILES to favor the settings in $HOME/.gtkrc-2.0.
       Thanks to Fidori on LQ.
 
1 members found this post helpful.
Old 11-18-2010, 02:42 AM   #14
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Exporting GTK2_RC_FILES broke the way KDE applies its theme to non KDE applications.
If you want to get that back apply $HOME/.kde/share/config/gtkrc-2.0
to the /etc/profile.d/gtk+.sh and gtk+.csh lines:
Code:
GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0"
like this:
Code:
GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0:$HOME/.kde/share/config/gtkrc-2.0"
Note: this is untested but should work, it will also most likely get fixed in a different way.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest sudo updates Feanor Slackware 2 09-21-2010 02:57 AM
Latest Updates from Distros? linuxunix Linux - Newbie 2 04-05-2010 07:04 AM
Radeon DRI lost after latest updates from current 64bit veeall Slackware 5 02-12-2010 04:38 AM
Problems with latest Updates jchorn Suse/Novell 2 01-19-2008 11:06 AM
Latest updates killed 3d accell trey85stang Fedora 3 12-26-2004 01:30 PM


All times are GMT -5. The time now is 05:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration