LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-11-2006, 07:41 AM   #1
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Last hurdle with Slack...boot from Grub [SOLVED]


Hi Everybody,

I am almost there...got Slack installed, net card is finally working, sound enabled. I have one last hurdle to overcome. I cannot seem to get the right grub.conf file entries to get it to boot. Slack is installed on the same SATA hard drive as WinXP. The partitions are this:

sda1: WinXP
sda2: Slackware
sda3: Swap

My current grub entry for Slack is this:

root (hd0,1)
kernel /boot/vmlinuz-2.4.31 root=/dev/sda2 vga-788 ro

When I choose Slack from the grub boot menu, I get this error:

Error 1: Filename must be either absolute pathname or blocklist

This is the grub entry for Slack that was recommended elsewhere and on other sites.
If anyone has Slackware booting from Grub successfully with a similar configuration to mine, would you be so kind as to showing me your grub.conf entry?

Any help very much appreciated.

Bob
 
Old 03-11-2006, 08:27 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try
Code:
title Slackware
kernel (hd0,1)/boot/vmlinuz-2.4.31 root=/dev/sda2 vga=788 ro
Your code above should probably work if you corrrect the vga section (= not -).
 
Old 03-11-2006, 09:44 AM   #3
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Thank you for your reply. I entered the line into grub.conf just as shown, but I am afraid it doesn't work. It returns:

Error 15: file not found

It could be that I do not have the kernel identified correctly (i.e. there may be more to the kernel name), but I have not found it yet. This one really baffles me.

I can boot from the floppy just fine. Just can't figure this one out.

Thanks for your help.

Bob
 
Old 03-11-2006, 09:57 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
if you can boot from the floppy, can you change into /boot and then list the files that are in there. Also what is the entry for Fedora Core?
 
Old 03-11-2006, 02:21 PM   #5
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Hi raddazz,

Thank you for your response. My Fedora grub entry is as follows:

root (hd1,0)
kernel /boot/vmlinuz-2.6.14-1.1656_FC4 ro LABEL=/ rghb quiet
initrd /boot/initrd-2.6.14-1.1656_FC4.img

Again, as I understand it, the initrd entry is not required for Slackware. And, yes, I have rooted around in the /boot directory of Slack and found nothing revealing about the file name. I can only assume there is more to the filename than just 2.4.31, but I have not found it.

Thank you again.

Bob
 
Old 03-11-2006, 03:20 PM   #6
KleB
Member
 
Registered: Jan 2006
Location: Slovenia
Distribution: Slackware, Gentoo
Posts: 97

Rep: Reputation: 15
Hi,

sorry if I mess around with things I don't know well, but are you sure that your kernel is in fact named vmlinuz-2.4.31? If I understand you correctly you are not sure. In that case please tell what files do you have in /boot. For other things with grub I can't help you, as I don't use it.

Klemen
 
Old 03-11-2006, 03:21 PM   #7
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Thank you to all who helped....job done!

Just a quick post to all who helped me with my new installation of Slackware 10.2. I added this distro to my collection as a training tool because of it rock solid stability reputation and it's lack of hand holding (like the other distros do). I want to become an advanced user and I believe Slack will let me to that.

I have two pending posts in this forum asking for help in writing code to enable me to boot Slack from my grub menu. Everything else had been solved (sound, net, etc.) but this one last thing was eluding me. Here is how I solved it:

I simply used the same entry I had described in my previous posts in my grub.conf file, BUT SIMPLY LEFT THE KERNEL VERSION OUT. As such:

root (hd0,1)
kernel /boot/vmlinuz root=/dev/sda2 ro vga=788

That's it!

To all who responded (you know who you are), just a quick thanks.

Bob
 
Old 03-11-2006, 03:24 PM   #8
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Thank you for your response..As it turns out I have solved the issue (please see my other post today). I knew the kernel version, but my entries weren't working. Out of a mindset of "one more try", I reedited the grub.conf file and simply left the kernel version out. BANG! It worked.

I hope this experience will help someone else.

Thanks again,

Bob
 
Old 03-11-2006, 03:57 PM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Glad you got it working. Its the small things that sometimes cause us big problems.
 
Old 03-11-2006, 07:51 PM   #10
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
I always have vmlinuz as a soft link to the kernel I'm using as my 'current'
Code:
ln -s /boot/vmlinuz-2.6.15a vmlinuz
and one to the older 'bootable' kernel
Code:
ln -s /boot/vmlinuz-2.6.15 vmlinuzsafe
That way, I can change the kernel (like I do almost once a week), and don't have to woory as much about bootloaders. I just make sure that 'vmlinuz' and 'vmlinuzsafe' are what is called from the bootloader.
 
Old 03-12-2006, 04:28 AM   #11
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Thank you. A good point to remember. I am primarily a Fedora user, so when I installed Slack I tried to make grub entries look the same. Obivously didn't work, but I will know for the future.

BTW, my home is Montgomery, AL. Just noticed you are from the Heart as well.

Bob
 
Old 03-12-2006, 11:27 AM   #12
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Congrats on getting it sorted. I have merged the 2 threads so that the thank yous are in the same place as the help received.
 
Old 03-12-2006, 11:38 AM   #13
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Quote:
Originally Posted by XavierP
Congrats on getting it sorted. I have merged the 2 threads so that the thank yous are in the same place as the help received.
A really nice move, plus the [SOLVED] added improves the quality of the forum greatly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo : grub: The file /boot/boot/grub/stage1 not read correctly Boudewijn Linux - Software 3 05-21-2008 04:13 AM
Realplayer last hurdle thom Slackware 10 09-26-2005 11:00 PM
need to access /boot/grub/menu.lst and /boot/grub/device.map neouto Linux - Newbie 8 09-04-2005 12:45 PM
The IM hurdle for no-IM settings. NoobieDoobieDo Programming 0 10-18-2004 04:50 PM
Fedora/Slack Dual-Boot w/ GRUB mijenks Linux - Software 0 06-11-2004 08:40 AM


All times are GMT -5. The time now is 04:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration