LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-12-2007, 02:10 PM   #1
thethinker
Member
 
Registered: Jul 2006
Location: Tallahassee, FL
Distribution: Slackware 12
Posts: 98

Rep: Reputation: 15
Laptop Power shutdown under heavy processor use, Slack 11.0 Kernel 2.6.18


Hey everyone,
Been working on upgrading my Toshiba 2545XCDT laptop to Slack 11.0 with a 2.6.18 kernel, but I'm having a power shutdown issue. This question might go in either the laptop or the kernel forum, but I figured it's Slack, so try here first.

The problem is simple and very reproducable; when the processor is doing something for a long time (recently it's been compiling ALSA from source), the power will randomly shutdown after maybe 20-30 minutes of this. It does it regradless if it's on battery power or wall power, and if the computer is just sitting (i.e. screensaver or something) there this doesn't happen, and it doesn't happen under the 2.4 kernel. I'm thinking a power issue in the new kernel, but I'm not really sure where to start looking.

Anyone have any thoughts on where to get started with this?

Thanks!
(PS in case it matters, the kernel is from the Slack 11.0 CDs with no customizing)
 
Old 06-12-2007, 02:51 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
It may be something with ACPI ... not sure if you can use apm instead on a 2.6.x kernel.

Last edited by H_TeXMeX_H; 06-16-2007 at 12:16 PM. Reason: it's ACPI not APIC, crap !
 
Old 06-12-2007, 03:11 PM   #3
bzyk
Member
 
Registered: Jun 2007
Location: Poland
Distribution: Debian, Slackware
Posts: 42

Rep: Reputation: 15
Why not use apm on 2.6 kernels? It's all depends of your hardware. I'm using apm on 2.6 (Thinkpad T23), and everything it's ok. Better then on acpi system.
thethinker; question is, what powersaving subsytem do you use? If you have default slackware 2.6 kernel, then I suppose that You use acpi. Try to stop acpi daemon (/etc/rc.d/rc.acpi stop), and watch for any changes...
 
Old 06-12-2007, 03:12 PM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,420

Rep: Reputation: Disabled
Could it be overheating? Does the fan come on?

Brian
 
Old 06-12-2007, 06:43 PM   #5
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,172

Rep: Reputation: 47
I would guess it's overheating. It sounds like either the kernel or BIOS is detecting excessive CPU temperature and forcing the power off to protect the hardware. If you can't modify the kernel's ACPI modules, try minimizing resource usage when compiling sources. And, if necessary, consider an external cooling source.
 
Old 06-12-2007, 07:47 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
Are there any internal sensors that you can get the temp from ? Maybe that'll tell you if it's overheating.
 
Old 06-13-2007, 09:06 AM   #7
thethinker
Member
 
Registered: Jul 2006
Location: Tallahassee, FL
Distribution: Slackware 12
Posts: 98

Original Poster
Rep: Reputation: 15
stopping the ACPI demon didn't work, so I guess I could just recompile the kernel with apm instead of acpi enabled (I didn't put either in as modular). Given that I don't have this problem in the 2.4 kernel, maybe that's the answer. I'll get back with more info later today.

Thanks for the help so far guys.
 
Old 06-13-2007, 04:06 PM   #8
thethinker
Member
 
Registered: Jul 2006
Location: Tallahassee, FL
Distribution: Slackware 12
Posts: 98

Original Poster
Rep: Reputation: 15
Well guys it appears the problem is fixed...I recompiled, getting rid of ACPI in favor of APM, tried to compile ALSA (which didn't work before) and it completed. So perhaps that was the answer. Fine with me!

Thanks a bunch!
 
Old 06-13-2007, 04:28 PM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
On my laptop I also had many problems with ACPI. Switching to APM helped. I guess some laptops don't fully (and correctly) support ACPI ... or there is a bug in ACPI ?
 
Old 06-14-2007, 09:08 AM   #10
bzyk
Member
 
Registered: Jun 2007
Location: Poland
Distribution: Debian, Slackware
Posts: 42

Rep: Reputation: 15
I think, there's nothing wrong with ACPI. Just older laptops don't correctly
cooperate with ACPI standard.
 
Old 06-14-2007, 09:50 AM   #11
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,139
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
So how does one install Slackware 11 on an older laptop to use apm instead of acpi and with a 2.6 kernel?

I've got a Thinkpad A22m that I'm considering wiping OpenSUSE off of to put on Slackware 11, which my desktop computer already has.

Regards,

-Drew
 
Old 06-14-2007, 11:03 AM   #12
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
First try it with ACPI, then if you have problems, recompile the kernel to use APM (take ACPI out of the kernel).

You should also note that you should not use APM with SMP. This is unlikely anyway, because, as bzyk says, it typically only happens in older laptops.
 
Old 06-15-2007, 02:14 PM   #13
bzyk
Member
 
Registered: Jun 2007
Location: Poland
Distribution: Debian, Slackware
Posts: 42

Rep: Reputation: 15
Lufbery: I have T23 (just typing on it), and Slackware 11 on board. I had some problems with acpi. Suspending and resuming from ram was not so good ad I want to... That why I give ACPI up. I'm using apm now, and everything is ok. Suspending to ram, to disc (suspend2 - path on kernel), working very good. And all Fn/control combinations are good. If you want occasionally turn off acpi, run kernel with parameter; acpi=off. Want to turn off for ever - configure your lilo or grub with append parameter (man lilo.conf). Then, when you start without acpi just type as root; modprobe apm. Generally, if you have more questions about linux and Thinkpad visit thinkwiki.org

Last edited by bzyk; 06-15-2007 at 02:16 PM.
 
Old 06-18-2007, 08:22 AM   #14
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,139
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
bzyk,

Thanks for the tips. Here's another question: which kernel are you using?

Thanks,

-Drew
 
Old 06-19-2007, 11:40 AM   #15
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,420

Rep: Reputation: Disabled
Quote:
Originally Posted by H_TeXMeX_H
Are there any internal sensors that you can get the temp from ? Maybe that'll tell you if it's overheating.
With acpi you can obtain this information from directory /proc/acpi/thermal_zone/THRM/. For example, to find out the cpu temperature I do:

Code:
cat /proc/acpi/thermal_zone/THRM/temperature
Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New kernel installed, laptop won't power off rollo Linux - Laptop and Netbook 8 12-07-2005 03:40 PM
Power-off during shutdown causes kernel panic CapKrugers Linux - General 6 11-08-2004 06:52 PM
Heavy processor usage while doing almost nothing Wynd Linux - General 12 01-09-2004 11:02 PM
Slack 9.0 Selection of kernel dual processor tungsten Slackware 3 06-27-2003 03:50 AM
how to automatically power off after shutdown in redhat7.3(kernel 2.4.20) prad Linux - General 8 12-18-2002 02:37 PM


All times are GMT -5. The time now is 01:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration