Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-06-2010, 03:32 AM   #1
Registered: Jan 2007
Distribution: Slackware 11.0
Posts: 141

Rep: Reputation: 16
Kppp not working


I use kppp to access internet through my mobile gprs and its properly configured. However for the past few days its giving error 16 i.e modem hangup and it shows that the connect script failed. I am unable to solve this problem through google or by changing any settings in the ppp scripts.

All my settings are working fine on windows and i am able to connect to internet with my mobile gprs with windows but not on Linux(Slackware 12)

Here is the output of /var/log/messages
pppd 2.4.4 started by root, uid 0
Feb 6 14:30:16 battleaXe pppd[3279]: Using interface ppp0
Feb 6 14:30:16 battleaXe pppd[3279]: Connect: ppp0 <--> /dev/modem
Feb 6 14:30:17 battleaXe pppd[3279]: PAP authentication succeeded
Feb 6 14:30:18 battleaXe pppd[3279]: LCP terminated by peer
Feb 6 14:30:21 battleaXe pppd[3279]: Connection terminated.
Feb 6 14:30:21 battleaXe pppd[3279]: Modem hangup
Feb 6 14:30:21 battleaXe pppd[3279]: Exit.

I will be grateful to you guys if you could provide some help

Old 02-06-2010, 08:55 AM   #2
Senior Member
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,407

Rep: Reputation: 188Reputation: 188
Here are a few things to try:

Try /etc/pppd/options, insert into options "noauth"
Set the authentication mode to PAP/CHAP
Restore the correct permissions by issuing the commands
chown root.root /etc/resolv.conf
chmod 644 /etc/resolv.conf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kppp not working in Kubuntu rayburke Ubuntu 10 04-21-2009 04:58 PM
Kppp is working pppd not xprometeus Linux - Networking 1 11-29-2005 10:34 AM
KPPP not working microsoft/linux Debian 3 01-18-2005 10:19 AM
kppp not working in mandrake10.0 square_eyes Linux - Networking 1 05-24-2004 05:17 AM
Is Kppp working properly? gmichel Linux - Newbie 0 01-13-2004 04:38 AM

All times are GMT -5. The time now is 04:51 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration