LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Kmymoney2 Slackware64 Sbo Slackbuild Error (http://www.linuxquestions.org/questions/slackware-14/kmymoney2-slackware64-sbo-slackbuild-error-737743/)

AlleyTrotter 07-04-2009 02:40 PM

Kmymoney2 Slackware64 Sbo Slackbuild Error
 
I plan to switch my primary stuff over to slackware64 when stable
For now I amd running it on a spare partition with excellent results
I have moved my mysql databases over without problems
I have moved my kvm virtual machines over also without problems
My php address book runs the same as 12.2
Several gainfully employment programs and their data have survived the test transition
Along with mail browser settings and bookmarks

Kmymoney2 has me stumped
It runs quite well in a VM but the solution is a little clumsy to me when moving from vm to main system and back.
So I tried the slackbuild from slackbuilds.org and it failed looking for kde3. After reviewing posts on LinuxQuestions
I've installed the kde3 compatability packages from extra.
I set the architecture to x86_64 still won't compile.
Read more posts and added
"--with-qtdir=/opt/kde3/lib64/qt3-3.3.8"
to the .configure portion of the slackbuild script. No cigar, finally decided I need help.
this is the most current error which has me stuck
<quote>
checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
</quote>

/opt/kde3/lib64/qt3-3.3.8b/lib/libqt-mt.so.3.3.8 exists and it is >= Qt 3.3 and < 4.0

any ideas will be greatly appreciated

thanks
john

Michielvw 07-04-2009 08:19 PM

well it seems that KMyMoney2 on Slackware64/KDE4 is going to be a right bugger to figure out. Anyway as far as the QT not found problem:

1) Make sure you are either logged out and logged back in so that QTDIR get set properly. [1]
2) Add the following to the ./configure statement for KMymoney2 to have it actually detect the libs [1]

--with-qt-dir=/opt/kde3/lib64/qt3 \
--with-qt-includes=/opt/kde3/lib64/qt/include \
--with-qt-libraries=/opt/kde3/lib64/qt3/lib \

See where that gets you. For me it actually detects QT3 but refuses to build so far.

[1] - Make sure you have kde3 compat installed .. or at least kdelibs,arts and qt.

Let me know how you get on...

-M.

AlleyTrotter 07-05-2009 07:37 AM

Michielvw
I retraced all my steps to be sure I was not doing anything really simple like a syntax error or such did not find any.
I used your suggestions of adding the includes and libs configure ran longer and seemed like I was on my way, but I still stop with the following error and about 20 similar before this ie "has no member 'xxxx'"
""""""""""""""""""""""""""""""""""
/opt/kde3/lib64/qt3/include/qmap.h:382: error: 'struct QMapNode<QString, QString>' has no member named 'left'
/opt/kde3/lib64/qt3/include/qvaluelist.h: In member function 'void QValueList<T>::detach() [with T = QString]':
/opt/kde3/lib64/qt3/include/qvaluelist.h:529: instantiated from 'QValueListIterator<T> QValueList<T>::append(const T&) [with T = QString]'
/opt/kde3/lib64/qt3/include/qmap.h:721: instantiated from 'QValueList<T> QMap<Key, T>::values() const [with Key = QString, T = QString]'
kgpgfile.cpp:586: instantiated from here
/opt/kde3/lib64/qt3/include/qvaluelist.h:565: error: 'class QValueListPrivate<QString>' has no member named 'count'
make[2]: *** [kgpgfile.lo] Error 1
make[2]: Leaving directory `/tmp/SBo/kmymoney2-0.9.3/libkgpgfile'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/kmymoney2-0.9.3'
make: *** [all] Error 2
""""""""""""""""""""""""""""""
for a quick recap the changes I had to make to get this far

1. I got a bash error on line 65 - so I changed the following two lines and commented out the test for useofx
--disable-ofxplugin \
--disable-ofxbanking \

2. This moved the error to /tmp/Sbo/admin/config.sub - so I changed the --build=$ARCH-slackware-linux line to
--build=$ARCH

3. This got me to the no libqt-mt error adding the three --with-qt lines produces the error listed above

This is starting to get over my 1970's TRS-80 programming capabilities

Any suggestions will be greatly appreciated

john

AlleyTrotter 07-05-2009 02:02 PM

It Works
 
Michielvw
As a young man returning from Vietnam my GI bill got me OJT as an appliance repairman. My trainer Rich always said first thing you do when entering a house is wipe your feet, ask for a cup of coffee and make sure the appliance is plugged in. Back to basics
In the README file it states
""""""""""""""""""""""""""
Run configure to tell the project about your local environment

./configure --with-qt-dir=[your location of qt3] \
--prefix=[your location of kde3]
""""""""""""""""""""""""""
all I had to do was change the --prefix

make the changes to the slackbuild as follows:

ARCH=${ARCH:-x86_64}

./configure \
--prefix=/opt/kde3 \

and add the lines:

--with-qt-dir=/opt/kde3/lib64/qt3 \
--with-qt-includes=/opt/kde3/lib64/qt/include \
--with-qt-libraries=/opt/kde3/lib64/qt3/lib \

Then Kmymoney2 builds a package and the package installs into /opt/kde3/bin/kmymoney2
and it works fine with slackware64 current as of today.

Thanks for your help
John

Michielvw 07-05-2009 10:10 PM

Quote:

Originally Posted by AlleyTrotter (Post 3597578)
Michielvw
ARCH=${ARCH:-x86_64}

That is not even needed. Just set export "ARCH="x86_64" in your shell's startup files and it will take care of that.

-M.


All times are GMT -5. The time now is 09:13 AM.