LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-09-2013, 03:32 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,476

Rep: Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531
KMS and pm-suspend quirk?


I discovered a quirk with my T400 laptop. Hopefully solvable.

The native default resolution for the laptop monitor is 1280x800 (16:10 ratio). At that resolution I found the fonts too small and causing eye strain. Therefore I have the following boot parameter:

i915.modeset=1 video=1024x600

I boot to run level 3. Screen resolution (and hence, font size) is as I intended.

I log in and manually run pm-suspend to place the laptop into sleep mode. I then resume the device.

The resolution reverts to the default 1280x800 screen size and the fonts are way small again.

To add to the strangeness, I then start and exit X, and the screen resolution returns to 1024X600.

Any ideas how to fix this quirk?

Thanks.
 
Old 07-09-2013, 04:25 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,422
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
I would avoid running a lower resolution and instead choose a larger font using the setfont command.
 
Old 07-09-2013, 04:35 PM   #3
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,025

Rep: Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966
A workaround would be to use a bigger console font with KMS (as does Slackware-current's installer).

For instance you could try a Terminus font (shipped in Slackware-current or available through slackbuilds.org).

Sizes available are 6x12, 8x14, 8x16, 10x18, 10x20, 11x22, 12x24, 14x28, 16x32.

EDIT TobiSGD was faster
 
Old 07-09-2013, 06:33 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,476

Original Poster
Rep: Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531
To me, changing the font is indeed a work-around. I'd rather fix the quirk if possible.

I tried other fonts, including the Terminus font, but prefer the default font.
 
Old 07-09-2013, 09:06 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,422
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
I would see it as workaround to run a LC display not at its native resolution, but that is of course up to you.
Have you searched the log-file for errors?
 
Old 07-11-2013, 10:31 AM   #6
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,912

Rep: Reputation: Disabled
This may not work , and if it doesn't, I'm out of ideas, but try this:
Code:
# cat /etc/modprobe.d/i915.conf
options i915 video=1024x600
I won't swear that the i915 module is unloaded on suspend, but it looks as if maybe that's the case. If indeed it is, then that means it's reloaded on resume, which would make the above modprobe config useful for you.
 
Old 07-11-2013, 05:56 PM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,476

Original Poster
Rep: Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531
Thanks. I tried several variations and every time udev complained that "video" was not recognized. I tried building i915 into the initrd too. Odd that 1024x600 is restored by starting and exiting X.
 
Old 07-11-2013, 09:03 PM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,912

Rep: Reputation: Disabled
Yeah, thinko on my part. I had in my head that the "video" parameter went with the i915 module, but it doesn't. I think this is worth mentioning to the kernel drm folks - seems like this should work as you expect without restarting X.
 
Old 07-12-2013, 12:11 AM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,476

Original Poster
Rep: Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531
Me too. I got so focused on associating the "video" parameter with "i915" that the distinction did not dawn on me for a while.

A modestly annoying quirk because I prefer to boot into run level 3. I have the lid and Fn-F4 mapped to sleep. Invoking either without logging in or starting X triggers the quirk. Nothing crashes but a classic example of a "paper cut."

I never liked the way KMS uses absurdly tiny fonts. Too much web design and software development is performed on monitors as big as a TV and seldom tested on basic monitors.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64-current in VirtualBox: if EFI always KMS, else no KMS. Why? Didier Spaier Slackware 6 07-04-2013 02:21 PM
LXer: Automatically Resume from Suspend to Ram and Suspend to Disk to Save Battery in Linux LXer Syndicated Linux News 0 05-10-2013 02:40 AM
LXer: Nouveau: X Render, RandR 1.2, FB, KMS Suspend Done LXer Syndicated Linux News 0 10-18-2009 05:50 AM
LXer: Nouveau Developments: KMS, Suspend & Resume LXer Syndicated Linux News 0 10-10-2009 11:50 AM
Linux KMS Intel 865G: Hacking KMS to use vesa... or disable hardware acceleration eantoranz Linux - Hardware 1 08-01-2009 12:58 PM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration