LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Kmail crashing in Slackware current with KDE 4.7.3 (http://www.linuxquestions.org/questions/slackware-14/kmail-crashing-in-slackware-current-with-kde-4-7-3-a-913087/)

saivnoba 11-11-2011 06:34 PM

Kmail crashing in Slackware current with KDE 4.7.3
 
1 Attachment(s)
Hi all,
I'm running Slackware current. I've installed KDE 4.7.3 from ktown repo. I'm having problem with Kmail.

Whenever I launch Kmail (first run), I get the following error:
Code:

Kmail encountered a fatal error and will terminate now.
The error was: Failed to fetch the resource collection.

I don't know much about debugging and all. I just ran kmail from konsole and saved all I could to a file. Please find the file attached (I exceeded 30k line limit :-).

Let me know if you need any more info. Thanks in advance.

Alien Bob 11-12-2011 08:18 AM

This sometimes happens if you upgrade from an older version of KDE (like Slackware's 4.5.5) and keep your existing KDE configuration below "~/.kde" intact.

Can you please try the following:

(1) Launch Akonadi Console (for instance by pressing "Alt-F2" to open krunner and typing "akonadiconsole")
(2) In the "Agents" tab, select the "Local Folders" resource
(3) Select "Configure > Configure natively...".
(4) If an error appears indicating that "the current folder does not exist" don't worry. Select a new directory which does not yet exist, for instance: /home/<USERNAME>/.kde/share/apps/kmail/mail/

This should fix your issue. The bug is fairly old, and is discussed at https://bugs.kde.org/show_bug.cgi?id=259355

Eric

saivnoba 11-12-2011 07:05 PM

Hi Eric,
Thanks a lot. That fixed my issue, although I did not understand it :-)

Should have googled. Since I was running -current and upgraded to your packages, I _wrongly_ _assumed_ it must be issue with this specific installation. Sorry about that.


All times are GMT -5. The time now is 12:18 PM.