LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-28-2005, 06:46 AM   #1
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
kmail: "Could not start process pop3." (after KDE update)


IMPORTANT: To anyone else having the problem described below, I have put a temporary workaround at the end of this post...

Late last night I updated my system by Swaret to current.

Everything seemed to go fine but this morning when trying to run kmail I just get a "Could not start process pop3" error whenever I try to download mail.

Any ideas what's wrong and (better) how to fix it?

A google for the error message gave no results and the kmail help hasn't.

[EDIT: To be exact, Google gave results, but only for the problem, not the solution to it! It seems I am not alone...]

A quick check of what was updated gives this:

Code:
iain@iains:/var/swaret$ ls -lt | grep "2005-04-28"
-rw-r--r--  1 root root  6598462 2005-04-28 02:53 xscreensaver-4.21-i486-2.tgz
-rw-r--r--  1 root root   311630 2005-04-28 02:52 python-tools-2.4.1-noarch-1.tgz
-rw-r--r--  1 root root   232015 2005-04-28 02:52 python-demo-2.4.1-noarch-1.tgz
-rw-r--r--  1 root root 11089581 2005-04-28 02:52 python-2.4.1-i486-1.tgz
-rw-r--r--  1 root root 16790738 2005-04-28 02:51 mozilla-1.7.7-i486-1.tgz
-rw-r--r--  1 root root   599328 2005-04-28 02:48 libxslt-1.1.14-i486-1.tgz
-rw-r--r--  1 root root  1875827 2005-04-28 02:48 libxml2-2.6.19-i486-1.tgz
-rw-r--r--  1 root root 17072500 2005-04-28 02:48 kdepim-3.4.0-i486-2.tgz
-rw-r--r--  1 root root 27673306 2005-04-28 02:45 kdebase-3.4.0-i486-2.tgz
-rw-r--r--  1 root root  6967273 2005-04-28 02:41 gtk+2-2.6.7-i486-1.tgz
-rw-r--r--  1 root root  1243426 2005-04-28 02:40 glib2-2.6.4-i486-1.tgz
-rw-r--r--  1 root root 10497497 2005-04-28 02:40 gimp-2.2.6-i486-1.tgz
-rw-r--r--  1 root root  4431328 2005-04-28 02:39 gaim-1.2.1-i486-1.tgz
-rw-r--r--  1 root root   887412 2005-04-28 02:38 cvs-1.11.20-i486-1.tgz
-rw-r--r--  1 root root  3141764 2005-04-28 02:38 binutils-2.15.92.0.2-i486-3.tgz
So kdepim was one of the updated packages - should I just roll-back to kdepim-3.4.0-i486-1.tgz or will that also mean having to go back to kdebase-3.4.0-i486-1.tgz?

Checking /var/log/swaret seems to show no issues:

Code:
Thu Apr 28 02:36:11 BST 2005: [ GLOBAL ] - swaret --update
Thu Apr 28 02:36:11 BST 2005: [ update_lists() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:36:15 BST 2005: [ update_lists() ] - ### Fetching CHECKSUMS List File... DONE!
Thu Apr 28 02:36:20 BST 2005: [ update_lists() ] - ### Fetching FILELIST List File... DONE!
Thu Apr 28 02:36:23 BST 2005: [ update_lists() ] - ### Fetching PACKAGES List File for Packages... DONE!
Thu Apr 28 02:36:23 BST 2005: [ update_lists() ] - Extra Packages Descriptions up-to-date!
Thu Apr 28 02:36:24 BST 2005: [ --changelog ] - ### Fetching ChangeLog... DONE!
Thu Apr 28 02:36:24 BST 2005: [ update_lists() ] - => Generating List Files... DONE!
Thu Apr 28 02:36:25 BST 2005: [ GLOBAL ] - swaret --upgrade -a
Thu Apr 28 02:37:26 BST 2005: [ GLOBAL ] - swaret --update
Thu Apr 28 02:37:26 BST 2005: [ update_lists() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:37:30 BST 2005: [ update_lists() ] - ### Fetching CHECKSUMS List File... DONE!
Thu Apr 28 02:37:30 BST 2005: [ update_lists() ] - FILELIST List File is up-to-date!
Thu Apr 28 02:37:30 BST 2005: [ update_lists() ] - Packages Descriptions up-to-date!
Thu Apr 28 02:37:30 BST 2005: [ update_lists() ] - Extra Packages Descriptions up-to-date!
Thu Apr 28 02:37:30 BST 2005: [ update_lists() ] - ChangeLog up-to-date!
Thu Apr 28 02:37:30 BST 2005: [ GLOBAL ] - swaret --upgrade -a
Thu Apr 28 02:37:52 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:38:20 BST 2005: [ gfile() ] - ### Fetching binutils-2.15.92.0.2-i486-3 (3068 kB)... DONE!
Thu Apr 28 02:38:20 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package binutils-2.15.92.0.2-i486-3 OK!
Thu Apr 28 02:38:20 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:38:28 BST 2005: [ gfile() ] - ### Fetching cvs-1.11.20-i486-1 (866 kB)... DONE!
Thu Apr 28 02:38:28 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package cvs-1.11.20-i486-1 OK!
Thu Apr 28 02:38:28 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:39:08 BST 2005: [ gfile() ] - ### Fetching gaim-1.2.1-i486-1 (4327 kB)... DONE!
Thu Apr 28 02:39:08 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package gaim-1.2.1-i486-1 OK!
Thu Apr 28 02:39:08 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:40:38 BST 2005: [ gfile() ] - ### Fetching gimp-2.2.6-i486-1 (10251 kB)... DONE!
Thu Apr 28 02:40:38 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package gimp-2.2.6-i486-1 OK!
Thu Apr 28 02:40:38 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:40:49 BST 2005: [ gfile() ] - ### Fetching glib2-2.6.4-i486-1 (1214 kB)... DONE!
Thu Apr 28 02:40:49 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package glib2-2.6.4-i486-1 OK!
Thu Apr 28 02:40:49 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:41:49 BST 2005: [ gfile() ] - ### Fetching gtk+2-2.6.7-i486-1 (6803 kB)... DONE!
Thu Apr 28 02:41:50 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package gtk+2-2.6.7-i486-1 OK!
Thu Apr 28 02:41:50 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:45:46 BST 2005: [ gfile() ] - ### Fetching kdebase-3.4.0-i486-2 (27024 kB)... DONE!
Thu Apr 28 02:45:46 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package kdebase-3.4.0-i486-2 OK!
Thu Apr 28 02:45:46 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:48:13 BST 2005: [ gfile() ] - ### Fetching kdepim-3.4.0-i486-2 (16672 kB)... DONE!
Thu Apr 28 02:48:13 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package kdepim-3.4.0-i486-2 OK!
Thu Apr 28 02:48:13 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:48:30 BST 2005: [ gfile() ] - ### Fetching libxml2-2.6.19-i486-1 (1831 kB)... DONE!
Thu Apr 28 02:48:30 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package libxml2-2.6.19-i486-1 OK!
Thu Apr 28 02:48:30 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:48:37 BST 2005: [ gfile() ] - ### Fetching libxslt-1.1.14-i486-1 (585 kB)... DONE!
Thu Apr 28 02:48:37 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package libxslt-1.1.14-i486-1 OK!
Thu Apr 28 02:48:37 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:51:00 BST 2005: [ gfile() ] - ### Fetching mozilla-1.7.7-i486-1 (16397 kB)... DONE!
Thu Apr 28 02:51:00 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package mozilla-1.7.7-i486-1 OK!
Thu Apr 28 02:51:00 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:52:36 BST 2005: [ gfile() ] - ### Fetching python-2.4.1-i486-1 (10829 kB)... DONE!
Thu Apr 28 02:52:36 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package python-2.4.1-i486-1 OK!
Thu Apr 28 02:52:36 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:52:39 BST 2005: [ gfile() ] - ### Fetching python-demo-2.4.1-noarch-1 (226 kB)... DONE!
Thu Apr 28 02:52:39 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package python-demo-2.4.1-noarch-1 OK!
Thu Apr 28 02:52:39 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:52:42 BST 2005: [ gfile() ] - ### Fetching python-tools-2.4.1-noarch-1 (304 kB)... DONE!
Thu Apr 28 02:52:42 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package python-tools-2.4.1-noarch-1 OK!
Thu Apr 28 02:52:42 BST 2005: [ gfile() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 02:53:40 BST 2005: [ gfile() ] - ### Fetching xscreensaver-4.21-i486-2 (6443 kB)... DONE!
Thu Apr 28 02:53:40 BST 2005: [ checksum() ] - => <MD5CHECK> MD5 for Package xscreensaver-4.21-i486-2 OK!
Thu Apr 28 02:53:56 BST 2005: [ function_upgrade() ] - => Upgrading binutils-2.15.92.0.2-i486-2 to binutils-2.15.92.0.2-i486-3... DONE!
Thu Apr 28 02:53:58 BST 2005: [ function_upgrade() ] - => Upgrading cvs-1.11.18-i486-1 to cvs-1.11.20-i486-1... DONE!
Thu Apr 28 02:54:04 BST 2005: [ function_upgrade() ] - => Upgrading gaim-1.2.0-i486-1 to gaim-1.2.1-i486-1... DONE!
Thu Apr 28 02:54:15 BST 2005: [ function_upgrade() ] - => Upgrading gimp-2.2.4-i486-1 to gimp-2.2.6-i486-1... DONE!
Thu Apr 28 02:54:20 BST 2005: [ function_upgrade() ] - => Upgrading glib2-2.6.3-i486-1 to glib2-2.6.4-i486-1... DONE!
Thu Apr 28 02:54:28 BST 2005: [ function_upgrade() ] - => Upgrading gtk+2-2.6.4-i486-1 to gtk+2-2.6.7-i486-1... DONE!
Thu Apr 28 02:54:47 BST 2005: [ function_upgrade() ] - => Upgrading kdebase-3.4.0-i486-1 to kdebase-3.4.0-i486-2... DONE!
Thu Apr 28 02:55:02 BST 2005: [ function_upgrade() ] - => Upgrading kdepim-3.4.0-i486-1 to kdepim-3.4.0-i486-2... DONE!
Thu Apr 28 02:55:08 BST 2005: [ function_upgrade() ] - => Upgrading libxml2-2.6.18-i486-1 to libxml2-2.6.19-i486-1... DONE!
Thu Apr 28 02:55:11 BST 2005: [ function_upgrade() ] - => Upgrading libxslt-1.1.13-i486-1 to libxslt-1.1.14-i486-1... DONE!
Thu Apr 28 02:55:41 BST 2005: [ function_upgrade() ] - => Upgrading mozilla-1.7.6-i486-1 to mozilla-1.7.7-i486-1... DONE!
Thu Apr 28 02:55:58 BST 2005: [ function_upgrade() ] - => Upgrading python-2.4-i486-1 to python-2.4.1-i486-1... DONE!
Thu Apr 28 02:56:02 BST 2005: [ function_upgrade() ] - => Upgrading python-demo-2.4-noarch-1 to python-demo-2.4.1-noarch-1... DONE!
Thu Apr 28 02:56:06 BST 2005: [ function_upgrade() ] - => Upgrading python-tools-2.4-noarch-1 to python-tools-2.4.1-noarch-1... DONE!
Thu Apr 28 02:56:12 BST 2005: [ function_upgrade() ] - => Upgrading xscreensaver-4.21-i486-1 to xscreensaver-4.21-i486-2... DONE!
Thu Apr 28 02:56:13 BST 2005: [ function_upgrade() ] - INFORMATION: Set DEPENDENCY to 0 in /etc/swaret.conf
             to disable Dependency Support.
Thu Apr 28 02:56:21 BST 2005: [ dependency_check() ] - %%% Verifying Dependencies... Libraries resolved successfully!
Thu Apr 28 11:53:09 BST 2005: [ GLOBAL ] - swaret --update
Thu Apr 28 11:53:09 BST 2005: [ update_lists() ] - [ ftp://ftp.nluug.nl/pub/os/Linux/dist...ckware-current ]
Thu Apr 28 11:53:13 BST 2005: [ update_lists() ] - ### Fetching CHECKSUMS List File... DONE!
Thu Apr 28 11:53:13 BST 2005: [ update_lists() ] - FILELIST List File is up-to-date!
Thu Apr 28 11:53:13 BST 2005: [ update_lists() ] - Packages Descriptions up-to-date!
Thu Apr 28 11:53:13 BST 2005: [ update_lists() ] - Extra Packages Descriptions up-to-date!
Thu Apr 28 11:53:13 BST 2005: [ update_lists() ] - ChangeLog up-to-date!
Thu Apr 28 11:53:14 BST 2005: [ GLOBAL ] - swaret --upgrade -a
Thu Apr 28 11:53:34 BST 2005: [ function_upgrade() ] - Installed Packages are up-to-date!
Any help will be much appreciated!

The system has now been restarted twice (with 30s power off) just in case it was some kind of screwy one-off failure, but it's consistent!

EDIT:

Further info: Starting kmail from the command line yields the following:
Code:
iain@iains:~$ kmail
iain@iains:~$ kmail: ERROR: : couldn't create slave : Unable to create io-slave:
klauncher said: Error loading 'kio_pop3'.
kmail:
kmail: ERROR: : couldn't create slave : Unable to create io-slave:
klauncher said: Error loading 'kio_pop3'.
kmail:
Where each error message appeared as I tried to download mail from a different POP3 account.

FURTHER EDIT: & Temporary Workaround

doing:

/var/swaret$ removepkg kdebase-3.4.0-i486-2.tgz
/var/swaret$ removepkg kdepim-3.4.0-i486-2.tgz
/var/swaret$ reboot
[boot sequence...]
/var/swaret$ installpkg kdebase-3.4.0-i486-1.tgz
/var/swaret$ installpkg kdepim-3.4.0-i486-1.tgz
/var/swaret$ reboot
[boot sequence...]

has got me back to the point where kmail functions as expected, however, removing the i486-1 packages and reinstalling the i486-2 packages gives the same symptoms again.

So for anyone having this problem I'd recommend (for now) to exclude kdepim and kdebase in swaret.conf and do the removal of the new packages and reinstall of the old ones as shown above.

This should keep you able to download mail at least while someone smarter than me works out a "proper" solution!

HTH



Last edited by resaguk; 04-28-2005 at 09:08 AM.
 
Old 04-28-2005, 04:59 PM   #2
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Salix and Porteus
Posts: 544

Rep: Reputation: 43
I had the same problem and as well as another which may or may not be upgrade to current related.

I remembered aversion or two back that some people had trouble with kde upgrade from current directory that I did not have since I had used the newest unofficial kde slackpacks from a kde mirror.

I have checked out the README in the slackware kde-3.4 directory on a mirror and here's what it has to say:

<snip>
Unofficial Slackware-10.1 packages

ChangeLog 2005-04-12:
Recompiled the cyrus-sasl package to fix the kio_smtp authentication problem.

The kdepim-fix-imap-resource-type.diff patch is included in this kdepim.

You must install the cyrus-sasl package for Kmail/Kontact

Theses packages seems to work also on slackware -current (2005/03/10)

If you have any problems with installing this release, please send an e-mail to
Jean-Christophe Fargette : kde@fargette.com
<snipped>

This may or may not provide an explanation for the pop3 problem but I'll find out once my download of the unofficial kde-3.4 slackpacks is completed
 
Old 04-28-2005, 05:27 PM   #3
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 15
Well done justwantin!

It appears that you are the person I needed to be "smarter than me"! Installing cyrus-sasl from linuxpackages.net seems to have fixed everything. So I am now running the i486-2 packages for kdebase and kdepim.

Thanks!
 
Old 04-28-2005, 06:18 PM   #4
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Salix and Porteus
Posts: 544

Rep: Reputation: 43
I did my upgrade with slapt-get yesterday. Cyrus-sasl was listed in the changelog 21 April entry either it didn't get installed maybe it did but its not working right.

I'll have to check.
 
Old 04-28-2005, 06:50 PM   #5
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Salix and Porteus
Posts: 544

Rep: Reputation: 43
I walked away and as soon as I did figured it out, at least for me.

cyrus-sasl was an "added" package so as such it would not be "upgraded" since it was not part of slack-10.1

I'll have to pay closer attention.
 
Old 05-04-2005, 12:19 PM   #6
h8r
Member
 
Registered: Jan 2003
Posts: 49

Rep: Reputation: 15
god bless!

God bless swaret
Code:
root@h8r:~# swaret --install cyrus-sasl
swaret 1.6.2-1

Listing available Packages matching Keyword: cyrus-sasl...
cyrus-sasl-2.1.20-i486-1 (502 kB)

Install cyrus-sasl-2.1.20-i486-1? (y/n/A/Q): [y]y
[ ftp://ssi.bg/mirrors/slackware-current/ ]
### Fetching cyrus-sasl-2.1.20-i486-1 (502 kB)...
--- 502 kB/502 kB [TOTAL: 485 kB/502 kB] ~ 0 kB/s DONE!
=> <MD5CHECK> MD5 for Package cyrus-sasl-2.1.20-i486-1 OK!
=> Installing cyrus-sasl-2.1.20-i486-1... DONE!

INFORMATION: Set DEPENDENCY to 0 in /etc/swaret.conf
             to disable Dependency Support.

%%% Verifying Dependencies... Libraries resolved successfully!
and god bless open source
 
Old 05-07-2005, 06:18 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,281

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
I had a related problem when trying to send mail using Kmail after updating to KDE 3.4.0, where Kmail reported that support for authentication was not compiled in. As stated above, the fix is to upgrade kdebase using the kdebase-3.4.0-i486-2.tgz package and to install the Cyrus SASL library in cyrus-sasl-2.1.20-i486-1.tgz

From the ChangeLog

Thu Apr 21 14:26:29 PDT 2005
...
kde/kdebase-3.4.0-i486-2.tgz: Recompiled to link with Cyrus SASL.
kde/kdepim-3.4.0-i486-2.tgz: Recompiled to link with Cyrus SASL.
....
n/cyrus-sasl-2.1.20-i486-1.tgz: Added Cyrus SASL library (for Kmail).
 
Old 07-18-2005, 02:42 PM   #8
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Rep: Reputation: 90
OK,
I suddenly got this exact error, and used the same process to sort it out for no other reason then installing Kubuntu onto my second drive. (/dev/hdb)
So why, after an age using kmail with no problems should installing kubuntu on /dev/hdb cause problems in Slack which is on /dev/hda.
The only time Kubuntu touched my 1st drive was to install grub, so it must be something to do with this I assume. Any one any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
User "list" running process "python" TroelsSmit Linux - Newbie 2 02-22-2005 04:55 AM
Kmail Can't start process Pop3? Snump Linux - Software 0 11-05-2004 09:15 PM
How to start KDE automaticlly without typing "startx" then "startkde" Jonescity Slackware 8 10-29-2004 09:32 PM
Update process in 10.1 community : "update_source" problem Rnd227 Mandriva 5 10-27-2004 05:55 AM
"Could not start process - Can't talk to Klauncher" ?? Sean Murphy Linux - Newbie 3 10-21-2003 11:28 AM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration