LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-12-2008, 07:33 AM   #1
nix2ways
LQ Newbie
 
Registered: Sep 2006
Location: Huddersfield, UK
Distribution: Debian
Posts: 22

Rep: Reputation: 15
Kino-(kino:5747): Gtk-WARNING **: cannot open display: :0


I've installed Kino 0.9.5. When I try to open it I get (kino:5747): Gtk-WARNING **: cannot open display: :0
I've Googled and searched this forum. I assume I need to set a config file somewhere that tells GTK which display to use(?)
Any ideas which?
 
Old 05-12-2008, 07:51 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
Is there any special reason you choose 0.9.5? It has been released in January 2007 and there are newer versions. I have for example 1.3 running. I had not the time to test in on Slackware 12.1 yet but at least it starts OK
 
Old 05-12-2008, 10:51 AM   #3
nix2ways
LQ Newbie
 
Registered: Sep 2006
Location: Huddersfield, UK
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
I get the same error when I try to start either 1.3 or 0.9.5.
I tried 1.3 first then uninstalled that and tried 0.9.5.
 
Old 05-12-2008, 11:43 AM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
Sorry but I'm probably not much help here. I compiled kino and dependencies without problem and can start it without a problem too. Is there a chance that you are running a graphical login manager and try to start it from command line as user "root"?
 
Old 05-12-2008, 12:34 PM   #5
nix2ways
LQ Newbie
 
Registered: Sep 2006
Location: Huddersfield, UK
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks for your replies. That was the problem, it's always the simplest things that seem to cause the most trouble.
I just installed 1.3 from source again and now it loads ok.
However, I now have the following message under the IEEE 1394 tab in Preferences
The IEEE 1394 Subsystem is not responding
The raw1394 module must be loaded and you must have read and write access to /dev/raw1394

I remember this from when I was using Debian/Ubuntu a while ago but the remedy for that refers to a file that isn't present in Slackware, or has a different name.

Also when I do modprobe raw1394 I get
WARNING: Error inserting ieee1394 (/lib/modules/2.6.24.5-smp/kernel/drivers/ieee1394/ieee1394.ko): Invalid module format


I'm on unknown ground here and may well be doing something wrong.
Any further help would be appreciated as I'm that much closer to being able to use Kino in Slackware.

Last edited by nix2ways; 05-12-2008 at 12:35 PM.
 
Old 05-12-2008, 12:41 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,115

Rep: Reputation: Disabled
Something is wrong with your kernel modules package. When I try the modprobe I see this on a fresh Slackware 12.1:
Code:
# modprobe raw1394

# ls -l /dev/raw1394 
crw-rw---- 1 root video 171, 0 2008-05-12 19:38 /dev/raw1394

# lsmod |grep 1394
raw1394                27096  0 
ieee1394               82744  1 raw1394
Eric
 
Old 05-12-2008, 01:47 PM   #7
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
Quote:
Originally Posted by Alien Bob View Post
Something is wrong with your kernel modules package. When I try the modprobe I see this on a fresh Slackware 12.1:
Code:
# modprobe raw1394

# ls -l /dev/raw1394 
crw-rw---- 1 root video 171, 0 2008-05-12 19:38 /dev/raw1394

# lsmod |grep 1394
raw1394                27096  0 
ieee1394               82744  1 raw1394
Eric
And to make the maybe not obvious clear: Please note that you have to be a member of the group "video" to have read-write access as normal user!
 
Old 05-13-2008, 05:17 AM   #8
nix2ways
LQ Newbie
 
Registered: Sep 2006
Location: Huddersfield, UK
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks Eric, I was wondering whether it was something like that. I upgraded from 12.0 to 12.1. I didn't experience any problems with the upgrade. I followed the procedure from the Slackware website and everything went ok.
Could the upgrade be the cause? If so, is there anything I can do about it? Here's what I get when I duplicate your output:

# modprobe raw1394
WARNING: Error inserting ieee1394 (/lib/modules/2.6.24.5-smp/kernel/drivers/ieee1394/ieee1394.ko): Invalid module format

# ls -1 /dev/raw1394
/dev/raw1394

# lsmod |grep 1394
raw1394 27096 0

Alien Bob, thanks, I have made sure I'm a member of the video group.

Last edited by nix2ways; 05-13-2008 at 05:18 AM.
 
Old 05-13-2008, 05:27 AM   #9
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
Quote:
Originally Posted by nix2ways View Post
Thanks Eric, I was wondering whether it was something like that. I upgraded from 12.0 to 12.1. I didn't experience any problems with the upgrade. I followed the procedure from the Slackware website and everything went ok.
Could the upgrade be the cause? If so, is there anything I can do about it? Here's what I get when I duplicate your output:

# modprobe raw1394
WARNING: Error inserting ieee1394 (/lib/modules/2.6.24.5-smp/kernel/drivers/ieee1394/ieee1394.ko): Invalid module format

# ls -1 /dev/raw1394
/dev/raw1394

# lsmod |grep 1394
raw1394 27096 0

Alien Bob, thanks, I have made sure I'm a member of the video group.
What kernel are you running? The non-smp version maybe?
 
Old 05-13-2008, 08:16 AM   #10
JustInterested
Member
 
Registered: Jul 2005
Posts: 38

Rep: Reputation: 15
Smile

Hi... Just thought I'd chime in here as I too am getting that same errors when I try to load the 1394 modules.

My scenario: Fresh install of 12.1, followed by fresh install of latest GnomeSlackBuild for SW12.1 (which includes Kino 1.3 in its installation).

Would dearly love to get to the bottom of this as I like Slack and I need Kino/dvgrab!

If there's any more info I can provide just let me know.

cheers

Edit: Kernel info...
bash-3.1$ uname -a
Linux Slack12 2.6.24.5-smp #2 SMP Wed Apr 30 13:41:38 CDT 2008 i686 Intel(R) Core(TM)2 Duo CPU E4600 @ 2.40GHz GenuineIntel GNU/Linux

Last edited by JustInterested; 05-13-2008 at 08:18 AM. Reason: added more info
 
Old 05-13-2008, 09:33 AM   #11
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
Do you only get an error message or is dvgrab really not working properly? I'm not sure what happens if you have the "huge" kernel installed and try to modprobe an included module. So maybe you get an error but it's already working???
Cave: I haven't tested dvgrab on my new setup because work is eating all my time I hope to have some spare time tomorrow to test it.

If I were you and if the problem persisted I would just recompile the kernel (with the config file for Pat's "generic-smp" kernel) and create a new initrd.gz file if needed. This resolved any similar problems for me in the past.
 
Old 05-13-2008, 11:34 AM   #12
nix2ways
LQ Newbie
 
Registered: Sep 2006
Location: Huddersfield, UK
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by titopoquito View Post
What kernel are you running? The non-smp version maybe?
$ uname -r
2.6.24.5-smp

Looks ok(?)
 
Old 05-13-2008, 12:10 PM   #13
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,510

Rep: Reputation: 87
I'm not sure if you can tell from this output if you are running the generic or huge kernel image, but doubt it. I would rather take a look in /boot and respectively your lilo.conf. If you have referenced "vmlinuz" as kernel, where is /boot/vmlinuz linked to?
 
Old 05-13-2008, 12:46 PM   #14
nix2ways
LQ Newbie
 
Registered: Sep 2006
Location: Huddersfield, UK
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by titopoquito View Post
I'm not sure if you can tell from this output if you are running the generic or huge kernel image, but doubt it. I would rather take a look in /boot and respectively your lilo.conf. If you have referenced "vmlinuz" as kernel, where is /boot/vmlinuz linked to?
lilo.conf:

image="/boot/vmlinuz"
root="/dev/hda1"
label="Slackware"

/boot/vmlinuz linked to vmlinuz-huge-smp-2.6.24.5-smp

Last edited by nix2ways; 05-13-2008 at 12:47 PM.
 
Old 05-13-2008, 01:56 PM   #15
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
The IEEE1394 module is compiled into the kernel in the huge-smp kernel, and compiled as a module in the generic-smp kernel. This is probably your problem. You should switch to the generic kernel. Please don't ask how, try searching -- it's been explained several thousand times in these forums. It is recommended that you use the generic-smp kernel instead of the huge-smp kernel in the official documentation that came with your Slackware installation/upgrade:
Quote:
Originally Posted by CHANGES_AND_HINTS.TXT
Use one of the provided generic kernels for daily use. Do not report
bugs until/unless you have reproduced them using one of the stock
generic kernels. You will need to create an initrd in order to boot
the generic kernels - see /boot/README.initrd for instructions.
Quote:
Originally Posted by CHANGES_AND_HINTS.TXT
As stated earlier, it is recommended that you use one of the generic kernels
rather than the huge kernels; the huge kernels are primarily intended as
"installer" and "emergency" kernels in case you forget to make an initrd.
For most systems, you should use the generic SMP kernel if it will run,
even if your system is not SMP-capable. Some newer hardware needs the
local APIC enabled in the SMP kernel, and theoretically there should not be
a performance penalty with using the SMP-capable kernel on a uniprocessor
machine, as the SMP kernel tests for this and makes necessary adjustments.
Furthermore, the kernel sources shipped with Slackware are configured for
SMP usage, so you won't have to modify those to build external modules
(such as NVidia or ATI proprietary drivers) if you use the SMP kernel.

If you decide to use one of the non-SMP kernels, you will need to follow the
instructions in /extra/linux-2.6.24.5-nosmp-sdk/README.TXT to modify your
kernel sources for non-SMP usage. Note that this only applies if you are
using the Slackware-provided non-SMP kernel - if you build a custom kernel,
the symlinks at /lib/modules/$(uname -r)/{build,source} will point to the
correct kernel source so long as you don't (re)move it.

If you decide to use one of the huge kernels anyway, you will encounter
errors like this:
kobject_add failed for uhci_hcd with -EEXIST, don't try to register
These occur because the respective drivers are compiled statically into the
huge kernels but udev tries to load them anyway. These errors should be safe
to ignore, but if you really don't want them to appear, you can blacklist the
modules that try to load in /etc/modprobe.d/blacklist. However, make sure you
remove them from the blacklist if you ever decide to use the (recommended)
generic kernels.
If you want to be complicated, you could blacklist the IEEE1394 module in /etc/modprobe.d/blacklist and then you should be able to successfully modprobe raw1394 -- but this isn't the best way to do it (the best way to avoid this and future kernel problems would be to switch to the generic-smp kernel).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk warning cannot open display bosewicht Linux - Newbie 2 03-10-2010 07:53 PM
Gtk-WARNING **: cannot open display: intelectro Linux - Software 2 05-08-2007 09:46 PM
Cinelerra, Kino, won't open Rockgod1969 Linux - Software 4 02-02-2007 03:03 AM
compiling kino, gtk test program cant run vance Linux - Software 1 06-02-2003 04:36 AM
Kino gtk problem jason955 Linux - Software 0 02-24-2003 09:17 PM


All times are GMT -5. The time now is 07:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration