LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-03-2005, 04:30 PM   #1
Oholiab
Member
 
Registered: Feb 2005
Location: UK
Distribution: Slackware 10.1
Posts: 165

Rep: Reputation: 30
Keyboard problems on dropline gnome on 10.1


I managed to reconfigure both of the files I needed for correct keyboard layout (uk), these being xorg and rc.keymap, and I managed to get the uk keymap working in the console, but when I started up Gnome, it came up with a dialogue box which asked whether I wanted the X settings for the keymap or the Gnome ones... So I chose X and it flooded me with error messages!

Also, just in case anyone can answer this too, my PCM volume resets every time I boot up... its a pain always resetting, so how do I get it to stick?
 
Old 03-03-2005, 11:36 PM   #2
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
I guess you've figured out by now that you should've picked the GNOME keyboard settings instead of X . I had this same thing happen to me but I picked GNOME no problems. You *might* want to check your keyboard settings using the Applications --> Desktop Preferences --> Keyboard applett and make sure that your keyboard is selected under the Layouts tab. Then log out of X and back in. If you get the message about picking which settings for your keyboard you know which one to pick this time . If that doesn't do the trick then you might want to head over to the Dropline Forums and post about your situation there. The folks at DLG have always been very helpful to me and they have more specific knowledge of DLG and it's innerworkings.

As far as the PCM sound thing, after you used alsamixer to set your volumes did you save them using the command:
Code:
alsactl store
If so, make sure you have the file rc.alsa in /etc/rc.d. If it's there, make sure it is set to execute at startup by doing:
Code:
ls -l /etc/rc.d/rc.alsa
The first part of the output (-rxw's) should look EXACTLY like this,
Code:
-rwxr-xr-x  1 root root  1514 2005-01-14 00:17 rc.alsa*
The rest of the output may vary some.

HTH,
MMYoung

Last edited by MMYoung; 03-03-2005 at 11:38 PM.
 
Old 03-04-2005, 12:06 PM   #3
Oholiab
Member
 
Registered: Feb 2005
Location: UK
Distribution: Slackware 10.1
Posts: 165

Original Poster
Rep: Reputation: 30
My Gnome keyboard applet won't open, and bash can't find the command alsactl!
Although I've been reconfiguring the sound under the OSS mixer tab (PCM as the sound was distorting) rather than ALSA

Last edited by Oholiab; 03-04-2005 at 12:15 PM.
 
Old 03-04-2005, 01:03 PM   #4
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
Quote:
Originally posted by Oholiab
My Gnome keyboard applet won't open
Sorry, just noticed that you are using 10.1. The "non-opening" keyboard applet is a "known bug" with Dropline Gnome 2.8.x and Slackware 10.1. It is due to the version of glibc that DLG was compiled with (Slackware 10.0), versus a newer version of glibc in in Slackware 10.1. You may want to check out some of the threads on their Forum Board to see what I'm talking about. Funny thing is I was initially hit with this "bug" but I found I had either a bad burn or a bad CD1 ISO download. I re-downloaded the CD1 ISO, re-burned it, and re-installed (formatting rather than "upgrading") and now my keyboard applet works just fine. The next version of DLG, 2.8.10, should be release in a few weeks and it will be compiled/tested on Slackware 10.1 so most of those type anomolies should be gone when it comes out. We'll have all NEW anomolies to report on .
Quote:
Originally posted by Oholiab
and bash can't find the command alsactl!
alsactl (alsa control) is actually part of the alsa-utils package, which is installed with Dropline Gnome (ver 1.0.8-i686-1dl), so it *should* be in /sbin. You are setting your mixer settings (alsamixer) either from a text login or from a terminal logged in as root? In order for the mixer settings to "stay put" you will need to set them as root and then use alsactl store, again as root. Reason I ask is I don't think /sbin is in the "users" path, whereas it is in "roots" path. Again, just wondering.

HTH,
MMYoung
 
Old 03-04-2005, 02:00 PM   #5
Oholiab
Member
 
Registered: Feb 2005
Location: UK
Distribution: Slackware 10.1
Posts: 165

Original Poster
Rep: Reputation: 30
I've just realised that my keyboard is working as I want it too... Which is strange because it didn't work last time I booted... I'll get back to you on my PCM levels next time I boot.
 
Old 03-05-2005, 07:44 AM   #6
Oholiab
Member
 
Registered: Feb 2005
Location: UK
Distribution: Slackware 10.1
Posts: 165

Original Poster
Rep: Reputation: 30
The PCM levels are sorted... no more resetting the volume... I'm still getting error messages because of the keyboard setup though... I'll give you details next time I boot up, but at least its not affecting anything!
 
Old 03-06-2005, 07:31 AM   #7
Oholiab
Member
 
Registered: Feb 2005
Location: UK
Distribution: Slackware 10.1
Posts: 165

Original Poster
Rep: Reputation: 30
Quote:
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60801000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
xprop -root | grep XKB:
Quote:
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc102", "uk", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc102", "uk", "", ""
gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb:
Quote:
layouts = [uk]
model = pc102
overrideSettings = false
options = []
update_handlers = []
 
Old 03-06-2005, 09:56 AM   #8
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
Quote:
Originally posted by Oholiab
xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc102", "uk", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc102", "uk", "", ""
Is that correct for your setup? Here is the output of the same command for me.
Code:
mmyoung@darkstar:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "microsoft", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "microsoftpro", "us", "", ""
I set the microsoftpro using the keyboard applet in DLG.
Quote:
Originally posted by Oholiab
xprop -root | grep XKB
layouts = [uk]
model = pc102
overrideSettings = false
options = []
update_handlers = []
Here is the same output from my PC.
Code:
mmyoung@darkstar:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
layouts = [us]
model = microsoftpro
overrideSettings = false
options = []
update_handlers = []
So the information from each (yours and mine) are identical, except for the different keyboards and locale. That being said, are you still getting errors? If so are they keeping you from using your keyboard as you would normally use it?

Later,
MMYoung
 
Old 03-06-2005, 09:56 AM   #9
ve2mrj
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Rep: Reputation: 1
For those of you having problem with the keyboard
applet under gnome, here is a way to make it work.

cd /usr/X11R6/lib/X11/xkb/symbols/pc
ln -s ../* .

That's do the trick... You may see some error messages
when you do the ln, but this is not important.

Another method is the following:

cd /etc/X11
vi xorg.conf

Changed or add the line:

Section "InputDevice"
.
.
.
Option "XkbDisable" "yes"

EndSection

Note: The first method is the best.

Richard
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XFCE4 and Dropline Gnome problems Gillibiabtiag Linux - Newbie 2 09-16-2004 07:19 PM
Dropline gnome and included gnome linda Slackware 1 09-01-2004 02:39 PM
What is the difference between Gnome and Dropline Gnome mikieboy Linux - Software 7 07-29-2004 12:52 PM
Keyboard problem on Dropline Gnome hydorn Slackware 7 04-29-2004 10:05 AM
Gnome Keyboard/Modem Problems with SuSE 9.0 gonniff Linux - Distributions 0 01-06-2004 08:32 AM


All times are GMT -5. The time now is 08:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration