LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2003, 12:18 PM   #1
Gregorius
LQ Newbie
 
Registered: May 2003
Location: Belgium
Distribution: Slackware
Posts: 3

Rep: Reputation: Disabled
Keyboard problems in KDE


Sorry to post this here, as this is not really a purely Slack-related question, but maybe others have had to deal with it as well.

I've just installed Slackware 9 and it worked out of the box. However, my keyboard doesn't get mapped correctly under KDE. More specifically, the problem concerns the key to the left of my 'w'-key (with the symbols < > \). I've tried selecting other keyboard layouts in the KDE keyboard setup (in the control center), but that doesn't work.

I then used "xmodmap -pke" on my other computer (with Slack 8.1, where everything works normally) to generate a correct keymap, which I then transferred to Slack 9. Importing this keymap solves the problem, but apparently changes the meaning of the <ctrl>+<alt>+<Fn> keys (the keys that switch virtual terminal).

The problems I had seem to be specific to KDE: I've had some of them in Gnome, but I was able to fix it. Under KDE, I can't. So I hope you can help me (otherwise Slack 9 looks really great!)
 
Old 05-26-2003, 02:19 AM   #2
dcm
LQ Newbie
 
Registered: May 2003
Posts: 17

Rep: Reputation: 0
Have you set keyboard layout?

Control panel > Regional & Accessibility > Keyboard Layouts

I think you can solve your problem here
 
Old 05-26-2003, 11:36 AM   #3
Gregorius
LQ Newbie
 
Registered: May 2003
Location: Belgium
Distribution: Slackware
Posts: 3

Original Poster
Rep: Reputation: Disabled
Well, I did that, but to no avail. All keys are mapped correctly, except for that one. I even selected different keyboards, or different countries, but still nothing.

For now I've made a temporary fix by composing my own keytable which I then load with xmodmap, but this is far from elegant. I wonder what causes my problem...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major problems with the keyboard! Microsoft keyboard is not compatable?. aweir14150 Mandriva 2 05-26-2006 06:57 AM
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
KDE Keyboard Problems AlgebraicSpore Linux - Software 1 08-19-2005 01:19 PM
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker Suse/Novell 1 02-13-2005 08:01 PM
keyboard problems with xfce4 - general keyboard question Villain Linux - General 2 06-20-2004 04:35 PM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration