LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-20-2010, 05:24 PM   #1
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Rep: Reputation: 2
Keyboard only works in Kde and Xfce, not other wm


Hi,

I've been using Xfce for some time now, but I'd like to return to fluxbox or trying fwm.

The problem is that the keyboard only works in Xfce or in Kde, in my system Slackware64 13.1.

What should I do to have it working in all window managers that come along the distribution?


Luis
 
Old 09-20-2010, 09:27 PM   #2
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,441

Rep: Reputation: 409Reputation: 409Reputation: 409Reputation: 409Reputation: 409
What are the contents of your /etc/X11/xorg.conf file?
 
Old 09-21-2010, 09:13 AM   #3
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Original Poster
Rep: Reputation: 2
Regarding the keyboard, they are:
Section "InputDevice"
Identifier "Keyboard0"
#Driver "kbd"
Driver "evdev"
Option "XkbModel" "pc105"
Option "XkbLayout" "pt"
EndSection
 
Old 09-23-2010, 04:31 PM   #4
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Original Poster
Rep: Reputation: 2
No ideas on this problem?
 
Old 09-23-2010, 10:08 PM   #5
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,441

Rep: Reputation: 409Reputation: 409Reputation: 409Reputation: 409Reputation: 409
Sorry, I had thought that I had responded earlier. (Obviously, I didn't.)

The keyboard is provided by X, so the other window managers should just work. Have you tried running X with no xorg.conf file at all? If you try that, you can examine your /var/log/Xorg.0.conf file to see what type of keyboard your system thinks that it has. Mine, for example, looks like...

Code:
(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event7"
(II) USB Multimedia Keyboard: Found 1 mouse buttons
(II) USB Multimedia Keyboard: Found scroll wheel(s)
(II) USB Multimedia Keyboard: Found relative axes
(II) USB Multimedia Keyboard: Found absolute axes
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as mouse
(II) USB Multimedia Keyboard: Configuring as keyboard
(**) USB Multimedia Keyboard: YAxisMapping: buttons 4 and 5
(**) USB Multimedia Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(EE) USB Multimedia Keyboard: failed to initialize for relative axes.
(**) USB Multimedia Keyboard: (accel) keeping acceleration scheme 1
(**) USB Multimedia Keyboard: (accel) acceleration profile 0
(II) USB Multimedia Keyboard: initialized for absolute axes.
(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event6"
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
...so maybe we can see what X is reporting when it comes up.
 
Old 09-24-2010, 04:24 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I would try deleting xorg.conf, with 13.1 you don't usually need one.
 
Old 09-24-2010, 05:40 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,325

Rep: Reputation: 882Reputation: 882Reputation: 882Reputation: 882Reputation: 882Reputation: 882Reputation: 882
failing the advice above. Xorg in 13.1 uses hal for input device hot-plugging. I never liked that approach and you can disable it in xorg.conf.

Here's a an example of doing it the old-fashioned way:
Code:
# **********************************************************************
# Server flags section.
# **********************************************************************
Section "ServerFlags"
        Option         "AllowEmptyInput" "false"
        Option         "AutoAddDevices" "false"
        Option         "AutoEnableDevices" "false"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option       "XkbModel"  "chicony0420"
        Option       "XkbLayout"  "gb"
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
EndSection
 
Old 09-24-2010, 04:30 PM   #8
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Richard Cranium View Post
Sorry, I had thought that I had responded earlier. (Obviously, I didn't.)

The keyboard is provided by X, so the other window managers should just work. Have you tried running X with no xorg.conf file at all? If you try that, you can examine your /var/log/Xorg.0.conf file to see what type of keyboard your system thinks that it has. Mine, for example, looks like...

Code:
(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event7"
(II) USB Multimedia Keyboard: Found 1 mouse buttons
(II) USB Multimedia Keyboard: Found scroll wheel(s)
(II) USB Multimedia Keyboard: Found relative axes
(II) USB Multimedia Keyboard: Found absolute axes
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as mouse
(II) USB Multimedia Keyboard: Configuring as keyboard
(**) USB Multimedia Keyboard: YAxisMapping: buttons 4 and 5
(**) USB Multimedia Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(EE) USB Multimedia Keyboard: failed to initialize for relative axes.
(**) USB Multimedia Keyboard: (accel) keeping acceleration scheme 1
(**) USB Multimedia Keyboard: (accel) acceleration profile 0
(II) USB Multimedia Keyboard: initialized for absolute axes.
(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event6"
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
...so maybe we can see what X is reporting when it comes up.
The only error was regarding fbdev.
Although that option was not present in xorg.conf, X tried to load it.
I've read that 13.0 deprecated the use of fbdev.

Luis
 
Old 09-24-2010, 04:31 PM   #9
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by H_TeXMeX_H View Post
I would try deleting xorg.conf, with 13.1 you don't usually need one.
It also didn't solve this issue.
When I removed xorg.conf, X start with a lower resolution and keyboard was still not working.

Luis
 
Old 09-24-2010, 04:34 PM   #10
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by GazL View Post
failing the advice above. Xorg in 13.1 uses hal for input device hot-plugging. I never liked that approach and you can disable it in xorg.conf.

Here's a an example of doing it the old-fashioned way:
Code:
# **********************************************************************
# Server flags section.
# **********************************************************************
Section "ServerFlags"
        Option         "AllowEmptyInput" "false"
        Option         "AutoAddDevices" "false"
        Option         "AutoEnableDevices" "false"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option       "XkbModel"  "chicony0420"
        Option       "XkbLayout"  "gb"
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
EndSection
Thank you all for your help.
This tip saved my day, specially one of the lines of the section serverflags.
Now, the keyboard works in Fluxbox as well!

Luis
 
Old 09-25-2010, 12:34 AM   #11
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,441

Rep: Reputation: 409Reputation: 409Reputation: 409Reputation: 409Reputation: 409
Quote:
Originally Posted by lupe View Post
The only error was regarding fbdev.
Although that option was not present in xorg.conf, X tried to load it.
I've read that 13.0 deprecated the use of fbdev.

Luis
Well, I did not suggest that there was an error. I merely wanted to see what your system auto-discovered when you started X, after which we could find the minimum amount of stuff to add to your xorg.conf file.
 
Old 09-27-2010, 05:10 PM   #12
lupe
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 34

Original Poster
Rep: Reputation: 2
For someone that has the same problem as I did, here is the solution.

Well, as the scrolling controls of the mouse where not working, I tried to solve the problem in another way.

I removed xorg.conf from /etc/X11/ as suggested.
Afterwards, I started a X session with kde and opened the keyboard manager. There was a command performed by kde:
setxkbmap -model pc105 layout pt -variant

Then I included this line in my ~/.xinitrc file. (I just excluded the '-variant' option because there was no value for it.)
And now both the keyboard and mouse are working fine!


Luis
 
  


Reply

Tags
fluxbox, keyboard, xfce46


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
User Shutdown Works from XFCE but not from KDE - Slackware12.2 mitchellray Linux - Desktop 9 04-03-2009 08:33 PM
camera works on kde, but not on xfce? ninja master Linux - Software 14 12-29-2008 12:32 PM
API for X that works with KDE XFCE etc. binarybob0001 Programming 9 11-18-2006 04:52 AM
ACPI power off works with PS/2 keyboard but not with USB keyboard mrwaters Linux - Hardware 5 10-05-2006 05:06 PM
mouse freezing in KDE 3.5, keyboard still works x94qvi Linux - Software 4 01-22-2006 09:23 AM


All times are GMT -5. The time now is 12:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration