LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Keyboard only works in Kde and Xfce, not other wm (http://www.linuxquestions.org/questions/slackware-14/keyboard-only-works-in-kde-and-xfce-not-other-wm-833422/)

lupe 09-20-2010 05:24 PM

Keyboard only works in Kde and Xfce, not other wm
 
Hi,

I've been using Xfce for some time now, but I'd like to return to fluxbox or trying fwm.

The problem is that the keyboard only works in Xfce or in Kde, in my system Slackware64 13.1.

What should I do to have it working in all window managers that come along the distribution?


Luis

Richard Cranium 09-20-2010 09:27 PM

What are the contents of your /etc/X11/xorg.conf file?

lupe 09-21-2010 09:13 AM

Regarding the keyboard, they are:
Section "InputDevice"
Identifier "Keyboard0"
#Driver "kbd"
Driver "evdev"
Option "XkbModel" "pc105"
Option "XkbLayout" "pt"
EndSection

lupe 09-23-2010 04:31 PM

No ideas on this problem?

Richard Cranium 09-23-2010 10:08 PM

Sorry, I had thought that I had responded earlier. (Obviously, I didn't.)

The keyboard is provided by X, so the other window managers should just work. Have you tried running X with no xorg.conf file at all? If you try that, you can examine your /var/log/Xorg.0.conf file to see what type of keyboard your system thinks that it has. Mine, for example, looks like...

Code:

(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event7"
(II) USB Multimedia Keyboard: Found 1 mouse buttons
(II) USB Multimedia Keyboard: Found scroll wheel(s)
(II) USB Multimedia Keyboard: Found relative axes
(II) USB Multimedia Keyboard: Found absolute axes
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as mouse
(II) USB Multimedia Keyboard: Configuring as keyboard
(**) USB Multimedia Keyboard: YAxisMapping: buttons 4 and 5
(**) USB Multimedia Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(EE) USB Multimedia Keyboard: failed to initialize for relative axes.
(**) USB Multimedia Keyboard: (accel) keeping acceleration scheme 1
(**) USB Multimedia Keyboard: (accel) acceleration profile 0
(II) USB Multimedia Keyboard: initialized for absolute axes.
(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event6"
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"

...so maybe we can see what X is reporting when it comes up.

H_TeXMeX_H 09-24-2010 04:24 AM

I would try deleting xorg.conf, with 13.1 you don't usually need one.

GazL 09-24-2010 05:40 AM

failing the advice above. Xorg in 13.1 uses hal for input device hot-plugging. I never liked that approach and you can disable it in xorg.conf.

Here's a an example of doing it the old-fashioned way:
Code:

# **********************************************************************
# Server flags section.
# **********************************************************************
Section "ServerFlags"
        Option        "AllowEmptyInput" "false"
        Option        "AutoAddDevices" "false"
        Option        "AutoEnableDevices" "false"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "XkbModel"  "chicony0420"
        Option      "XkbLayout"  "gb"
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
EndSection


lupe 09-24-2010 04:30 PM

Quote:

Originally Posted by Richard Cranium (Post 4107269)
Sorry, I had thought that I had responded earlier. (Obviously, I didn't.)

The keyboard is provided by X, so the other window managers should just work. Have you tried running X with no xorg.conf file at all? If you try that, you can examine your /var/log/Xorg.0.conf file to see what type of keyboard your system thinks that it has. Mine, for example, looks like...

Code:

(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event7"
(II) USB Multimedia Keyboard: Found 1 mouse buttons
(II) USB Multimedia Keyboard: Found scroll wheel(s)
(II) USB Multimedia Keyboard: Found relative axes
(II) USB Multimedia Keyboard: Found absolute axes
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as mouse
(II) USB Multimedia Keyboard: Configuring as keyboard
(**) USB Multimedia Keyboard: YAxisMapping: buttons 4 and 5
(**) USB Multimedia Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(EE) USB Multimedia Keyboard: failed to initialize for relative axes.
(**) USB Multimedia Keyboard: (accel) keeping acceleration scheme 1
(**) USB Multimedia Keyboard: (accel) acceleration profile 0
(II) USB Multimedia Keyboard: initialized for absolute axes.
(II) config/hal: Adding input device USB Multimedia Keyboard
(**) USB Multimedia Keyboard: always reports core events
(**) USB Multimedia Keyboard: Device: "/dev/input/event6"
(II) USB Multimedia Keyboard: Found keys
(II) USB Multimedia Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "USB Multimedia Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"

...so maybe we can see what X is reporting when it comes up.

The only error was regarding fbdev.
Although that option was not present in xorg.conf, X tried to load it.
I've read that 13.0 deprecated the use of fbdev.

Luis

lupe 09-24-2010 04:31 PM

Quote:

Originally Posted by H_TeXMeX_H (Post 4107490)
I would try deleting xorg.conf, with 13.1 you don't usually need one.

It also didn't solve this issue.
When I removed xorg.conf, X start with a lower resolution and keyboard was still not working.

Luis

lupe 09-24-2010 04:34 PM

Quote:

Originally Posted by GazL (Post 4107535)
failing the advice above. Xorg in 13.1 uses hal for input device hot-plugging. I never liked that approach and you can disable it in xorg.conf.

Here's a an example of doing it the old-fashioned way:
Code:

# **********************************************************************
# Server flags section.
# **********************************************************************
Section "ServerFlags"
        Option        "AllowEmptyInput" "false"
        Option        "AutoAddDevices" "false"
        Option        "AutoEnableDevices" "false"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "XkbModel"  "chicony0420"
        Option      "XkbLayout"  "gb"
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
EndSection


Thank you all for your help.
This tip saved my day, specially one of the lines of the section serverflags.
Now, the keyboard works in Fluxbox as well!

Luis

Richard Cranium 09-25-2010 12:34 AM

Quote:

Originally Posted by lupe (Post 4108130)
The only error was regarding fbdev.
Although that option was not present in xorg.conf, X tried to load it.
I've read that 13.0 deprecated the use of fbdev.

Luis

Well, I did not suggest that there was an error. I merely wanted to see what your system auto-discovered when you started X, after which we could find the minimum amount of stuff to add to your xorg.conf file.

lupe 09-27-2010 05:10 PM

For someone that has the same problem as I did, here is the solution.

Well, as the scrolling controls of the mouse where not working, I tried to solve the problem in another way.

I removed xorg.conf from /etc/X11/ as suggested.
Afterwards, I started a X session with kde and opened the keyboard manager. There was a command performed by kde:
setxkbmap -model pc105 layout pt -variant

Then I included this line in my ~/.xinitrc file. (I just excluded the '-variant' option because there was no value for it.)
And now both the keyboard and mouse are working fine!


Luis


All times are GMT -5. The time now is 03:43 AM.