LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   keyboard map (http://www.linuxquestions.org/questions/slackware-14/keyboard-map-404141/)

neilcpp 01-16-2006 03:00 PM

keyboard map
 
I tried looking in the slackbook for the answer to this and i could not find this question aswered before. If it has been asked before, i am sorry and hope that the moderator will point me to the thread. but here goes...

Im running slackware 10.1, but there is something wrong with my keyboard. The right characters dont print out especially with the shift key:

shift+ the keys below give me this output-

1 = !
2 = @ (should be ")
3 = # (should be a uk pound sign)
4 = $
5 = %
6 = ^
7 = &
8 = *
9 = (
0 = )
- = _
= = +
; = :
' = " (should be @)
# when pressed alone gives \
with shift it gives | when it should be the squiggly line.

basically my keyboard is configured wrong and i cant use it effectively like this.

How can I change the settings to get the output that is printed on the actual keys?

My keyboard is a KB-0108. It also has a bunch of other 'power keys' on that i guess i have no chance of ever getting them to work :confused:

Tuttle 01-16-2006 03:16 PM

You need the "gb" keyboard map in your /etc/X11/xorg.conf Add it in the "InputDevice" section like this:
Code:

Section "InputDevice"

        Option    "XkbLayout"      "gb"

EndSection



All times are GMT -5. The time now is 06:39 PM.