LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   keyboard layout sw 13.0 (http://www.linuxquestions.org/questions/slackware-14/keyboard-layout-sw-13-0-a-751252/)

H_TeXMeX_H 08-30-2009 09:09 AM

keyboard layout sw 13.0
 
Just a note, because I use the dvorak keyboard layout and on sw 13.0 'xorgsetup' doesn't do anything.

As noted in changes and hints:

Quote:

If you need to use a non-US keyboard layout, then copy the file located at
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy
and edit it to suit your needs. Have a look at the contents of that file
for an example and more information.
http://slackware.mirrors.tds.net/pub..._AND_HINTS.TXT

So basically what I had to do was run this:

Code:

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy
nano /etc/hal/fdi/policy/10-keymap.fdi

For dvorak for example you change:

Code:

    <!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string" />

to

Code:

      <!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string">dvorak</merge>

And finally run:

Code:

/etc/rc.d/rc.hald restart
Then log back into xorg and everything should work.

Bruce Hill 08-31-2009 02:15 AM

yo ... no more zero replies

mpregos 09-24-2009 03:18 PM

So i have the following 10-keymap.fdi file for my Greek language:
Code:

<!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string">gr</merge>

I restart the hal deamon .

How i change to greek??????

cendryon 09-24-2009 04:11 PM

Hi

For a non-US keyboard, you replace the layout key.
Mine is french :
Code:

<!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string"/>

If you have a previous xorg.conf, just input XkbLayout in the layout key, and XkbVariant in the variant key.

mpregos 09-26-2009 02:37 AM

OK Done ...Thanks cendryon...:D:D:D:D:D

I add greek language and with alt-shift buttons change the layout.

Here is my 10-keymap.fdi file, as a reference:

Code:

<!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us,el</merge>
      <merge key="input.xkb.options" type="string">grp:alt_shift_toggle,grp_led:scroll,compose:menu</merge>
      <merge key="input.xkb.variant" type="string" />


mpregos 09-26-2009 02:38 AM

OK Done ...Thanks cendryon...:D:D:D:D:D

I add greek language and with alt-shift buttons change the layout.

Here is my 10-keymap.fdi file, as a reference:

Code:

<!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us,el</merge>
      <merge key="input.xkb.options" type="string">grp:alt_shift_toggle,grp_led:scroll,compose:menu</merge>
      <merge key="input.xkb.variant" type="string" />


gefst 10-05-2009 03:39 PM

Building on Mpregos solution regarding Greek, you can change the last line as follows in order to be able to type the euro symbo using altgr and e:

<merge key="input.xkb.variant" type="string">,extended</merge>

For more information on the various options see here [in Greek]
http://members.hellug.gr/djart/grlinux-3.html

mpregos 08-11-2011 12:01 PM

Update

Add keyboard layout in Slack 13.37....In this example i use my lang -> Greek:

Hal daemon is history....At least ,about hotplugging . So, now if you want to modify - add a layout in your keyboard you should do the following:
From CHANGES_AND_HINTS.TXT
Quote:

The version of Xorg in Slackware 13.37 will not (in most cases) require an
/etc/X11/xorg.conf file. Input hotplugging is no longer done using hal;
instead, it now uses udev for input device detection and keyboard mapping.

/usr/share/X11/xorg.conf.d/ is the "packaged" configuration directory; all
files ending with ".conf" in this directory are used by the X server
unless there is an identically-named file in the local sysadmin directory.
The local sysadmin config directory is /etc/X11/xorg.conf.d/ - all files
ending with ".conf" in this directory are parsed.
Code:

cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d/

pico /etc/X11/xorg.conf.d/90-keyboard-layout.conf

Mine 90-keyboard-layout.conf looks like this,with Euro symbol enabled .... Modify according your needs

Quote:

Section "InputClass"
Identifier "keyboard-all"
MatchIsKeyboard "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
Option "XkbLayout" "us,el"
Option "XkbVariant" "basic,extended"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:menu"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


H_TeXMeX_H 08-11-2011 01:15 PM

Yeah, you should always check CHANGES_AND_HINTS.TXT. It will say what needs to be done.


All times are GMT -5. The time now is 01:47 AM.