LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-01-2009, 07:52 AM   #1
debaser4
LQ Newbie
 
Registered: Sep 2009
Location: Northampton, UK
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
Question Keyboard layout in Slackware 13


Hi everyone

This is my first post here so don't burn me too bad!

I've been using linux for about 2 years but have only recently moved to Slack to try and find out how it actually works under the bonnet and get better with the CLI.

I've managed to sort out a whole host of stuff already including basic package management, rc files and wireless networking.

One thing I am struggling to understand however is the keyboard mapping and how this is passed to the GUI's. I understand this is no longer handled by xorg.conf but by the hal.

I setup qwerty-uk from a clean install and in the console everything if fine. However XFCE and KDE both by default still think I've got a US keyboard. I can of course manually set the regional/keyboard settings in these GUI's but I'd like to understand why this isn't working.

The release changes and hints text says:
'If you need to use a non-US keyboard layout, then copy the file located at /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policyand edit it to suit your needs. Have a look at the contents of that file for an example and more information'

I tried this and this didn't seem to have any impact on what the GUI though the keyboard language arrangement on starting x?!

So specifically my 2 questions are:

When I set the keyboard as UK from the slack install where is this setting stored?
Why are KDE/ XFCE not being passed this setting, would this normally happen?

Hope this doesn't sound toooo noobish!


Refs

http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT

http://www.linuxquestions.org/questi...e-13.0-751300/

http://strangeworlds.co.uk/2009/06/1...hout-xorgconf/
 
Old 09-01-2009, 08:04 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,044
Blog Entries: 52

Rep: Reputation: Disabled
For KDE, look amongst System Settings from the main menu, keyboard layout is there somewhere (I'm on 12.2 at the moment so can't check properly).
 
Old 09-01-2009, 10:19 AM   #3
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 250

Rep: Reputation: 66
Quote:
Originally Posted by brianL View Post
For KDE, look amongst System Settings from the main menu, keyboard layout is there somewhere (I'm on 12.2 at the moment so can't check properly).
Brian, I think what the OP is getting at, is shouldn't the DE reflect what HAL is using? So if he sets up the fdi for HAL to use the UK version of a keyboard, shouldn't the DE automatically pick up on that and change accordingly, or should it be set in each individual DE (which seems pointless to me if HAL is already detecting it properly)?
 
Old 09-01-2009, 11:04 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
There are two different places for setting the keyboard layout, one for the console, which is set by the slackware installer, it is stored in '/etc/rc.d/rc.keymap', for example mine is:

Code:
#!/bin/sh
# Load the keyboard map.  More maps are in /usr/share/kbd/keymaps.
if [ -x /usr/bin/loadkeys ]; then
 /usr/bin/loadkeys dvorak.map
fi
this however ONLY affects the console ... i.e. during the installer and before starting xorg.

The second place is not really stored unless you follow what it says in changes and hints or what I wrote here:
http://www.linuxquestions.org/questi...w-13.0-751252/
That one applies to xorg and terminals open from it.

As for the GUI programs ... which ones are those ? I don't use KDE, so I'm not sure how to test to see if it sees dvorak (what I use) properly.
 
Old 09-01-2009, 11:15 AM   #5
debaser4
LQ Newbie
 
Registered: Sep 2009
Location: Northampton, UK
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Cheers for the replies. What no flames?!

Yes, bassmadrigals explanation is exactly what I'm driving at.

The console is storing the UK keyboard layout I selected at install somewhere - I just need someone to point me where.

The presence or not of a custom 10-keymap.fdi at /etc/hal/fdi/policy doesn't seem affect the DE keyboard settings (yes I restarted daemon and DE). Unless I'm doing something wrong I'm failing to grasp the point of it.

I will keep on reading around in the meantime. I pray for slackbook 3!
 
Old 09-01-2009, 11:54 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,044
Blog Entries: 52

Rep: Reputation: Disabled
Yes, you're right, bassmadrigal. I really must start reading questions properly.
 
Old 09-01-2009, 12:38 PM   #7
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 250

Rep: Reputation: 66
Meh... we are all guilty of it at some point. Or somehow missing something that was easy to find on google or not reading it in the manual/faq.
 
Old 09-01-2009, 12:54 PM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,044
Blog Entries: 52

Rep: Reputation: Disabled
Quote:
Originally Posted by debaser4 View Post
What no flames?!
We only have flames in the Slackware forum if users of other distros come in criticising Slack.
 
Old 09-01-2009, 02:15 PM   #9
debaser4
LQ Newbie
 
Registered: Sep 2009
Location: Northampton, UK
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
H_TeXMeX_H - appreciate your comment - I had in fact seen your post but forgot to reference it (I blame FF 3.5.2 in KDE having it's embarassing issue of failing to save tabs... http://forums.mozillazine.org/viewto...401385&start=0)

I read on an Arch forum that adding a line 'setxkbmap gb' to .xinitrc works fine. I think this sorted my test XFCE sessions* but I think KDE4 remains a law unto it's own.

KDE however doesn't seem to want to pay the blindest bit of attention to wherever I stick X settings! (added to my growing list of reasons I don't like KDE)

I will keep tinkering and update if get anywhere with this. I know it's trivial but if I can't properly understand something like keyboard settings in slack I may as well stick with ubuntu (gives a 'sudo' shudder)

* I say think...you know when you've changed so many parts your not sure it you reset them all to what they were to start with
 
Old 09-01-2009, 02:51 PM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,044
Blog Entries: 52

Rep: Reputation: Disabled
A quote from /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi:

Quote:
Many desktop environments, including KDE and Xfce, have their own methods to
configure keyboard layouts and such if you'd like to use them.
Was I right after all?
 
Old 09-01-2009, 03:03 PM   #11
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,524

Rep: Reputation: 94
Quote:
Originally Posted by debaser4 View Post
KDE however doesn't seem to want to pay the blindest bit of attention to wherever I stick X settings! (added to my growing list of reasons I don't like KDE)
I wonder if KDE might pick up the LANG and/or LC_ALL settings. I cannot test it right now though (still on 12.2). Do you already have changed it to en_GB or something like that?
 
Old 09-01-2009, 03:14 PM   #12
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,044
Blog Entries: 52

Rep: Reputation: Disabled
Try System Settings -> Regional & Language -> Keyboard Layout.
Set it to UK, that's all I did, apart from setting it during installation.
Everything works for me as far as keyboard input goes: in the terminal, in Konsole, in Kwrite, etc.
I have set locale in /etc/profile.d/lang.sh to en_GB too.

P.S.
I don't think you'll be very happy going back to Ubuntu once you've tried Slackware.

Last edited by brianL; 09-01-2009 at 03:34 PM.
 
Old 09-01-2009, 03:40 PM   #13
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
If you design your own custom keyboard layouts like me then you need to do the following:
- update or create a file in /etc/X11/xkb/symbols
- add the changes to /etc/X11/xkb/evdev.xml (and possibly base.xml)

Works in KDE 3 & 4.
 
Old 09-01-2009, 04:19 PM   #14
lourensc
LQ Newbie
 
Registered: Nov 2005
Location: Johannesburg South Africa
Distribution: Debian Lenny; Ubuntu; Arch Linux
Posts: 12

Rep: Reputation: 1
I use the dvorak layout. Never had a problem setting it up by just adding
Code:
        Option       "XkbLayout"  "us"
        Option       "XkbVariant" "dvorak"
to the InputDevice Section of my xorg.conf.

For some reason it didn't work this time until I added

Code:
       
        Option "AutoAddDevices" "False"
        Option "AllowEmptyInput" "False"
to the ServerFlags Section of the xorg.conf.

I got the above advice from the web by searching for a warning message I found in /var/log/Xorg.0.log. I tried to see the warning now but it seems yesterdays logs are gone.

Hope this helps.
 
Old 09-01-2009, 04:22 PM   #15
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,044
Blog Entries: 52

Rep: Reputation: Disabled
debaser4 was trying to get qwerty UK working in KDE.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] keyboard layout sw 13.0 H_TeXMeX_H Slackware 8 08-11-2011 01:15 PM
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 06:43 PM
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
keyboard layout acidjuice Slackware 10 02-22-2005 08:51 AM
uk keyboard layout in X fateslack Linux - Newbie 1 02-28-2003 04:27 PM


All times are GMT -5. The time now is 02:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration