LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-30-2012, 05:50 AM   #1
funkyslacker
LQ Newbie
 
Registered: Sep 2012
Location: Germany
Distribution: Slackware64-14.0, Slackware-current, Slackware ARM
Posts: 15

Rep: Reputation: Disabled
keyboard layout changes during boot


Hi,

I have installed slackware 2 days ago and I'm impressed. It's a lot of work, but I like it to configure my linux.

I've encrypted my home folder/partition and swap space with cryptsetup.
Every time during the boot process I have to enter the password. That's not the problem, but the keyboard layout is US, but during the installation i set it to german-latin1.

This is the content of my /etc/rc.d/rc.keymap
Code:
#!/bin/sh
# Load the keyboard map.  More maps are in /usr/share/kbd/keymaps.
if [ -x /usr/bin/loadkeys ]; then
 /usr/bin/loadkeys de-latin1.map
fi
when boot process ended and I have to enter my username and password (at the console/getty), the keymap changed to the correct german settings.

I installed the login manager SLiM (great manager). If I change the runlevel to 4 and linux starts slim the keymap is US. After the login it changes to german.

I'm very confused and I don't know how to change it. Can you give me some hints ?
 
Old 09-30-2012, 07:05 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,184

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
Hi Funkysmlacker,

Welcome to LQ and to the Slakware forum.

Just do this as root:
Code:
cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d
Then in /etc/X11/xorg.conf.d/90-keyboard-layout.conf replace the line:
Code:
	Option "XkbLayout" "us"
with
Code:
	Option "XkbLayout" "de"
Then (re) start X.

Rationale: there are two distinct settings for the keyboard layout: one on the console and one under X.

You could have to do this setting in your DE as well, depending on which one you use.

Last edited by Didier Spaier; 09-30-2012 at 07:16 AM. Reason: s/"us"/"de"/ Shame one me but hopefully "Le lecteur avait rétabli de lui-même"
 
Old 09-30-2012, 07:26 AM   #3
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Rep: Reputation: 17
With encryption you are probably booting from an initrd, you can set a keymap for the initrd.
So keyboard is already in native language when you type your luks password

Code:
# mkinitrd --help
Usage: mkinitrd [OPTION]

[...]

  -l      Custom keymap to load. Like, 'nl' or 'de-latin1-nodeadkeys'

[...]
 
Old 09-30-2012, 08:33 AM   #4
funkyslacker
LQ Newbie
 
Registered: Sep 2012
Location: Germany
Distribution: Slackware64-14.0, Slackware-current, Slackware ARM
Posts: 15

Original Poster
Rep: Reputation: Disabled
@Didier
thank you, this solved the problem with the wrong keymap at SLiM.

@hotchili
thanx for the tip. You're right I'm booting from an initrd and the keymap is still "us" when I enter my luks password.
I've never set up an initrd. Do I have to change somthing in /boot ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong keyboard layout at boot vlachakb Linux - Newbie 6 03-26-2009 12:54 AM
KeyBoard Layout damanhoury Suse/Novell 5 06-15-2007 04:05 PM
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 06:43 PM
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
keyboard layout tetanus Yoper 2 04-13-2005 03:40 PM


All times are GMT -5. The time now is 01:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration