LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-21-2005, 06:12 AM   #1
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
keyboard layout


hello all,

this should be rather simple: how do you configure keyboard layout? i'm not talking under X11 (which i guess is under xorg.conf), instead i'm talking when you do a login in init:2: mode (i.e. when you have to manually startx to enter the gui).

everything is fine if i'm into X, however before starting X i still have the classic US keyboard.

any ideas?

thank you,

aj.
 
Old 02-21-2005, 06:55 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You need to setup the correct keymap in /etc/rc.d/rc.keymap.
 
Old 02-21-2005, 09:00 AM   #3
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
thank you i'll try this!
 
Old 02-21-2005, 11:23 AM   #4
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
hem sorry but no rc.keymap file on my system...
 
Old 02-21-2005, 11:36 AM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Check this post: http://www.linuxquestions.org/questi...hreadid=249005

If you don't have the /etc/rc.d/rc.keymap file just create it with root as owner and group, and set it to executable (it'll be loaded by rc.M).
My rc.keymap looks like:
Code:
#!/bin/sh
# Load the keyboard map. More maps are in /usr/share/kbd/keymaps.
if [ -x /usr/bin/loadkeys ]; then
 /usr/bin/loadkeys es.map
fi
Also be sure that you've the kbd package installed.

PD: es.map is the Spanish layout

Last edited by gbonvehi; 02-21-2005 at 11:44 AM.
 
Old 02-21-2005, 03:54 PM   #6
Oholiab
Member
 
Registered: Feb 2005
Location: UK
Distribution: Slackware 10.1
Posts: 165

Rep: Reputation: 30
Funny, I've got mine set to uk.map, but it types in american format! HELP!
 
Old 02-22-2005, 12:03 AM   #7
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
What do you mean it types in american format? Maybe you need to change that layout in X which was explained in the post I linked to.
 
Old 02-22-2005, 02:24 AM   #8
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You need to make sure that the keymap in /etc/rc.d/rc.keymap is the same as that in you xorg.conf. So in your case what you need to do is edit xorg.config and change the following line

Option "XkbLayout" "us"
to
Option "XkbLayout" "gb"
 
Old 02-22-2005, 06:47 AM   #9
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
hi again,

problem is i don't have the /etc/rc.d/rc.keymap file. i created one that looks like gbonvehi's one of the post here above, however i don't think this is executed at boot.

you know how i can execute this at boot? and why in any case this file wasn't generated on my install (slack 10.1)?

thank you,

aj
 
Old 02-22-2005, 08:28 AM   #10
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
As root, just do "chmod +x /etc/rc.d/rc.keymap. When you restart your PC, it should use the selected keymap. There is mine below using the UK keymap.

Code:
#!/bin/sh
# Load the keyboard map.  More maps are in /usr/share/kbd/keymaps.
if [ -x /usr/bin/loadkeys ]; then
 /usr/bin/loadkeys uk.map
fi
 
Old 02-22-2005, 08:51 AM   #11
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 375

Rep: Reputation: 31
Whoops. Answered an un-asked question.

Last edited by WilliamS; 02-22-2005 at 08:54 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard layout phoenix7 Linux - Software 3 02-24-2009 08:20 PM
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
Keyboard Layout AlessPT Linux - Software 1 12-20-2004 01:07 AM
keyboard layout evensen Linux - Games 0 05-03-2004 03:14 AM
uk keyboard layout in X fateslack Linux - Newbie 1 02-28-2003 04:27 PM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration