LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-12-2007, 05:47 AM   #1
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
keyboard doesnt work


yup. You read right. My regular, non-USB keyboard does not want to work with Slackware. Its recognized on startup at the boot prompt, but when I try to login, it doesn't read anything. What is the problem? This is kinda stupid.
 
Old 12-12-2007, 07:32 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
What kind of keyboard is it ? What is your default init level ? Do you boot straight into KDM (GUI login) (init 4) or to the regular CLI (command line interface) login (init 3) ?
 
Old 12-12-2007, 10:22 AM   #3
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
Regular type of keyboard, standard with the HP a1410y desktop computer. Its PS/2 jack. I boot into command line first, then used kdm from root, or startx after creating user.
 
Old 12-12-2007, 10:38 AM   #4
WoodLark
LQ Newbie
 
Registered: Feb 2004
Location: South Carolina
Distribution: Slackware et. al.
Posts: 29

Rep: Reputation: 15
If I understand you correctly, the keyboard works at the command line since you can "startx", but doesn't work in the GUI. Check your xorg.conf file; it appears to be telling x that you either don't have a keyboard or that you have some unusual keyboard.
 
Old 12-12-2007, 11:01 AM   #5
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
No, at the initial LILO screen, at the boot prompt, I can type. But after everything loads, and comes to the shell login, I can't type.
 
Old 12-12-2007, 02:11 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Ok, which Slackware version are you using and with what kernel ? Looks like there's something wrong with the keyboard driver. Did you just install Slackware ? If so, check the md5sum of the install CD/DVD.
 
Old 12-12-2007, 03:05 PM   #7
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
I have already installed Slackware on my laptop, which is what I'm using right now. Its Slackware 11, with the default sata.s (something like that) kernel. It works for my laptop, but not my desktop.
 
Old 12-12-2007, 03:19 PM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Maybe try out a different kernel. Try 'huge26.s' for example.
 
Old 12-12-2007, 04:19 PM   #9
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
OK, this solved the keyboard problem, but still no mouse. What entry do i need to make sure I have in xorg.conf to make my mouse work? And what program do I open it up with in command line (given it doesn't have nano).
 
Old 12-12-2007, 06:42 PM   #10
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
Anybody have any ideas? I'm without a desktop computer right now...
 
Old 12-12-2007, 06:56 PM   #11
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,895
Blog Entries: 51

Rep: Reputation: Disabled
If it's a wheel mouse, in xorg.conf, change:

Code:
Protocol    "PS/2"
to:

Code:
Protocol    "IMPS/2"
then at rhe bottom of the mouse section, add:

Code:
Option      "Buttons" "5"
Option      "ZAxisMapping" "4 5"
It has pico, similar to nano.

Last edited by brianL; 12-12-2007 at 06:59 PM.
 
Old 12-12-2007, 07:56 PM   #12
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
OK, I changed the PS/2 to IMPS/2, and added the lines at the end, but when I tried to startx, or start kdm, it said it couldnt find a screen. So I deleted the last two lines, and it came up, but my mouse still doesnt work. Do those lines need to be in a subsection? Cause I put them after the last section, before the next device starts.
 
Old 12-12-2007, 09:00 PM   #13
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
Do I make a separate section for those lines, or try a different kernel? If the last one, which kernel?
 
Old 12-13-2007, 01:29 AM   #14
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
Put those lines directly underneath your "IMPS/2" entry. If X still won't start, check /var/log/Xorg.0.log, and look for any lines beginning with EE or WW.
 
Old 12-13-2007, 06:07 AM   #15
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Original Poster
Rep: Reputation: 47
X starts, but my mouse still doesn't work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard doesnt work in X (Suse 10) WRXHokie Linux - Hardware 4 04-06-2006 01:49 PM
Keyboard doesnt work in X WRXHokie Suse/Novell 1 03-28-2006 01:40 AM
Keyboard doesnt work after install... WRXHokie Linux - Hardware 10 03-22-2006 05:05 PM
KnoppMyth Keyboard Doesnt Work When Installing gblasius Linux - Newbie 0 12-29-2005 05:09 AM
Keyboard doesnt work in X jarquet Linux - Hardware 1 06-26-2003 01:22 PM


All times are GMT -5. The time now is 12:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration