LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-28-2004, 11:33 AM   #1
reaz82
LQ Newbie
 
Registered: Aug 2002
Location: Austin
Distribution: Gentoo/FreeBSD
Posts: 24

Rep: Reputation: 15
keyboard does not respond


when i use the bare.i kernel on the cd the keyboard works just fine. however, when i compile the kernel (be it 2.4 or 2.6.7) the boot process reaches the terminal login but the keyboard is disabled.

what am i doing wrong? and can someone provide advice
 
Old 07-28-2004, 11:44 AM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Is it an USB keyboard ?

And if not, in your kernel config, did you enable these features :
CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ATKBD=y
 
Old 07-28-2004, 11:44 AM   #3
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 32
is it a USB or PS/2 keyboard?

you might need to load the USB modules..
 
Old 07-28-2004, 11:50 AM   #4
reaz82
LQ Newbie
 
Registered: Aug 2002
Location: Austin
Distribution: Gentoo/FreeBSD
Posts: 24

Original Poster
Rep: Reputation: 15
it's a ps/2 keyboard. i use it with a usb mouse.
 
Old 07-28-2004, 12:03 PM   #5
wass29
Member
 
Registered: Feb 2003
Distribution: Slack 9,10 Ubuntu 8.04-current RHEL4(sort of)
Posts: 63

Rep: Reputation: 15
Boot off of the first cd, then go to /etc/rc.d folder
type 'chmod -x rc.gpm' then reboot that should fix your problem

if not then try starting in single user mode
 
Old 07-28-2004, 12:20 PM   #6
reaz82
LQ Newbie
 
Registered: Aug 2002
Location: Austin
Distribution: Gentoo/FreeBSD
Posts: 24

Original Poster
Rep: Reputation: 15
i think i tried disabling the gpm script. and i dont think that helped.
 
Old 07-28-2004, 12:29 PM   #7
wass29
Member
 
Registered: Feb 2003
Distribution: Slack 9,10 Ubuntu 8.04-current RHEL4(sort of)
Posts: 63

Rep: Reputation: 15
If you did disable it and that didn't fix it, then try hitting a key about every second during boot and see when it breaks. When I had that problem it was GPM that was loading last and my keyboard worked just fine until that module started and then I had nothing.
 
Old 07-28-2004, 12:39 PM   #8
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Hey reaz82, why do you think it is a system config problem as you said that your keybord works with the bare.i kernel.
What is your output with :
cat /usr/src/linux-2.6.7/.config | grep -i key
 
Old 07-28-2004, 12:43 PM   #9
reaz82
LQ Newbie
 
Registered: Aug 2002
Location: Austin
Distribution: Gentoo/FreeBSD
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Cedrik
Hey reaz82, why do you think it is a system config problem as you said that your keybord works with the bare.i kernel.
What is your output with :
cat /usr/src/linux-2.6.7/.config | grep -i key
i dont think it's a system config problem.. i mean i am not sure what you mean by that.. all i can tell for now is that it works with the packaged bare.i kernel but not with my custom kernel.. the bare.i kernel lacks a lot of other stuff which is why i compiled the kernel ..

the keyboad doesnt respond during boot.. it's not like it messes up after gpm.. it just doesnt respond at all when the compiled kernel is loading..
 
Old 07-28-2004, 01:19 PM   #10
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
I see, why don't you try to configure your kernel from the config of bare.i ?
 
Old 07-28-2004, 02:09 PM   #11
reaz82
LQ Newbie
 
Registered: Aug 2002
Location: Austin
Distribution: Gentoo/FreeBSD
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Cedrik
I see, why don't you try to configure your kernel from the config of bare.i ?
i'll try that.. later..
 
Old 07-28-2004, 07:39 PM   #12
reaz82
LQ Newbie
 
Registered: Aug 2002
Location: Austin
Distribution: Gentoo/FreeBSD
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Cedrik
Is it an USB keyboard ?

And if not, in your kernel config, did you enable these features :
CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ATKBD=y
i searched through .config and found these options.. they are enabled..

Last edited by reaz82; 07-28-2004 at 07:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard does not respond after install reaz82 Slackware - Installation 4 07-13-2005 01:07 PM
Alsa on games makes the keyboard and mouse respond with a 15 sec. delay Ac1db0rN Linux - Hardware 4 03-24-2005 04:13 PM
keyboard doesn´t respond after plugging in overlord73 Fedora 2 01-04-2005 10:03 AM
Keyboard does not respond in 2.6 Knio Linux - Hardware 1 09-19-2004 09:45 PM
Keyboard fails or respond eraticly jimsteven Linux - Newbie 1 04-24-2003 12:33 PM


All times are GMT -5. The time now is 08:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration