LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-21-2012, 09:17 AM   #1
thund3rstruck
Member
 
Registered: Nov 2005
Location: East Coast, USA
Distribution: Fedora 18, Slackware64 13.37, Windows 7/8
Posts: 346

Rep: Reputation: 38
Keyboard Cursor Jumps While Typing


I thought I was imagining things for the last few days but last night I was working on a python script and now I'm absolutely sure the issue is real.

I'm using KDE 4.6.5 from KTown on slackware 13.37 on a new Dell Inspiron 15R Laptop. Any time I am typing in a textbox control, the cursor will jump up and or back at random (seemingly) to a new position and this garbles up my text real bad. I am having to type, really, really slowly to prevent the cursor from jumping to a new position and screwing up my work.

I think I resolved the issue by disabling the keystroke repeat option in KDE but then I can't hold up to go up more than one line, hold enter to go down more than one line, etc, etc. Disabling the keystroke repeat basically makes the computer useless for anything other than web surfing.

Does anyone have any idea how to resolve this or am I just crazy?
 
Old 05-21-2012, 09:36 AM   #2
pan64
Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 5,571

Rep: Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468
keyboard error? glass of cafe?
 
Old 05-21-2012, 09:42 AM   #3
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,828

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
Could you be catching the touchpad whilst typing? I know a combination of that and catching the menu key causes me to select and delete text when I first move to some latptops.
 
Old 05-21-2012, 10:02 AM   #4
thund3rstruck
Member
 
Registered: Nov 2005
Location: East Coast, USA
Distribution: Fedora 18, Slackware64 13.37, Windows 7/8
Posts: 346

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by 273 View Post
Could you be catching the touchpad whilst typing? I know a combination of that and catching the menu key causes me to select and delete text when I first move to some latptops.
That's what I originally thought, I must be hitting the touchpad but no it's been going on all week. If I type like a leper with my hands arched upwards to I'm nowhere near the touchpad it still jumps like that. I don't know, maybe there's some kind of hotkey shortcut or something that I'm hitting when I type that jumps me around.

I need to boot into Windows 7, load Visual Studio and try working on some code and see if it happens there too. If not then I can be 100% sure it's a slackware/kde thing.
 
Old 05-21-2012, 10:06 AM   #5
thirteen_engines
Member
 
Registered: Sep 2009
Location: Saskatoon, Saskatchewan
Distribution: Slackware 14.1
Posts: 82

Rep: Reputation: 19
Don't know if this will help but I have much the same problem and have solved it using syndaemon. I put a script in ~/.kde/Autostart that reads:

#!/bin/bash

/usr/bin/syndaemon -d -i20

The '-d' is to run as a daemon process and the '-i20' tells syndaemon to turn off the touchpad for 20 seconds after a key has been typed. 20 seconds is probably overkill and could be reduced to something more reasonable.
 
Old 05-21-2012, 10:20 AM   #6
thund3rstruck
Member
 
Registered: Nov 2005
Location: East Coast, USA
Distribution: Fedora 18, Slackware64 13.37, Windows 7/8
Posts: 346

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by thirteen_engines View Post
Don't know if this will help but I have much the same problem and have solved it using syndaemon. I put a script in ~/.kde/Autostart that reads:

#!/bin/bash

/usr/bin/syndaemon -d -i20

The '-d' is to run as a daemon process and the '-i20' tells syndaemon to turn off the touchpad for 20 seconds after a key has been typed. 20 seconds is probably overkill and could be reduced to something more reasonable.
Brilliant! I'll give that a try after work tonight!
 
Old 05-21-2012, 07:59 PM   #7
thund3rstruck
Member
 
Registered: Nov 2005
Location: East Coast, USA
Distribution: Fedora 18, Slackware64 13.37, Windows 7/8
Posts: 346

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by thund3rstruck View Post
Brilliant! I'll give that a try after work tonight!
I gave that command a try and the stdout was: Unable to find a synaptics device.
 
Old 11-26-2013, 08:04 PM   #8
rcorkum
Member
 
Registered: Aug 2005
Location: Thunder Bay, Ontario, Canada
Distribution: Slackware Current
Posts: 102

Rep: Reputation: 15
experiencing this exact same issue on a gateway nv-54 like you I thought I was loosing my mind finally my wife was like whats wrong and then I told her she was like sure sure with a wifely smile then she used it this morning to do some stuff. and told me when i walked out 'you know your not crazy there is something wrong. mine jumps randomly drives me nuts. tempted to wipe and reinstall but did some searching and saw this exact same thread so thought I'd ask what your results where. if your still checking.

Quote:
Originally Posted by thund3rstruck View Post
I thought I was imagining things for the last few days but last night I was working on a python script and now I'm absolutely sure the issue is real.

I'm using KDE 4.6.5 from KTown on slackware 13.37 on a new Dell Inspiron 15R Laptop. Any time I am typing in a textbox control, the cursor will jump up and or back at random (seemingly) to a new position and this garbles up my text real bad. I am having to type, really, really slowly to prevent the cursor from jumping to a new position and screwing up my work.

I think I resolved the issue by disabling the keystroke repeat option in KDE but then I can't hold up to go up more than one line, hold enter to go down more than one line, etc, etc. Disabling the keystroke repeat basically makes the computer useless for anything other than web surfing.

Does anyone have any idea how to resolve this or am I just crazy?
 
Old 11-26-2013, 10:55 PM   #9
thund3rstruck
Member
 
Registered: Nov 2005
Location: East Coast, USA
Distribution: Fedora 18, Slackware64 13.37, Windows 7/8
Posts: 346

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by rcorkum View Post
experiencing this exact same issue on a gateway nv-54 like you I thought I was loosing my mind finally my wife was like whats wrong and then I told her she was like sure sure with a wifely smile then she used it this morning to do some stuff. and told me when i walked out 'you know your not crazy there is something wrong. mine jumps randomly drives me nuts. tempted to wipe and reinstall but did some searching and saw this exact same thread so thought I'd ask what your results where. if your still checking.
Yea I ended up engineering a solution for the problem back in the spring:
http://www.linuxquestions.org/questi...2/#post4941398

I wrote a script that unloads/loads the psmouse kernel module. Basically you install xbindkeys (or any key-press hooking program) and configure it to run the script anytime your sequence of keys are pressed. In my case I setup xbindkeys to listen for CTRL+ALT+D and it runs the script anytime those keys are pressed.

It has been a life-saver for me and I think it went somewhat viral because I get emails fairly frequently from people thanking me for writing it

Hope it helps you out!

Last edited by thund3rstruck; 11-26-2013 at 11:01 PM. Reason: xbindkeys
 
1 members found this post helpful.
Old 11-27-2013, 08:03 AM   #10
Spect73
Member
 
Registered: Aug 2013
Distribution: Slackware 14.1
Posts: 128

Rep: Reputation: Disabled
Thanks for that little script. It solved my laptops problem also. On mine, the touchpad worked okay until the machine went to sleep. If I forgot to cycle the touchpads on/off switch after it awoke, I would get the same unwanted movement. And of course, it seems almost impossible to remember to cycle the switch.

As an aside, using the stock 14.0 'huge' kernel, I was surprised that the psmouse wasn't just compiled in. Evidently it isn't as rmmod 'psmouse' does remove the module. Live and learn.

Coordially,
 
Old 05-29-2014, 11:49 AM   #11
Tansul
LQ Newbie
 
Registered: May 2014
Posts: 1

Rep: Reputation: Disabled
Angry Jumping cursor

Hi all, I'm new.
I installed Linux as it was what I thought, would be the only option to try to keep-out a persistent, destructive, hacker. I do a lot of writing, mainly on the Internet and the jumping cursor is causing problems even as I type this short post.
I tried downloading the code and running it, but it made not a scrap of difference. For example the cursor would not even stand still for me to enter a password to get into this site.
I'm not a developer, I just need a secure operating system.
Please help!

Last edited by Tansul; 05-29-2014 at 11:56 AM.
 
Old 05-29-2014, 04:41 PM   #12
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 221
Blog Entries: 2

Rep: Reputation: Disabled
check for EMI, power supply(80+ standard), and try add ferrite bread/chock snap on your keyboard or mouse.
 
Old 02-07-2015, 05:22 AM   #13
rcorkum
Member
 
Registered: Aug 2005
Location: Thunder Bay, Ontario, Canada
Distribution: Slackware Current
Posts: 102

Rep: Reputation: 15
its not emi have a degree in electronics this is a bug related to specific makers of laptops

I had the gateway nv-54 listed in the thread above and now an acer aspire 4739 and honestly was trying to do an email and almost whipped the laptop across the room and i've never damaged any hardware in anyway in 32 years of computer use.

Can anyone verify this is a bug in a kernel module. the above script works great and is a god send but having to toggle the mousepad off and on in 2015 seems we should have a more built in fix for our mobile pc market.

I love slackware absolutely love it. but its not slackware based have the same thing on kali which is debian to.

I really HATE to put windows back on this laptop slackware is so elegant but this is one of the most frustrating bugs ever. your cursor basically jumps around the field your typing in, randomly copy and pasting or inserting. my wife laughed at me about the gateway nv-54 till I had her try to send an email she handed that laptop back to me her eyes smoldering and me laughing myself to tears

btw so far doing this small post my cursor has jumped 19 times so far. makes it so much FUN.

Robert chuckle now 20.

Last edited by rcorkum; 02-07-2015 at 05:26 AM. Reason: typo's
 
Old 02-07-2015, 03:10 PM   #14
kjhambrick
Member
 
Registered: Jul 2005
Location: Round Rock, TX
Distribution: Slackware-64 -current
Posts: 70

Rep: Reputation: 39
What make of touchpad do you have ?

If you do have a Synaptics touchpad, this worked for me:

Code:
synclient ClickFinger2=0 ClickFinger3=0 TapButton2=0 TapButton3=0 VertEdgeScroll=0 FastTaps=1
The synclient command on Slackware 13.37 is part of xf86-input-synaptics-1.4.0-x86_64-1

I played around with the settings until it worked for my Laptop.

I saved the command as /usr/local/fix-mouse:

Code:
echo 'synclient ClickFinger2=0 ClickFinger3=0 TapButton2=0 TapButton3=0 VertEdgeScroll=0 FastTaps=1' > /usr/local/bin/fixmouse
chmod 755 /usr/local/bin/fix-mouse
I run 'fix-mouse' each time I start KDE ... it does save me from maddening text pastes and mouse jumping.

-- kjh
 
Old 02-07-2015, 03:21 PM   #15
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 607

Rep: Reputation: 206Reputation: 206Reputation: 206
Quote:
Originally Posted by kjhambrick View Post
I run 'fix-mouse' each time I start KDE ... it does save me from maddening text pastes and mouse jumping.
You could just put this in your ~/.kde/Autostarts folder and have it executable and then KDE will run it for you automatically every time you log in. I have this done for my mouse to remap my back button (Microsoft apparently reversed the buttons and clicking back on the mouse takes you forward).
 
  


Reply

Tags
kde35, keyboard, slackware 13.37


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cursor jumps all over taj Ubuntu 3 11-13-2008 02:47 PM
Cursor jumps all over taj Linux - General 3 11-13-2008 01:19 PM
mouse cursor jumps while typing subetai Slackware 3 07-16-2008 08:24 AM
Synaptics / touch pad typing with random cursor jumps --solution 1kyle Suse/Novell 0 03-25-2008 07:54 AM
typing on keyboard jumps to mouse cursor position iomari Linux - General 5 07-26-2007 04:03 AM


All times are GMT -5. The time now is 03:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration