LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-18-2010, 07:48 PM   #1
quiescere
Member
 
Registered: Sep 2003
Distribution: Slackware64 13.1
Posts: 52

Rep: Reputation: 15
keyboard configuration in Xorg: deadkeys, hal, evdev, what?


What is the modern way to set up a compose key and deadkeys in X? (Slack 13.1, standard US equipment)

First I tried xorg.conf:
Code:
Section "InputDevice"
    Identifier   "Keyboard1"
    Driver       "kbd"
    Option       "XkbRules"    "xorg"
    Option       "XkbModel"    "pc104"
    Option       "XkbLayout"   "us"
    Option       "XkbVariant"  "intl"
    Option       "XkbOptions"  "compose:ralt"
EndSection
Then further reading suggested hal is the new way, so I copied /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy and made some changes:
Code:
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string">intl</merge>
      <merge key="input.xkb.options" type="string">compose:ralt</merge>
That didn't work either. Now I've read more that says Xorg doesn't need hal any longer.

Does anyone have any recommendations for where to turn next? It seems like every three years or so I have to re-learn how to configure a keyboard because the infrastructure has fundamentally changed. This is frustrating.

Thanks----
quiescere
 
Old 12-18-2010, 07:58 PM   #2
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
If you are just modifying a few keys of any particular map, I would use xmodmap. However, if you are completely changing a keyboard map (say qwerty to dvorak) I would use setxkbmap.

EDIT: the above mentioned file has the same note as the CHANGES_AND_HINTS.txt
You can try disabling hal for xinputs. But you will need a full xorg.conf file.
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"

Being that you already tried the hal method, I would either give up and use setxkbmap but save hal for the other inputs and video card, or ditch hal and define a full xorg.conf file.

EDIT EDIT EDIT:

The solution might be simple...

Did you restart the hal service? It might not like your changes until it restarts and rereads the config file .. obviously also restart x.

Code:
su -c '/etc/rc.d/rc.hald restart'

Last edited by lumak; 12-18-2010 at 08:06 PM.
 
Old 12-18-2010, 09:07 PM   #3
quiescere
Member
 
Registered: Sep 2003
Distribution: Slackware64 13.1
Posts: 52

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by lumak View Post
Being that you already tried the hal method, I would either give up and use setxkbmap but save hal for the other inputs and video card, or ditch hal and define a full xorg.conf file.
This may be what I have to do. The following command gives the behaviour I want, but it bugs me that I don't know the proper way to configure this as the default:
Code:
setxkbmap -model pc105 -layout us -variant intl -option "compose:ralt"
Quote:
Originally Posted by lumak View Post
Did you restart the hal service? It might not like your changes until it restarts and rereads the config file .. obviously also restart x.

Code:
su -c '/etc/rc.d/rc.hald restart'
Good suggestion. I did restart both before my first posting, with no luck. I should have said so in my initial post.

Thanks for your quick reply.

quiescere
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf and hal conficts: unable to set keyboard or monitor settings. Gustav 4 Slackware 3 08-16-2009 07:01 AM
Xorg 7.3, evdev, and mouse CrEsPo Slackware 1 05-05-2008 04:16 AM
Sid Users - Beware of Xorg 7.3 (xserver-xorg-input-evdev) bug rickh Debian 4 10-24-2007 03:30 AM
Using evdev causes Xorg to restart on keypress Likosin Linux - Software 5 04-03-2006 04:10 PM
evdev with xorg 6.9 ganja_guru Linux - Software 1 12-25-2005 12:46 PM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration