LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Keyboard and Mouse not working in X (http://www.linuxquestions.org/questions/slackware-14/keyboard-and-mouse-not-working-in-x-749321/)

Karimo 08-21-2009 11:43 AM

Keyboard and Mouse not working in X
 
Hi all!
I'm posting this thread, although there are many around there (but no one solved the problem), because, after an upgrade-all, mouse and keyboard stopped working in X under the same kernel and xorg.conf.
Both keyboard and mouse (under gpm) works perfectly in the console, but not in X, and obviously I'm exasperated wondering why.
I tried to reconfigure X with xorgsetup and xorgconfig, reinstalling entirely X.org, reinstalling hal, reinstalling dbus but nothing did the trick.
I'm running a 2.6.30.4 home-compiled kernel with all packages to -current.
Here is my package-brewed xorg.conf[-vesa] (that, I think, should work at least for mouse and keyboard):

Code:

Section "Module"
    Load        "dbe"          # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"  # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "freetype"
    #Load        "speedo"
    Load      "glx"
EndSection
Section "Files"
    RgbPath        "/usr/share/X11/rgb"
    FontPath  "/usr/share/fonts/local/"
    FontPath  "/usr/share/fonts/misc/"
    FontPath  "/usr/share/fonts/OTF/"
    FontPath  "/usr/share/fonts/TTF/"
    FontPath  "/usr/share/fonts/Type1/"
    FontPath  "/usr/share/fonts/CID/"
    FontPath  "/usr/share/fonts/Speedo/"
    FontPath  "/usr/share/fonts/75dpi/:unscaled"
    FontPath  "/usr/share/fonts/100dpi/:unscaled"
    FontPath  "/usr/share/fonts/75dpi/"
    FontPath  "/usr/share/fonts/100dpi/"
    FontPath  "/usr/share/fonts/cyrillic/"
EndSection
Section "ServerFlags"
EndSection
Section "InputDevice"
    Identifier        "Keyboard1"
    Driver        "kbd"
EndSection
Section "InputDevice"
    Identifier        "Mouse1"
    Driver        "mouse"
    Option "Protocol"    "PS/2"
    Option "Device"      "/dev/mouse"
EndSection
Section "Monitor"
    Identifier  "My Monitor"
    HorizSync  31.5 - 50.0
    VertRefresh 40-90
EndSection
Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor    "My Monitor"
  DefaultDepth 24
    Subsection "Display"
        Depth      8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      32
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
EndSection
Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Xorg.log doesn't show anything useful.
I'm really stuck, any suggestion is really appreciated.
Thanks in advance,

Karimo

GrapefruiTgirl 08-21-2009 12:15 PM

Have you verified that HAL is actually running, or that it has been started? If rc.hald chmodded executable?

Try from console as root before starting X:

Code:

root# /etc/rc.d./rc.hald restart

or

ps ax | grep hald

and see if helps or tells you anything.. (note the rc.hald file may have a slightly different name, but I think this is correct)

Does the system work with a default kernel? Maybe you omitted something silly from your kernel? :)

Finally, check the -current changelog to make sure something hasn't changed that would influence this situation.

Best of luck,
Sasha

GrapefruiTgirl 08-21-2009 12:21 PM

And hey wait!! Doesn't HAL need to use the evdev driver? I don't use HAL so I'm not sure about this.

Sasha

Karimo 08-21-2009 06:43 PM

HAL and DBus are working perfectly.
I've solved noticing that the "AllowEmptyInput" was implicitly turned On.
This option makes X.org deactivating all the input devices that are driven by kbd,mouse,[...] drivers.
Was sufficient to add a Option "AllowEmptyInput" "False" to the ServerLayout section to fix the issue.
Thanks to you all,

Greetings,

Karimo


All times are GMT -5. The time now is 05:37 PM.