LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2003, 07:15 AM   #1
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
Kernel SCSI Emulation for CD-RW


I've comiled the kernel 2.4.21|All works well but I got this problem with the CD-RW
I've enabled:
In the ATA/IDE support section, enable SCSI emulation support
In the SCSI Support section, enable SCSI Support, SCSI CD-ROM support and SCSI generic support
but the error still remain:

[root@thor:~]# cdrecord -scanbus
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

This is a part of my .config file:

#
# ATA/IDE/MFM/RLL support
#
CONFIG_IDE=y

#
# IDE, ATA and ATAPI Block devices
#
CONFIG_BLK_DEV_IDE=y

#
# Please see Documentation/ide.txt for help/info on IDE drives
#
# CONFIG_BLK_DEV_HD_IDE is not set
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_IDEDISK=y
# CONFIG_IDEDISK_MULTI_MODE is not set
# CONFIG_IDEDISK_STROKE is not set
CONFIG_BLK_DEV_IDECS=m
CONFIG_BLK_DEV_IDECD=y
# CONFIG_BLK_DEV_IDETAPE is not set
CONFIG_BLK_DEV_IDEFLOPPY=y
CONFIG_BLK_DEV_IDESCSI=y
# CONFIG_IDE_TASK_IOCTL is not set


#
# SCSI support
#
CONFIG_SCSI=y

#
# SCSI support type (disk, tape, CD-ROM)
#
CONFIG_BLK_DEV_SD=m
CONFIG_SD_EXTRA_DEVS=40
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
CONFIG_BLK_DEV_SR=y
# CONFIG_BLK_DEV_SR_VENDOR is not set
CONFIG_SR_EXTRA_DEVS=2
CONFIG_CHR_DEV_SG=y

Some1 should help please??
ThanksVeryMuch

Last edited by Obscure; 08-22-2003 at 07:16 AM.
 
Old 08-22-2003, 07:22 AM   #2
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Try 'cdrecord dev=ATAPI -scanbus'

and also 'man cdrecord'

Enjoy!
--- Cerbere
 
Old 08-22-2003, 12:34 PM   #3
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Well...with this command something seems to work:

[root@thor:~]# cdrecord dev=ATAPI -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'HL-DT-ST' 'CD-RW GCE-8520B ' '1.00' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

A friend of mine says that if I enable ide support it takes the control and the scsi emulation doesn't work...
I wil try...
TnxVM
 
Old 08-22-2003, 01:52 PM   #4
Angelo
Member
 
Registered: Mar 2003
Location: Connecticut
Distribution: Slackware, OpenBSD
Posts: 60

Rep: Reputation: 15
From /etc/rc.d/rc.modules:

# *** THIS IS STILL LOADED BY DEFAULT ***
# SCSI emulation support. This will provide SCSI host adapter emulation
# for IDE ATAPI devices, and will allow you to use a SCSI device driver
# instead of a native ATAPI driver. This is useful if you have an ATAPI
# device for which no native driver has been written (for example, an ATAPI
# PD-CD or CD-RW drive); you can then use this emulation together with an
# appropriate SCSI device driver. Note that this option does NOT allow you
# to attach SCSI devices to a box that doesn't have a SCSI host adapter
# installed. Also, you'll need to exclude your CD-RW from being grabbed by
# the normal ATAPI driver by passing a flag to the kernel at boot time.
# If you're using LILO, add this: append="hdc=ide-scsi"
# Replace "hdc" with the appropriate device name.
/sbin/modprobe ide-scsi
 
Old 08-22-2003, 02:00 PM   #5
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
I know about this!!
But I used append="hdc=ide-scsi" since first time!!
The append options seems that doesn't exclude ATAPI driver...
I've also added into modules.conf the line
options ide-cd ignore=hdc
but remains the same...
I'll recompile the kernel excluding completly the ide cd support!!
TNX

Last edited by Obscure; 08-22-2003 at 02:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel 2.8.1 scsi emulation doralsoral Linux - Software 6 10-18-2004 09:30 AM
k3b and scsi emulation in kernel 2.6x taek Slackware 10 10-03-2004 09:46 AM
Recompiling kernel without ide-scsi emulation techrolla Linux - Software 1 06-21-2004 12:52 PM
SCSI Emulation after Kernel recompile phekno Linux - Newbie 3 10-21-2003 03:48 PM
SCSI Emulation with Kernel 2.4.18-bf2.4 Donald1000 Linux - Hardware 2 10-30-2002 05:10 PM


All times are GMT -5. The time now is 09:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration