LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-14-2003, 12:07 AM   #1
slackfan
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware
Posts: 20

Rep: Reputation: 0
kernel recompiled successfully... though now tux is missing :(


I searched around for keyword tux and no joy regarding how to get tux back...

here is what I did...

1. installed distro slackware 8.1
2. installed dropline
3. replaced issued kernel 2.4.18 with 2.4.20 from: http://www.kernel.org/pub/linux/kern...-2.4.20.tar.gz
4. ran /sbin/lilo -v for testing new kernel
5. rebooted, and tested new kernel... looks good so far, except no tux... reboot again to LILO choose old kernel and tux is there...

... I want tux back!

thanks for your help.
 
Old 02-14-2003, 12:32 AM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Not sure why you built a custom kernel so I do not know what would be the easiest or best recommendation. But the framebuffer options were not enabled in the new kernel.

Either enable them, you can review the config of 2.4.18. Or you can create a 2.4.20 kernel using the config from the 2.4.18. Just copy the .config file from 2.4.18 source tree to the 2.4.20 source tree. (Note the period in the name.) After you copy the file, run make oldconfig and just press enter to all the new options for the defaults. You can then modify the config as you originaly desired, like CPU, etc. After installing the kernel and rebooting, tux should be back once again. This method is usually best unless you know exactly what options you need or do not need. It will also provide for all the modules like the stock kernel.

If you didn't have a 2.4.28 source tree, then look on your install CD in the kernels directory probably for bare.i. The config file should be there. eBe sure to use the period in the filename when you copy it the 2.4.20 source tree.

Last edited by Excalibur; 02-14-2003 at 12:37 AM.
 
Old 02-14-2003, 04:36 AM   #3
chr15t0
Member
 
Registered: Jun 2002
Location: London
Distribution: Slackware
Posts: 201

Rep: Reputation: 30
you need to enable frame buffering

christo

edit: Sorry - I didn't read excalibur's reply properly !

Last edited by chr15t0; 02-14-2003 at 04:38 AM.
 
Old 02-14-2003, 11:09 AM   #4
slackfan
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Excalibur
Not sure why you built a custom kernel
I was hoping to kill two pengy's with one kernel...
0. I needed 2.4.20 to support some of the usbserial devices I had.
1. The kernel that was installed was super bloated with stuff I would never use on my laptop... since I needed to get the latest stable kernel anyhow, i'd figure i'd start from a bare config and just add the things that I wanted, rather than removing things I didn't want....

Quote:
Originally posted by Excalibur
But the framebuffer options were not enabled in the new kernel.
Ah, that is what the problem is... ok I noticed that when using make xconfig that the framebuffer section was grayed out... so let me tell you what I did from the advice you gave...

1. First I just wanted to test what you were saying (because I am that way), and you were correct, it worked and tux came back when basing the new kernel (2.4.20) with the old config (the one that came on the cd)... tux was back... though I did it in a hurry so didn't remove all the bloat in hopes that I could figure out how to just add something to the finished config... If all else fails I can take this path again to get tux back...

2. So I am thinking that I can use make xconfig generate a new config file, edit it to enable the framebuffer support by adding a few lines from the old config in the # Frame-buffer section... i know the config file says not to edit it, but what they heck... so I go ahead and do this... (I spent all night recompiling and recompiling, probably around 20 times to try and find the specific lines)...

here is the one that comes on the cd:

#
# Frame-buffer support
#
CONFIG_FB=y
CONFIG_DUMMY_CONSOLE=y
CONFIG_FB_RIVA=m
CONFIG_FB_CLGEN=m
CONFIG_FB_PM2=m
# CONFIG_FB_PM2_FIFO_DISCONNECT is not set
CONFIG_FB_PM2_PCI=y
CONFIG_FB_CYBER2000=m
CONFIG_FB_VESA=y
CONFIG_FB_VGA16=m
CONFIG_FB_HGA=m
CONFIG_VIDEO_SELECT=y
CONFIG_FB_MATROX=m
CONFIG_FB_MATROX_MILLENIUM=y
CONFIG_FB_MATROX_MYSTIQUE=y
CONFIG_FB_MATROX_G100=y
CONFIG_FB_MATROX_I2C=m
CONFIG_FB_MATROX_MAVEN=m
CONFIG_FB_MATROX_G450=m
CONFIG_FB_MATROX_MULTIHEAD=y
CONFIG_FB_ATY=m
CONFIG_FB_ATY_GX=y
CONFIG_FB_ATY_CT=y
CONFIG_FB_RADEON=m
CONFIG_FB_ATY128=m
CONFIG_FB_SIS=m
CONFIG_FB_SIS_300=y
CONFIG_FB_SIS_315=y
CONFIG_FB_3DFX=m
CONFIG_FB_VOODOO1=m
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_VIRTUAL is not set
CONFIG_FBCON_ADVANCED=y
CONFIG_FBCON_MFB=m
CONFIG_FBCON_CFB2=m
CONFIG_FBCON_CFB4=m
CONFIG_FBCON_CFB8=y
CONFIG_FBCON_CFB16=y
CONFIG_FBCON_CFB24=y
CONFIG_FBCON_CFB32=y
# CONFIG_FBCON_AFB is not set
# CONFIG_FBCON_ILBM is not set
# CONFIG_FBCON_IPLAN2P2 is not set
# CONFIG_FBCON_IPLAN2P4 is not set
# CONFIG_FBCON_IPLAN2P8 is not set
# CONFIG_FBCON_MAC is not set
# CONFIG_FBCON_VGA_PLANES is not set
CONFIG_FBCON_VGA=y
CONFIG_FBCON_HGA=m
# CONFIG_FBCON_FONTWIDTH8_ONLY is not set
CONFIG_FBCON_FONTS=y
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_PEARL_8x8 is not set
# CONFIG_FONT_ACORN_8x8 is not set


though I have tried removing one by one until I realized that this one line:
CONFIG_FB=y
when enabled will not allow me to complete the make bzImage... it aborts in the middle of compilation with an error saying that it is missing the fonts and can't find them and thus erroring out...
If I comment this line out then the make bzImage is successful, but during the reboot I get a blank screen after choosing this kernel for booting... ... progress, but not really...

would you Excalibur, or chr15t0 know exactly what lines my config file required before I run make dep ; make clean... etc.. ? there must be a subtle difference and I can feel I am only one or two steps away from successfully enabling the framebuffer without having to make oldconfig (as previously suggested, and done to the letter as stated above)... my config file is perfect for my system except for tux ... any pointers would be appreciated Thanks again.
 
Old 02-14-2003, 12:24 PM   #5
slackfan
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware
Posts: 20

Original Poster
Rep: Reputation: 0
quick update:
Doing a few searches on google, I found this:
http://www.linuxquestions.org/questions/history/40074
which talks about that to enable we only need to edit lilo.conf !... I will have to try this when I get home!
Quote:
The penguin picture on bootup is from the framebuffer stuff. In your lilo.conf file you should see some VESA framebuffer lines with text like "vga=791". To enable fb support comment out the line "vga=normal" and uncomment out the resolution that you want. I think I use vga=791 on my laptop. Run lilo when you are done.

There is some documentation on the framebuffer device and how to configure some graphics cards. The docs are in:

/usr/src/linux/Documentation/fb
also found a few other sites involving modifcation to this logo:

http://inoshiro.com/code/
Quote:
http://inoshiro.com/code/patches/tux_slackware.diff.gz
Slackware Logo for the Linux Kernel.
This patch (not written by me) will change the frame buffer boot logo in the Linux kernel to a nice Slackware logo (with Tux). It applies cleanly to the 2.2.x (2.2.16 and 2.2.17pre tested), and 2.4.x (2.4.0-test5 tested) series.
http://coredump.free.fr/linux/slack.html
Quote:
For those who interested in changing the logo that is displayed at boot time when the framebuffer is activated, here are some links plus my boot time logo (I'm fed up with Tux, so I chose QuickTimeİ one).

The logo in PNG format (LinuxSlackware-logo.png) and the same "directly" usable linux_logo.h (I've got to change fbcon.c to change the size of the logo)

fblogo allow you to convert a TIFF image into a C header file 'linux_logo.h'.

Here are some links that allowed me to use the framebuffer on my S3 Trio 64 (vesa 1.2):
www.colonel-panic.com/linux : this is the one I use on my 2.2.16 kernel (also tested on 2.2.13).
www.hut.fi/~hmallat/linux/s3.html : non tested.
and of course the Framebuffer-HOWTO:
http://tux.cprm.net/pub/slackware/sl...mebuffer-HOWTO

... all this has provided a plenty of reading to do tonight
 
Old 02-14-2003, 04:24 PM   #6
slackfan
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware
Posts: 20

Original Poster
Rep: Reputation: 0
quick update part 2:

More googling has brought up this step during make xconfig that I didn't think I required... I will try and make sure this is involved in the next kernel compile this evening sounds good from here:
http://web.gnu.walfield.org/mail-arc...uary/0128.html

Quote:
From: James A Simmons <jsimmons@acsu.buffalo.edu>
Date: Mon, 24 Jan 2000 08:57:17 -0500 (EST)
Subject: Re: Framebuffer & 2.3.39


Did you select Code maturity level Options and then checked the box for
prompt for developement and/or incomplete code/drivers.



P.S
I think its time to remove this. Fbdev has been around for a long time
now


Codito, ergo sum - "I code, therefore I am"
James Simmons (o_
fbdev/gfx developer (o_ (o_ //\
http://www.linux-fbdev.org (/)_ (/)_ V_/_
http://linuxgfx.sourceforge.net


On Sat, 22 Jan 2000, nsmith wrote:


> Hi again,
>
> I have been trying to compile the latest kernel with FB support, but the
> option doesn't appear (it's greyed out) within the xconfig option. Is there
> something missing? or do I need to use the text config program to set this
> up?
>
> BTW: I have noticed some of the post concerning complining kernel with the
> Althlon -- I have ran into the same problems and have had to compile the
> kermel using optimizations for the AMD K6 to get things to work.
>
> Nasa
>
>
>
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.rutgers.edu
> Please read the FAQ at http://www.tux.org/lkml/
>


 
Old 02-14-2003, 09:07 PM   #7
slackfan
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware
Posts: 20

Original Poster
Rep: Reputation: 0
whoo hoo! houston we have TUX!

final update on how to get tux back of a clean (2.4.20) kernel:
alright all looks very sweet at this point. I took james advice in the previous post :
Quote:
Did you select Code maturity level Options and then checked the box for prompt for developement and/or incomplete code/drivers.
during xconfig, made sure Code maturity level option was enabled in the kernel, and that I enabled:
[console drivers]->[Frame buffer support]
  • Support for frame buffer devices (EXPERIMENTAL)
    VESA VGA graphics console
    VGA 16-color graphics console
    NeoMagic display support (EXPERIMENTAL)
    [below selected by default]
    8bpp packed pixesl support
    16bpp packed pixesl support
    24bpp packed pixesl support
    32bpp packed pixesl support
    VGA 16-color planar support
    VGA 8x8 font
    VGA 8x16 font

... and recompiled and VIOLA! TUX IS IN THE BUILDING!...
Thanks for everyone's help, i will be sure to save this config file in a safe place

== ( && )

Thanks everyone for the assist!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new kernel compiled successfully, but the kernel-source package is the same old? luqman Red Hat 2 03-03-2005 09:41 AM
Missing tux logo in Sarge? uk_dave Debian 33 08-06-2004 08:17 PM
recompiled kernel not in use taoweijia Linux - Newbie 1 01-09-2004 09:33 AM
recompiled kernel and no vmlinuz.old or kernel module for Nvidia Bruce Hill Slackware 13 12-11-2003 02:36 AM
After recompiled my Mandrake Kernel, cdrom is missing hanxuerui Linux - Hardware 11 04-04-2003 11:48 AM


All times are GMT -5. The time now is 11:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration