LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-19-2011, 04:33 AM   #1
rsol4747
LQ Newbie
 
Registered: Oct 2003
Location: DFW
Distribution: slackware,suse
Posts: 18

Rep: Reputation: 0
"Kernel panic" :VFS: Unable to mount root fs on 08:05"


I have been dual booting "Windoz" (hda1) and slackware 11 (RTAI - hda 5) old system.
The problem happen after I installed slackware 13(sda8) on the same hard drive. I was able to mount my old slack11 (now (sda5)) to slack13 to read. So I wanted to boot to slack11.
MY Lilo on slack 13:
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda8
label = Slackware13
read-only
# Linux bootable partition config ends
# Linux bootable partition config begins

image = /rtai/boot/vmlinuz
root= /dev/sda5
label= "Slackware11"
read-only
# Linux bootable partition config ends

Now when I boot to Slackware11 I get:

VFS: Cannot open root device "805" or 08:05
Please append a correct "root=" boot option
Kernel panic :VFS: Unable to mount root fs on 08:05

How can I boot a old "hda" image on "sda" system.
With a floppy I can go back to Slackware11. Need help?

Last edited by rsol4747; 04-20-2011 at 04:13 AM. Reason: clearity of answer
 
Old 04-19-2011, 08:44 AM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
*** FAULTY ******

Just change this
Code:
image = /rtai/boot/vmlinuz
root= /dev/sda5
label= "Slackware11"
read-only
# Linux bootable partition config ends
to this
Code:
image = /rtai/boot/vmlinuz
root= /dev/hda5
label= "Slackware11"
read-only
# Linux bootable partition config ends
make sure /rtai/boot/vmlinuz is reachable (mounted) and run lilo. The root= parts are passed to the kernel on boot up so they are not checked when you install lilo. Slackware 11 is expecting the drive to be /dev/hda and Slackware 13 /dev/sda.

Last edited by bgeddy; 04-20-2011 at 05:48 AM. Reason: Bad Information
 
Old 04-20-2011, 12:49 AM   #3
rsol4747
LQ Newbie
 
Registered: Oct 2003
Location: DFW
Distribution: slackware,suse
Posts: 18

Original Poster
Rep: Reputation: 0
After I changed the /dev/sda5 to /dev/hda5, I received the following error.

Sorry: Fatal: Illegal 'root=' specification: /dev/hda5

I tried combinations of "hda5" with "fstab" & "mtab" no success.

Is their a command that would allow /dev/sda5 = /dev/hda5 in "lilo" thru append. I don't know.

I have tried the reverse used the floppy to move back to slackware11 than I tried to boot slack13. I could mount, but could not boot to slack13

Last edited by rsol4747; 04-20-2011 at 04:11 AM.
 
Old 04-20-2011, 01:46 AM   #4
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
I don't know if this already worked in slackware-11, but you could try specifying root by UUID or LABEL - take a look at 'man lilo.conf'
 
Old 04-20-2011, 03:14 AM   #5
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
There are some questions about your lilo.conf.
Did lilo run without any errormessages?
Why did you insert quotationmarks in the line
Quote:
label="Slackware11"
If Slack11 recognizes your disk as /dev/hda and Slack13 as /dev/sda, I'd suggest to boot Slack11 like Windows (with "other"). Change the lilo.conf in you old Slackware-11 installation from "boot=/dev/hda" to "boot=/dev/hda5". This will write your Slack11 lilo onto the mbr of the partition (not the disk).

Then add Slack11 like Windows with "other" in lilo.conf of the Slackware-13 installation.
Code:
other = /dev/sda5
label = Slack-11
...
don't forget to boot Slack-11 and execute lilo there. You may remove the line "Prompt" in your lilo.conf in Slackware-11, since you'll not have to chose an operatingsystem there.

Markus
 
Old 04-20-2011, 04:39 AM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,344

Rep: Reputation: 184Reputation: 184
try this
Quote:
image = /rtai/boot/vmlinuz
root= /dev/sda5
label= "Slackware11"
read-only
append = "root=/dev/hda5"
# Linux bootable partition config ends

Last edited by colorpurple21859; 04-20-2011 at 04:45 AM.
 
Old 04-20-2011, 05:16 AM   #7
rsol4747
LQ Newbie
 
Registered: Oct 2003
Location: DFW
Distribution: slackware,suse
Posts: 18

Original Poster
Rep: Reputation: 0
Colorpurple21859: The "append" did it I was able to go back to 13 and make changes.

Thanks so much. Great fix mix mode of new "sda" and old "hda". Thanks
 
Old 04-20-2011, 05:34 AM   #8
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
After I changed the /dev/sda5 to /dev/hda5, I received the following error.

Sorry: Fatal: Illegal 'root=' specification: /dev/hda5
Oops ! I think I owe you an apology. I have just tested this on my system and I now see my advice was very wrong. I was under the impression that lilo did not check the root setting until it booted. I'm sure it used to be that way but I may be mixed up there.

Sorry for leading you astray. I should have tested my recommendation before posting as I usually always do. In any case I'm glad you managed to fix your problem thanks to colorpurple21859's idea.

Edit: I hope no one minds but I have added to my original post flagging it as being incorrect - just in case anyone reads the first reply to the problem and tries to implement my original fix which won't work.

Last edited by bgeddy; 04-20-2011 at 05:52 AM. Reason: Addition to original post
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Startup problem: "VFS: Unable to mount root fs on 03:03" dbany Linux - Newbie 4 08-07-2009 10:34 AM
"Kernel panic: VFS: Unable to mount root fs" - Kernel fails to boot linux Freedom Seeker Linux - General 11 11-12-2006 07:48 PM
Common problems explained: "kernel panic - not syncing", "unable to mount..." sundialsvcs Linux - Newbie 2 03-01-2006 12:17 PM
Possible solution to common "unable to mount root fs" kernel panic while installing pergesu Linux - Software 2 12-26-2005 03:11 PM
error:"kernel panic: VFS: Unable to mount root fs":-( shyguy Linux - Newbie 1 07-23-2001 04:03 PM


All times are GMT -5. The time now is 08:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration