LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-03-2007, 03:36 AM   #1
bijit1709
Member
 
Registered: Oct 2006
Location: Costa Rica, Escazu
Distribution: Slackware 12.0 (2.6.21.5)
Posts: 67

Rep: Reputation: 15
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block


Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,1)

Hi everyone,

i have been trying to install kernel-generic-2.6.17.13 and i get the kernel panic error from above. I have installed the header and the modules. And created a initrd for ext3. AND I STILL GET THAT ERROR OR KERNEL PANIC - ATTEMPING TO KILL INIT. i have ln system, vmlinuz and rc.modules and still don't get it to work. I tried it from bareacpi.i and huge26.s my hdd is a ata. If someone has the solution for this i would hight appreciate it. Or please let me know what i am doing wrong. by the way i also edited lilo. with the vmlinuz-generic-smp and added initrd = /boot/initrd.gz. i will be waiting for your replies thanks...


bijit
 
Old 06-03-2007, 03:38 AM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I don't think you need an initrd for ext3. And from the looks of it, your lilo is pointing to the wrong partition. Are you sure that root is on the second partition of the fourth disk?
 
Old 06-03-2007, 07:20 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,215
Blog Entries: 3

Rep: Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437
Quote:
Originally Posted by bijit1709
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,1)

Hi everyone,

i have been trying to install kernel-generic-2.6.17.13 and i get the kernel panic error from above. I have installed the header and the modules. And created a initrd for ext3. AND I STILL GET THAT ERROR OR KERNEL PANIC - ATTEMPING TO KILL INIT. i have ln system, vmlinuz and rc.modules and still don't get it to work. I tried it from bareacpi.i and huge26.s my hdd is a ata. If someone has the solution for this i would hight appreciate it. Or please let me know what i am doing wrong. by the way i also edited lilo. with the vmlinuz-generic-smp and added initrd = /boot/initrd.gz. i will be waiting for your replies thanks...


bijit
Hi,

Did you run lilo as root from the console? Just editing the lilo.conf with the proper stanza without writing will get you nothing.

Did you follow the '/boot/README.initrd' procedures?
 
Old 06-03-2007, 01:05 PM   #4
bijit1709
Member
 
Registered: Oct 2006
Location: Costa Rica, Escazu
Distribution: Slackware 12.0 (2.6.21.5)
Posts: 67

Original Poster
Rep: Reputation: 15
I only have two partitions hda1=/ and hda2=swap. On lilo i have root = /dev/hda1. Yes i ran lilo as root on the console. And also followed /boot/README.initrd. this is all that I did.

Quote:
mount /mnt/cdrom
cd /mnt/cdrom
installpkg * #the disk only has 3 files(kernel generic, kernel headers and kernel modules$)
cd /boot
ln -s System.map-generic-smp-2.6.17.13
ln -s vmlinuz-generic-smp-2.6.17.13
mkinitrd -c -k 2.6.17.13-smp -m jbd:ext -f ext3 -r /dev/hda1
cd /etc/rc.d/
ln -s rc.modules-generic-smp-2.6.17.13
vim /etc/lilo
image = /boot/vmlinuz
initrd = /boot/initrd.gz
:wq
lilo
That is all that i did. On the /boot the initrd.gz is red. It shouldn't be in the same color as the vmlinuz? Please reply back since my comp is in standby until i can fix it...
 
Old 06-04-2007, 07:00 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,215
Blog Entries: 3

Rep: Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437
Hi,

Your line is not correct;
Quote:
mkinitrd -c -k 2.6.17.13-smp -m jbd:ext -f ext3 -r /dev/hda1
should be;
Code:
mkinitrd -c -k 2.6.17.13-smp -m jbd:ext3 -f ext3 -r /dev/hda1
Also post your lilo.conf. What is your boot device?
 
Old 06-04-2007, 10:30 AM   #6
bijit1709
Member
 
Registered: Oct 2006
Location: Costa Rica, Escazu
Distribution: Slackware 12.0 (2.6.21.5)
Posts: 67

Original Poster
Rep: Reputation: 15
This is my boot device. The line i just missed the 3 but i had it the same as you did.

Quote:
boot = /dev/hda

root = /dev/hda1
 
Old 06-04-2007, 10:35 AM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,215
Blog Entries: 3

Rep: Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437
Quote:
Originally Posted by bijit1709
This is my boot device. The line i just missed the 3 but i had it the same as you did.
Hi,

That's why you should use the cut&paste instead of typing. Wastes everyones time!

BTW, would you post the /etc/lilo.conf file as requested?
 
Old 06-04-2007, 10:39 AM   #8
bijit1709
Member
 
Registered: Oct 2006
Location: Costa Rica, Escazu
Distribution: Slackware 12.0 (2.6.21.5)
Posts: 67

Original Poster
Rep: Reputation: 15
Here you go. Apologize for the typo.

Quote:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot="/dev/hda"
message = /boot/boot_message.txt
prompt
timeout="100"
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga="773"
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga = 791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins

image="/boot/vmlinuz-generic-smp-2.6.17.13"
initrd = /boot/initrd.gz
root="/dev/hda1"
label="Slackware"
read-only
# Linux bootable partition config ends
 
Old 06-04-2007, 10:53 AM   #9
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,215
Blog Entries: 3

Rep: Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437
Hi,

lilo.conf looks OK. Try as root from console;

Code:
lilo -v -t -b /dev/hda     #this will test the lilo.conf
lilo -v -b /dev/hda        #will write the lilo MBR
If you have any errors for the first command above then post them.
If no errors then try the second. This will write to the 'MBR' of /dev/hda. I would also suggest the use of the 'compact' option in the lilo.conf.

I would 'man lilo.conf' for understanding.
 
Old 06-05-2007, 05:57 PM   #10
animeresistance
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 191

Rep: Reputation: 20
Hi !
I had the same problem like you many years in the past I found that this happened when i separated some directories of linux (honestly i don't remember what are the name of those directories, maybe one is the /boot) in different hard disks, and when you recompiled the kernel, copied and moved all the stuff and modified lilo to start the new kernel. The mount point of the new kernel was pointing to another part.

The point in here is check your configuration, and start playing what directories you can move with the hard disks without making this error happens (i found that you can have /home safely in another directory, maybe the /tmp is another afe one to move).

Good luck
 
Old 06-05-2007, 10:07 PM   #11
hottdogg
Member
 
Registered: Aug 2004
Location: aisenodni
Distribution: slackware 64bit ,debian 64bit
Posts: 202

Rep: Reputation: 30
This is just a shot in the dark...what if you replace any hda word with sda in your lilo.conf and in /etc/fstab . I know u use paralel ata,but just give it a try....
And then don't forget to run lilo again.
(boot and mount to your slackware partition via liveCD or slackware install CD,of course).
It may still not work,though
 
Old 06-08-2007, 04:38 PM   #12
bijit1709
Member
 
Registered: Oct 2006
Location: Costa Rica, Escazu
Distribution: Slackware 12.0 (2.6.21.5)
Posts: 67

Original Poster
Rep: Reputation: 15
I have found the error. The error for the 2.6.# is that the vga doesn't work. In order to see the booting process I have to give vga=normal. But I still have problems When give command:

Code:
# startx
Its gives some error and says it doesn't support my screen depth. Any screen depth I put. And when I do:

Code:
# shutdown -r 0
it says rebooting . and it doesn't do anything after and it doesn't reboot. Do you think its the same problem with the vga?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic - not syncing:VFS: Unable to mount root fs on unknown-block (1,0) Zenx Linux - Kernel 12 08-04-2010 05:33 AM
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) OR13 Linux - Kernel 18 01-12-2008 09:23 AM
Kernel panic - not syncing : VFS: Unable to mount root fs on unknown block(0,0) Merlinator Ubuntu 1 03-05-2007 04:18 AM
kernel panic - not syncing : VFS: unable to mount root FS on unknown-block kaplis Linux - Software 1 09-19-2006 01:44 AM
kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(3,2) o2bfishn Slackware 5 04-28-2006 03:51 PM


All times are GMT -5. The time now is 05:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration