LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Kernel panic - not syncing: VFS: unable to mount root fs on uknown-block(253,0) (http://www.linuxquestions.org/questions/slackware-14/kernel-panic-not-syncing-vfs-unable-to-mount-root-fs-on-uknown-block-253-0-a-4175492093/)

fjur94 01-21-2014 10:43 PM

Kernel panic - not syncing: VFS: unable to mount root fs on uknown-block(253,0)
 
SLACKWARE LINUX 14.0

/dev/sda1 = /boot
/dev/sda2 = LVM Partition
/dev/lvfelix/swap = swap
/dev/lvfelix/var = /var
/dev/lvfelix/root = /
/dev/lvfelix/usr = /usr
/dev/lvfelix/opt = /opt
/dev/lvfelix/home = /home

After the installation finished and i boot the operating system this message shows up(see link below)

(picture)
http://postimg.org/image/3nvdh48ex/

markush 01-22-2014 02:08 AM

Hello fjur94, welcome to LQ,

I suppose you're using a generic kernel?

Seems your missing either the driver for the filesystem (ext4?) or the disk (ahci or ide?) in your initrd.

In general your errormessage means that the kernel cannot mount the / partition due to missing drivers.

I'd recommend to post Slackware-related issues in the Slackware-forums at LQ. I'll report this thread and ask for moving to the Slackware-Forums.

Markus

ChrisAbela 01-22-2014 05:34 AM

/var on a separate partition might not have been a good idea but I cannot locate the document I vaguely remember recommending against it so I cannot be sure.

Did you build an initrd? How?
Did you include the entry for initrd it in /etc/lilo.conf?
Did you run lilo -v after editing /etc/lilo.conf

Richard Cranium 01-22-2014 07:21 PM

http://www.linuxquestions.org/questi...9/#post5103222

Please don't double post your problem in the forum again.

fjur94 01-22-2014 09:25 PM

Sorry Richard

Chris, no i have not done that :S

Richard Cranium 01-22-2014 09:48 PM

No problem, it's just slightly annoying to have to post a reply in two different places.

fjur94 01-24-2014 03:02 PM

i made this vídeo during the installation, the most important part is when it is installing packages

See link below
http://www.youtube.com/watch?v=CsXP3Lb54ao

Note: i'm speaking spanish in the video

markush 01-24-2014 03:12 PM

Hi,

at least one problem is quite obvious. You use a partition with only 1 GB of size for your /usr directory, this is way too small. I don't know how lvm comes into play, but there are errormessages about "no space left on device". But I would recommend to create only three partitions, /, /home and /swap (if necessary) and you should know that after a complete installation, there are about 7GB used on /

Markus

Richard Cranium 01-24-2014 03:16 PM

One of your disk partitions filled up during the install. At that point, your system is insane. See which of the partitions is close to full, make it larger and reinstall from scratch.

(By the way, I've been there and done that.)

I've installed other things on this Slackware64 14.1 machine, but my current partition use is
Code:

~$ df -h
Filesystem                    Size  Used Avail Use% Mounted on
/dev/mapper/vg1-rootlv        10G  1.2G  8.8G  12% /
/dev/sda2                    488M  39M  415M  9% /boot
/dev/mapper/vg1-homelv        32G  1.5G  31G  5% /home
/dev/mapper/vg1-varlv          20G  829M  20G  5% /var
/dev/mapper/vg1-optlv          16G  2.2M  16G  1% /opt
/dev/mapper/vg1-usrlv          20G  7.5G  13G  38% /usr
/dev/mapper/vg1-libvirtstore  121G  60M  115G  1% /var/lib/libvirt/images
tmpfs                        3.8G    0  3.8G  0% /dev/shm
tmpfs                        3.8G  33M  3.7G  1% /tmp

You'll note that a lot of stuff goes into /usr, which tends to be the one that fills up. My use of tmpfs for /tmp is not considered standard behavior but I reboot this laptop often.

fjur94 01-25-2014 12:56 AM

i resized the /usr partition, everything seems to be well with the installation but while booting another message appeared

See link below
http://postimg.org/image/o7ggy2zij/

markush 01-25-2014 04:49 AM

Please boot your install-CD and post the ouput of
Code:

fdisk -l
and then mount your /
Code:

mkdir /mnt/tmp/
mount /dev/rootpartition /mnt/tmp

where rootpartition is the device where your / resides. Then postthe output of
Code:

cat /mnt/tmp/etc/fstab
Furthermore I'd like to see the output of
Code:

ls -lh /mnt/tmp/boot
And please don't put your screenshots on external sites, LQ allows for upload of images, when you're writing your post look below at "Manage Attachments"

Markus

Richard Cranium 01-25-2014 07:55 AM

The OP will have to run
Code:

/sbin/vgchange -ay --ignorelockingfailure
prior to attempting to mount the root directory.

I would also like to know the mkinitrd command used to create the initrd.

fjur94 01-25-2014 02:02 PM

3 Attachment(s)
mkinitrd command:
chroot
$( /usr/share/mkinitrd/mkinitrd_command_generator.sh -r )

Changed lilo.conf

Code:

image = /boot/vmlinuz-generic-smp-3.2.29-smp
initrd = /boot/initrd.gz
root = /dev/lvfelix/root
label = Linux
read-only

i reinstalled again, but i have not reboot yet(im not sure how to boot from cd with vmware, thats why i reinstalled.)

(pictures shows fdisk -l and df -h)

fjur94 01-25-2014 02:29 PM

1 Attachment(s)
markush /mnt/tmp already exist

note: Have not rebooted yet, the system will be damaged again if i start it :s

picture shows (ls -lh /mnt/tmp/boot) and (cat /mnt/tmp/etc/fstab)

markush 01-25-2014 02:31 PM

Don't forget to run lilo again after creating a new initrd!

I use to have a "failsafe" option in my lilo.conf which means that I have also the huge-kernel available. This helps when there is something wrong with the initrd or the modules. Here the lines of my lilo.conf
Code:

# Linux bootable partition config begins
image = /boot/vmlinuz
  initrd = /boot/initrd.gz
  append = "resume=/dev/sda9"
  root = /dev/sda5
  label = Slack64-current
  read-only
###
image = /boot/vmlinuz-huge-3.10.17
  append = "resume=/dev/sda9"
  root = /dev/sda5
  label = failsafe
  read-only
# Linux bootable partition config ends

I can't help with lmv. But I would recommend to boot the huge kernel in order to find out if the problem is related to initrd or lvm.

Markus


All times are GMT -5. The time now is 08:51 AM.