LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Kernel Panic - Not Syncing VFS: unable to mount root file system (http://www.linuxquestions.org/questions/slackware-14/kernel-panic-not-syncing-vfs-unable-to-mount-root-file-system-441723/)

push 05-04-2006 09:05 PM

Kernel Panic - Not Syncing VFS: unable to mount root file system
 
Alright I already know the problem is most likely when I made changes to the lilo.conf and wrote it to the MBR I didn't specify to use the reiser fs, but now I can't boot up Slackware. I have an auditor cd and put that in and tried to make the changes and then run lilo, but of course it runs the auditor lilo, so I tried running /mnt/hda2/sbin/lilo and it complains that the kernel differs or something. So the question now is how do I write the new lilo.conf to the MBR. This all started when I made changes to initrd.gz and lilo.conf to enable bootsplash. Any ideas? I have restored my backups of initrd.gz and lilo.conf. I am running the 2.6.15.3 linux kernel.

ataraxia 05-04-2006 09:39 PM

Code:

chroot /mnt/hda2 /sbin/lilo

Acron_0248 05-05-2006 01:51 AM

Correct me if I'm wrong, but the Kernel Panic VFS message occurs when you have a kernel that has the filesystem support for the HD that has linux installed, compiled as a module when it should be compiled "into" the kernel, not as a module....



Regards

onebuck 05-05-2006 08:36 AM

Quote:

Originally Posted by Acron_0248
Correct me if I'm wrong, but the Kernel Panic VFS message occurs when you have a kernel that has the filesystem support for the HD that has linux installed, compiled as a module when it should be compiled "into" the kernel, not as a module....



Regards

Hi,

Yes! If you want to use a module for your FS then you must create a initrd. Then add the initrd to the stanza of the lilo.conf. And run lilo to update the lilo on the mbr.

push 05-05-2006 07:49 PM

Quote:

Originally Posted by ataraxia
Code:

chroot /mnt/hda2 /sbin/lilo

Thank you that worked :)

push 05-05-2006 07:51 PM

Quote:

Originally Posted by gwsandvik
Hi,

Yes! If you want to use a module for your FS then you must create a initrd. Then add the initrd to the stanza of the lilo.conf. And run lilo to update the lilo on the mbr.

Yeah that's what I have done, I chose a bad initrd and it caused the panic. Fixed the problem and ran lilo and it's working again :)

gau_veldt 08-28-2006 07:07 AM

does udev need initrd?
 
Quote:

Originally Posted by push
Yeah that's what I have done, I chose a bad initrd and it caused the panic. Fixed the problem and ran lilo and it's working again :)

running 2.6.12 using udev and the FS for reiser2 (the type on /dev/hda2 which happens to be the drive on my root= parameter)

I get the same error VFS: Unable to...on unknown block(0,0)
under these circumstances

I think udev is the name to my pain and I have a hunch a /dev node needs to exist in an initrd for udev to work (to make hda2 visible) so the kernel can mount it

Or is there something I'm overlooking?

rkelsen 08-28-2006 08:06 AM

Quote:

Originally Posted by gau_veldt
running 2.6.12 using udev

Which version of udev? The latest versions of udev require a 2.6.15 kernel as a minimum.

gau_veldt 08-28-2006 08:17 AM

Quote:

Originally Posted by rkelsen
Which version of udev? The latest versions of udev require a 2.6.15 kernel as a minimum.

I had this kernel running (on a previous build) until I lost the initrd support in a new kernel rebuild. I have a udev that wanted 2.6.10+ won't know its version until this kernel I'm trying to get to work will go and I'm not using a LFS rescue disk to mount my system to fix whatever was wrong.

To make the long sad story short dpkg did what the dox said it shouldn't: namely deleting the currently active kernel. I'm surprised I didn't get a panic on the spot when dpkg pulled that stunt.

so I have no system (aside from an LFS rescue disk) until this rebuild of the kernel decides to get past the VFS problem (again I think disabling initrd support via menuconfig had something to do with it--I took it out becuase on *that* build I had panic issues stemming from an initrd enabled kernel not finding an initrd file, oh and the symlink I had to add to the initrd becuase make-kpkg seemed to have compiled the kernel to use one version name and set the module directory in the initrd otherwise).

The joys of surrogately mounting the filesystems and using
Code:

chroot /mountedroot/ bash
so I can recompile the kernel until it decides to work

UPDATE: I've got the kernel rebuilt and working again so that means the initrd support is required for udev (and it's 076 btw).


All times are GMT -5. The time now is 04:00 AM.