LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-31-2009, 11:44 PM   #1
vttay03
LQ Newbie
 
Registered: Dec 2009
Location: USA
Distribution: Slackware64 14.0
Posts: 29

Rep: Reputation: 3
Kernel panic - not syncing


Hi all--

I've been using Linux for awhile and have recently decided to give Slackware a try since I've read good things. Anyways - to test it out I am using an external hard drive that is connected to an eSata port on my motherboard. During installation I disconnected my internal hard drives just to be on the safe side to make sure that I wouldn't accidentally erase everything. After I installed Slackware and BEFORE I reconnected the internal hard drives, it booted fine. However, after I connected the internal hard drives and tried to boot again, I got this ugly message: "Kernel panic - not syncing: no init found. Try passing init= option to kernel." I then went in and edited lilo.conf to reflect the right drive (i.e. /dev/sda or /dev/sdb, etc.). Afterwards, it still wouldn't boot. Can anyone point me in the right direction?
 
Old 12-31-2009, 11:56 PM   #2
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,019

Rep: Reputation: 63
Quote:
Originally Posted by vttay03 View Post
Hi all--

I've been using Linux for awhile and have recently decided to give Slackware a try since I've read good things. Anyways - to test it out I am using an external hard drive that is connected to an eSata port on my motherboard. During installation I disconnected my internal hard drives just to be on the safe side to make sure that I wouldn't accidentally erase everything. After I installed Slackware and BEFORE I reconnected the internal hard drives, it booted fine. However, after I connected the internal hard drives and tried to boot again, I got this ugly message: "Kernel panic - not syncing: no init found. Try passing init= option to kernel." I then went in and edited lilo.conf to reflect the right drive (i.e. /dev/sda or /dev/sdb, etc.). Afterwards, it still wouldn't boot. Can anyone point me in the right direction?
Post:
Code:
su
password:
fdisk -l
cat /etc/lilo.conf
 
Old 01-01-2010, 12:10 AM   #3
vttay03
LQ Newbie
 
Registered: Dec 2009
Location: USA
Distribution: Slackware64 14.0
Posts: 29

Original Poster
Rep: Reputation: 3
I think this may have answered my question. My Slackware build is on /dev/sdc - it seems I need to change the first line in lilo.conf to boot = /dev/sdc1 instead of /dev/sdc. See info requested below:

fdisk -l
Code:
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1549f232

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       37725   303026031    7  HPFS/NTFS
/dev/sda3           37726       38913     9542610    c  W95 FAT32 (LBA)

Disk /dev/sdc: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0008c72b

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1       13738   110350453+  83  Linux
/dev/sdc2           13739       14593     6867787+  82  Linux swap / Solaris

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7876a9a3

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       19791   158968640    7  HPFS/NTFS
/dev/sdb2           19792       38913   153597465    5  Extended
/dev/sdb5           19792       38132   147324051   83  Linux
/dev/sdb6           38133       38913     6273351   82  Linux swap / Solaris
cat /etc/lilo.conf
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sdc

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and 
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
 
Old 01-01-2010, 02:41 AM   #4
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,019

Rep: Reputation: 63
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
No linux in /dev/sda1,may be it's /dev/sdc1 or /dev/sdb5
Code:
/dev/sdc1   *           1       13738   110350453+  83  Linux
/dev/sdb5           19792       38132   147324051   83  Linux
 
Old 01-01-2010, 10:04 AM   #5
vttay03
LQ Newbie
 
Registered: Dec 2009
Location: USA
Distribution: Slackware64 14.0
Posts: 29

Original Poster
Rep: Reputation: 3
Changed

Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
to
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sdc1
  label = Linux
  read-only
# Linux bootable partition config ends
Like you said, the Slackware install is on /dev/sdc1. However, I still get the same "Kernel panic" output when trying to boot. After I did the install everything booted fine before I reconnected my internal hard drives. Once I did this, it reordered my drive enumeration to sda, sdb, and sdc (the Slackware drive). Whereas before I only had the one hard drive connected, the Slackware install defaulted to sda. Is there any other configuration file that could be pointing to sda instead of sdc? Lilo seems to be installed properly as it comes up with Slackware Linux as my only option. Any other thoughts?
 
Old 01-01-2010, 10:11 AM   #6
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,019

Rep: Reputation: 63
Quote:
Originally Posted by vttay03 View Post
Changed

Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends
to
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sdc1
  label = Linux
  read-only
# Linux bootable partition config ends
Like you said, the Slackware install is on /dev/sdc1. However, I still get the same "Kernel panic" output when trying to boot. After I did the install everything booted fine before I reconnected my internal hard drives. Once I did this, it reordered my drive enumeration to sda, sdb, and sdc (the Slackware drive). Whereas before I only had the one hard drive connected, the Slackware install defaulted to sda. Is there any other configuration file that could be pointing to sda instead of sdc? Lilo seems to be installed properly as it comes up with Slackware Linux as my only option. Any other thoughts?
I have installed grub,but the contents of lilo.conf was:
Code:
image = /boot/vmlinuz-generic-smp-2.6.29.6-smp
  initrd = /boot/initrd.gz
  root = /dev/hda8
  label = Linux
  read-only
# Linux bootable partition config ends
Do you have other linux distribution installed?
 
Old 01-01-2010, 10:15 AM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,050
Blog Entries: 1

Rep: Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373
Hi,

You need to run 'lilo' again as root. By changing the '/etc/lilo.conf' you must re-run as root 'lilo' to update the bootloader on the 'MBR'.

When you had the other drive disconnected the 'lilo.conf' was generated for install configuration. You then reconnected the hdd and the configuration changed thus the 'kernel panic'.

Code:
~#lilo -v -t -b /dev/your_device    #test the configuration
~#lilo -v -b /dev/your_devcie       #write 'MBR' to your_device
The first command on the 'cli' will test your '/etc/lilo.conf'. If no errors then the second line will write to the 'MBR' of your_device.

I suggest that you read 'man lilo' and 'man lilo.conf'.


Just a few links to aid you;

SlackwareŽ Essentials
SlackwareŽ Basics
Linux Documentation Project
Rute Tutorial & Exposition
Linux Command Guide
Utimate Linux Newbie Guide
LinuxSelfHelp
Getting Started with Linux
Advanced Bash-Scripting Guide
Virtualiation- Top 10

The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 01-01-2010, 09:14 PM   #8
vttay03
LQ Newbie
 
Registered: Dec 2009
Location: USA
Distribution: Slackware64 14.0
Posts: 29

Original Poster
Rep: Reputation: 3
This is what I ended up doing in order to get everything working together:

1) I reinstalled Slackware with all of the hard drives connected so that there wouldn't be any issues with drive letters

2) When prompted for the LILO install I installed it to the root drive, NOT the MBR (which would have screwed my Windows drive up)

3) I edited the 40_custom file for GRUB2 in my Ubuntu install and added an entry for Slackware to chain-load LILO from GRUB2

Thanks for everyone's inputs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic - not syncing desdenova Mandriva 2 08-08-2009 07:28 PM
Kernel Panic - not syncing lazylogic Slackware 10 04-18-2008 04:13 AM
kernel panic - not syncing luzyS Linux - Newbie 1 04-12-2008 07:50 AM
kernel panic - not syncing kgandhi5 Linux - Newbie 5 12-08-2007 09:48 PM
Kernel panic - not syncing darkarcon2015 Slackware 7 11-01-2005 09:02 PM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration