LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-09-2006, 08:15 PM   #1
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Rep: Reputation: 30
Kernel Panic (init) with Slack and Grub


My grub boot looks something like(from the grub prompt):

root (hd0,0)
kernel /vmlinuz

where hda1 is my /boot partition.

So it appears to find the kernel fine, but when it tries to load init, it gets
Code:
Warning: unable to open an initial console.
Kernel panic - not syncing: No init found.  Try passing init= option to kernel.

Now, correct me if I am wrong, but Slack shouldn't need an init to boot.

Could it be I have the wrong kernel? I was forced to install by USB, and so couldn't load a new kernel, and when I got to the "select your kernel" screen, I skipped it, and used the default kernel.

(my Thinkpad X30 does not have floppy or CDROM)

Anyway, Can anyone tell me how to get by this and get into slack?

Cheers(!)
Dia

Last edited by Diademed; 01-09-2006 at 10:04 PM.
 
Old 01-10-2006, 12:23 AM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
root (hd0,0)
kernel /vmlinuz
You have part of the info correct. You need to use GRUB syntax to tell GRUB where the kernel resides. You also need to boot with the root partition read-only. Something like this:

title Slackware 10.2 - 2.4.31 - KDE 3.4.2
kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 ro

If you have installed everything on one partition (hda1 / hda0,0) then be sure to add the /boot prefix to vmlinuz. Also notice that although GRUB begins counting partition and devices with zero, the kernel counts the first partition as hda1.
 
Old 01-10-2006, 05:47 PM   #3
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Woodsman
You have part of the info correct. You need to use GRUB syntax to tell GRUB where the kernel resides. You also need to boot with the root partition read-only. Something like this:

title Slackware 10.2 - 2.4.31 - KDE 3.4.2
kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 ro

If you have installed everything on one partition (hda1 / hda0,0) then be sure to add the /boot prefix to vmlinuz. Also notice that although GRUB begins counting partition and devices with zero, the kernel counts the first partition as hda1.
That's not quite right... the root command sets the root directory for grub, so you no longer have to give the full path for the kernel.

In any case, this seems to just be an issue with grub 0.97 on my system. 0.95 works fine.
 
Old 01-10-2006, 06:02 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
In any case, this seems to just be an issue with grub 0.97 on my system. 0.95 works fine.
Interesting. I'm using 0.97. I've had no boot-related issues arise.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic: no init found. Try passing init= option to kernel. ericb Slackware - Installation 3 10-20-2005 11:03 AM
grub runs then: Kernel Panic: unable to mount 03:00, slack 10.0 chrisidaho Slackware 8 02-09-2005 02:47 PM
Kernel Panic: No init found. Try passing init=option to Kernel Bamse123 Linux - Newbie 3 08-13-2004 04:56 AM
slack 9.1 install, kernel panic no init found wincen Slackware 0 11-24-2003 03:49 AM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 03:38 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration