LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2006, 07:57 PM   #1
LearningToLive
LQ Newbie
 
Registered: Jan 2006
Distribution: Kubuntu Dapper Drake
Posts: 7

Rep: Reputation: 0
Kernel Panic after trying to update Kernel to 2.6 several times


I'm trying to update my Slackware 10.2 Kernel from 2.4.31 to 2.6.13 using the pre-compiled kernel from the second Slackware installation cd. I followed every step in the README.initrd, and have done this a few times, and I keep getting the same error whenever I try to boot to the updated kernel from LILO. Goes something like this:



Code:
VFS: Cannot open root device "303" or unknown-block(3,3)
Please append a correct "root=" boot option
Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,3)

Now this is what I did to update to 2.6:

Code:
cd /mnt/cdrom/linux-2.6.13
installpkg kernel-generic-2.6.13-i486-1.tgz
installpkg kernel-modules-2.6.13-i486-1.tgz
Then from the boot folder:

Code:
cd /boot
mkinitrd -c -k 2.6.13 -m reiserfs
I then precided to update my lilo.conf:

Code:
pico /etc/lilo.conf

#Start Linux 2.6.13
image = /boot/vmlinuz-generic-2.6.13
  initrd = /boot/initrd.gz
  root = /dev/hda3
  label = Linux_2.6
  read-only
#End Linux 2.6.13

Ctrl-X
Y
ENTER

/sbin/lilo

Then I rebooted my system, selected the Linux_2.6 from LILO and got that error as it loaded. I've done this multiple times with multiple variations of this method, and got the same thing every time. Any idea how to fix this, or a better method of updated my kernel to 2.6? Any help would be appreciated, thank you.
 
Old 01-15-2006, 08:10 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
I think this line should be something like;
initrd=/boot/initrd-generic-2.6.13.img
See if this helps;
http://www.tuxmachines.org/node/2652
You can cd to /boot then ls to see what is there ...
 
Old 01-15-2006, 09:59 PM   #3
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Why deal with initrd?

It's just another layer of complexity. Try to recompile your own kernel following Shilo's sticky: How I did it all.

Just remember to make sure you include your filesystem in the compile, and not as a module. The kernel needs this info long before the modules load.

The other advantage to compiling your own kernel is you only include what you/your hardware needs.
 
Old 01-16-2006, 02:11 AM   #4
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
Smile

Hi There,

I run Slackware 10.1 - w.kernel 2.4.29 and recently upgraded to kernels 2.6.15 and ..14

I downloaded the kernal from: kernal.org

I then followed 2 artilces (mostly) on the web - the forum is not allowing me to post URLS untill i have made at least 5 posts.

If you are interested in the articles email me and i will give you the links. Both demonstrated compiling the new kernal without messing with the old one + adding two entries into LILO.conf file so as to retain the OLD settings and test the NEW kernel..

Worked a treat for me

//Graz
graz@veritel.com.au

I hope this helps..
 
Old 01-16-2006, 05:40 PM   #5
LearningToLive
LQ Newbie
 
Registered: Jan 2006
Distribution: Kubuntu Dapper Drake
Posts: 7

Original Poster
Rep: Reputation: 0
Okay, I just tried compliling my own kernel 2.6.15 using the "How I did it all" sticky and it just gave me the same error. Maybe I'm not selecting the right options in the gconfig?
 
Old 01-16-2006, 06:45 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,205

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Sounds more like a fstab issue. Make sure it matches for your root partition.
Also make sure you note cwwilson721 comments re selecting all your filesystem types in the kernel.
 
Old 01-18-2006, 04:05 AM   #7
mrapathy
Member
 
Registered: Nov 2005
Distribution: debian/slackware
Posts: 90

Rep: Reputation: 17
use install cd check your partition table with cfdisk make sure your root is proper address. try booting to your root with test26.s kernel that or boot the installation cd then mount and chroot your install partition rerun lilo. had that same problem forget what all I had to juggle. was a pita. I had my /proc directory screwed up. had to reinstall a directory packages.

except for my newest computer I have been running 2.6 flawlessly for months. newest computer bleeding edge bound to be some probs. did a full install which installs a 2.4.x kernal and accessories went to delete the 2.4.x items got same problem you describe. had to shuffle some packages.

Last edited by mrapathy; 01-18-2006 at 05:52 AM.
 
Old 01-18-2006, 04:28 AM   #8
yoron
Member
 
Registered: Nov 2005
Posts: 120

Rep: Reputation: 15
I've had some problems with 2.6 myself (from the SlackwareCD2/test).
I've tried to choose it as kernel when installing Slackware.
From there on, i've never succeeded to go into the GUI, and my wireless keyboard stopped working etc..
So i gave up on it.
 
Old 01-19-2006, 07:06 AM   #9
LearningToLive
LQ Newbie
 
Registered: Jan 2006
Distribution: Kubuntu Dapper Drake
Posts: 7

Original Poster
Rep: Reputation: 0
I just tried compiling again with the 2.6.15 from the kernel website, and I went into the "make menuconfig" and I went through every option and read the help on it, selected everything that looked important, selected all my filesystem types in the kernel. It got a little farther booting, but still got a kernel panic.
 
Old 01-19-2006, 07:20 AM   #10
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Could you post the error, not the kernel panic but the part that happens right before. Also make sure your chipset is compiled in also.
 
Old 01-19-2006, 08:57 AM   #11
vaporizel
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware 10.0
Posts: 23

Rep: Reputation: 0
Try recompile your 2.6.xx kernel with option something about RAMDISK except EXPERIMENTAL.
If you use Reiserfs, you should activate all of Reiserfs feature except EXPERIMENTAL as builtin kernel.

after that.. do it usually.

I hope it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4 in Zipslack (Waring: unable to open an initial console | Kernel Panic...) kurtamos Linux - General 2 05-10-2006 12:58 PM
Kernel Panic after lilo update aje Slackware 4 09-03-2005 01:39 PM
Installed suse...ran Yast Update...now a kernel panic? RoaCh Of DisCor Suse/Novell 1 12-24-2004 10:32 PM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 03:28 AM
YaST Online Update + AMD kernel patch = kernel panic THX1138 Linux - General 3 10-26-2003 04:25 PM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration