LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-18-2012, 03:11 PM   #1
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Rep: Reputation: 1
kernel panic


I just configured a kernel and installed it. The problem is when I try to boot into it I get the following message:

Code:
VFS: Cannot open root device "801" or unkown block (8,1): error -6

Please append a correct "root=" boot option; here are the available partitions:

Kernel panic - not syncing: VFS: unable to mount root fs on unkown_block(8,1)
I'm guessing I left something out that the kernel needs to boot b/c I installed a default kernel configuration under the same kernel (3.5) and it works fine.
 
Old 08-18-2012, 03:23 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,238

Rep: Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041
Possibly neither did you configure the file system for your root partition as built in nor did you include the module for it in an initrd (or didn't reference that initrd in /etc/lilo.conf).

Last edited by Didier Spaier; 08-18-2012 at 03:25 PM.
 
Old 08-18-2012, 03:29 PM   #3
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Original Poster
Rep: Reputation: 1
I thought the same thing but checked that and it is configured. I'm using ext4
 
Old 08-18-2012, 03:33 PM   #4
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
So boot your kernel appending the root directive
like
kernel root=/dev/sda1
 
Old 08-18-2012, 03:37 PM   #5
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Original Poster
Rep: Reputation: 1
Where would I put this?
I have my lilo.conf as follows:

Code:
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only
 
Old 08-18-2012, 03:43 PM   #6
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
Well, you could do it on lilo command line but if you can edit lilo.conf then you are in advantage, just find out what partition is your root typing
Code:
mount
 
Old 08-18-2012, 04:57 PM   #7
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Original Poster
Rep: Reputation: 1
so you're saying use
Code:
kernel root=/dev/sda1
In place of
Code:
root = /dev/sda1
?

I'm not familiar with the "kernel root" command in lilo.conf

Last edited by doughyi8u; 08-18-2012 at 05:00 PM. Reason: edit
 
Old 08-18-2012, 05:13 PM   #8
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.16.0) UEFI enabled
Posts: 348

Rep: Reputation: 71
I am going to say something silly but:
every time I have gotten this error it was
because
I forgot to run lilo after modifying lilo.conf

john
 
Old 08-18-2012, 05:19 PM   #9
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Original Poster
Rep: Reputation: 1
Good thinking alleyTrotter but I made sure I ran lilo more than once
 
Old 08-18-2012, 05:59 PM   #10
sgmart
LQ Newbie
 
Registered: Jun 2012
Location: Mexico
Distribution: Slackware Linux
Posts: 6

Rep: Reputation: 0
Lightbulb Lilo

Hello @doughyi8u

I had a similar trouble some days ago, I solved that putting this:
Code:
root = "UUID=uuid_of_your_root_partition"
to /etc/lilo.conf file, and running lilo command again after changes.

The uuid is obtained executing:
Code:
blkid /dev/sdaX
as root.

I hope this solve your problem!
 
Old 08-18-2012, 08:03 PM   #11
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Original Poster
Rep: Reputation: 1
sgmart: I tried that and get the same result.

Like I said, I used the default kernel configuration for the 3.5 kernel and it boots that just fine. I made a lot of changes to the default .config and it won't boot with that. I thought for a while that it could be b/c I didn't configure any scsi devices and added those to the .config and re-ran make. I tried that config and get the same results.

Last edited by doughyi8u; 08-18-2012 at 08:17 PM.
 
Old 08-19-2012, 06:48 AM   #12
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,238

Rep: Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041
We need a little more information to help you.

1) What is your Slackware version?
2) What do you mean "by the default configuration for the 3.5 kernel"?
3) Did you download the kernel source from a kernel.org mirror?
4) Why do you need a 3.5 kernel? Does one of your hardware devices miss a driver in the provided Slackware kernels?
5) What is the purpose of the changes you made in the default .config?
6) How did you make these changes?

To compile a kernel for Slackware, read this how-to from Alien Bob, one of the main Slackware contributors.

Other than that, to help us investigate you could append to your next post two .config files (one with which you could make a booting kernel a one with which there was a problem), respectively renamed as goodconfig.txt and badconfig.txt.

Also, outputs of "lspci -k" and "uname -a" would be useful.

PS To investigate yourself, if you think you miss some driver, look at output of "lspci -k" and check in the "bad" .config that all drivers/modules listed are present in this configuration. Or check that with the "search" feature of your configuration command ("/" for make menuconfig, Ctrl+F for make xconfig).

Last edited by Didier Spaier; 08-19-2012 at 10:34 AM. Reason: PS added
 
Old 08-19-2012, 08:33 AM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Maybe posting the .config will help.
 
Old 08-19-2012, 08:56 AM   #14
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
Have you checked whether you have enabled the correct SATA/PATA drivers? I've had my kernels fail to boot for that reason.
 
Old 08-19-2012, 05:56 PM   #15
doughyi8u
Member
 
Registered: Apr 2010
Posts: 154

Original Poster
Rep: Reputation: 1
I'm using Slackware 13.37

What I mean by default .config is the .config you get when you run make menuconfig (or make xconfig) and change nothing. When I compile that .config, it starts fine.

I downloaded the kernel from www.kernel.org

The config that works is attached as good_config.txt and the one I'm trying to compile that's giving me problems is config.txt.

Here is the output from "lspci":
Code:
00:00.0 Host bridge: Intel Corporation 82850 850 (Tehama) Chipset Host Bridge (MCH) (rev 02)
00:01.0 PCI bridge: Intel Corporation 82850 850 (Tehama) Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 04)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 04)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 04)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)
02:09.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
02:0a.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
02:0b.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
02:0d.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 09)
Attached Files
File Type: txt config_good.txt (82.3 KB, 12 views)
File Type: txt config.txt (77.4 KB, 7 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Logging a Kernel Panic Event - Problem writing the log in panic situation lucasct Linux - Embedded & Single-board computer 5 09-08-2011 01:44 PM
upgrading Fedora Core 3 kernel 2.6.9-1.667 to 2.6.26.3 manually+kernel panic error LinuxLovinNoob Linux - Newbie 7 12-17-2008 08:45 PM
Kernel panic puts me in a panic theeeg Linux - Software 2 07-31-2004 04:46 PM
kernel panic (narius panic) narius Linux - Newbie 3 06-20-2002 03:56 PM
Kernel panic making me panic! Linux_N0oby Linux - Software 19 05-29-2002 12:31 AM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration