LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-23-2005, 03:39 PM   #1
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
kernel config options for soundblaster


dear all,

i've just upgraded my kernel to 2.6.10 and everything works fine, EXCEPT the sound card. when i run alsaconf i get 'No supported PnP or PCI card found'.

i guess this strongly depends on some options that i've not selected in my kernel configuration.

...anyone has a clue? the exact model is a creative audigy Z2 2 platinum pro.

thank you,

aj.
 
Old 02-23-2005, 04:11 PM   #2
fax8
Member
 
Registered: Jul 2004
Location: Italy
Distribution: SlackWare 10 - The Best
Posts: 72

Rep: Reputation: 15
did the sound worked with your old kernel?

If so you can try to use your old kernel and with "lsmod"
find the kernel module that run your sound card.
Usually the sond module name starts with snd- .

Then during kernel configuration simply compile
the sound module you need.

Hope this could help you.
 
Old 02-23-2005, 04:31 PM   #3
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
i have a soundblaster live
tried 2.6.10 and reverted to 2.6.7
what works for me is:
Sound > Sound Card Support = Y
then d/l the most current versions of ALSA (drivers, libs, utilities)
and compile the modules manually

Last edited by kodon; 02-23-2005 at 07:51 PM.
 
Old 02-24-2005, 05:33 AM   #4
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by fax8
did the sound worked with your old kernel?
hi fqx8, yes it did work. I tried compiling the kernel with things like emu-101k enabled however still can't get it to work.

i wish i could have the config files used to compile the precompiled kernels of slack, my perfect image was sata.i however it's still in 2.4.29.

Last edited by acidjuice; 02-24-2005 at 05:42 AM.
 
Old 02-24-2005, 05:38 AM   #5
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by kodon
then d/l the most current versions of ALSA (drivers, libs, utilities)
and compile the modules manually
being the noob i am and before destroying everything good i did until now, you have any link to an appropriate tut for this? thanks
 
Old 02-24-2005, 05:50 AM   #6
tlilja
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware current
Posts: 2

Rep: Reputation: 0
Hope this helps.
 
Old 02-24-2005, 03:57 PM   #7
fax8
Member
 
Registered: Jul 2004
Location: Italy
Distribution: SlackWare 10 - The Best
Posts: 72

Rep: Reputation: 15
.config files for 2.4 kernels should work on 2.6 kernels.
So you can use the config file for the kernel wich run your sound card.
I did it.

What I told you on my post was to boot your old kernel and using lsmod
discover what kernel module uses your soundcard.
They usually starts with snd- . Once understood what modules uses your car just
enable it during kernel configuration.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel config options elmu Linux - General 2 11-02-2005 11:15 AM
Kernel config options (/dev, /dev/pts) jrdioko Slackware 5 08-22-2005 01:25 AM
difference in .config options utanja Debian 3 08-31-2004 10:40 PM
Kernel 2.6.2 options question - LOCKED options ? tvojvodi Linux - General 0 02-17-2004 04:23 AM
Compilation options in config and Kernel panic beejayzed Linux - Newbie 0 01-30-2004 04:56 PM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration