LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2006, 04:46 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Kernel Compiling and 'ide2=noprobe'


I use the 2.4.x kernel in Slackware 10.x. I use older hardware. In my boxes I have only two IDE controllers, IDE0 and IDE1.

When booting the kernel reports:

ide2: ports already in use, skipping probe

The message is non fatal, but distracting. The IDE2 port cannot be in use because I don't have any.

Surfing the web helped me discover the boot option parameter of ide2=noprobe. I added that option in my boot loader configuration and dmesg no longer shows any messages about IDE2. Nice.

Seeing as this boot option suppresses the dmesg "error," when compiling a new kernel is there a way to configure for ignoring IDE2? I do not see any such option, but I will never claim to be a kernel expert. Possibly the option exists. Yes, I can live with the boot option parameter. I'm just wondering while I am tinkering with some kernel compiling.

Thanks.
 
Old 08-20-2006, 01:10 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I have a motherboard where IDE0 will not work with Slackware,
but it will work with Windows. I, also, would not claim to be
a kernel expert, but afaik there is nothing in the kernel to
single out one port on the IDE controller. Both IDE0 and IDE1
are on the same bus.

And btw -- I enjoy your Slackware Desktop Enhancement Guide.
 
Old 08-20-2006, 05:15 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
I have a motherboard where IDE0 will not work with Slackware, but it will work with Windows
Fascinating. But that explains the purpose of the noprobe boot parameter.

Quote:
. . . but afaik there is nothing in the kernel to single out one port on the IDE controller
I pretty much guessed the same. I simply was curious that because there existed this specific boot parameter whether there also existed a kernel config option when compiling.

Quote:
And btw -- I enjoy your Slackware Desktop Enhancement Guide.
 
Old 03-14-2007, 01:04 AM   #4
huangzen
LQ Newbie
 
Registered: May 2004
Location: Sacramento
Posts: 18

Rep: Reputation: 0
Hey you guys, so how did you fix "ide2 ports already in use, skipping probe" problem??
what seems to be the problem? is it my IDE drive, my Debian Linux is too old or?

I am new to Linux and I just try to install the Debian 3.0 Kernel 2.2.20....

Can any of you guide me through it?
 
Old 03-14-2007, 08:27 AM   #5
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
As in Woodsman's first post here, there is no total 'fix' it seems, but there IS a way to suppress the error/warning message.
The line "ide2=noprobe" would be placed in your etc/lilo.conf file as an append, either near the start of the file, or in the image section of the image you boot.
It is not your drive, or the age of your Debian, but merely the fact that the limited number of ide busses is not specifically addressable in the compile options for the kernel.
Hope that clarifies it a little bit for you huangzen
SV
PS- as always after editing or working on LILO, run lilo in a command console when you are done to make sure it reconfigures itself with no errors.
NOTE: My instructions are for LILO bootloader, but surely there is a near identical method for if you use GRUB instead.

Last edited by GrapefruiTgirl; 03-14-2007 at 08:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
confusion in IDE1/IDE2, device manager settings in XP b0nd Linux - Hardware 5 08-17-2006 07:15 PM
Lilo noprobe problems Wolf_Assassin Linux - Software 0 11-11-2005 11:56 AM
Old Motherboard IDE2 problem linmix Linux - Hardware 2 11-17-2004 02:13 AM
Fedora noprobe install mimsmall Fedora - Installation 1 03-24-2004 12:24 PM
ide2: unexpected interrupt SykoSoft Linux - Hardware 0 02-20-2004 10:34 PM


All times are GMT -5. The time now is 03:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration