LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Kernel Compile Guide for 2.6.0 (http://www.linuxquestions.org/questions/slackware-14/kernel-compile-guide-for-2-6-0-a-127095/)

DaOne 12-18-2003 07:32 PM

Kernel Compile Guide for 2.6.0
 
Hey all...just went through a few compiles to see what's what, and wanted to share with you since alot of you refer to the Sticky which was based on 2.4 kernels. The Sticky is HERE

First...the same applies as far as editing lilo.conf and the Makefile (uncomment "export INSTALL_PATH=/boot"). I know...it's not line 74 anymore...it is now line 450.

Now, make install still works great as long as the above is done. So...once the kernel source is downloaded and extracted to /usr/src, you can then create a new link.

From /usr/src

rm -f linux
ln -s linux-2.6.0 linux
cd /linux

make mrproper

Then copy your existing .config to your new kernel source tree...

cp /usr/src/linux-2.4.?/.config /usr/src/linux

make oldconfig (to use your old config and choose to add/not add the new options)
or...
make menuconfig (to use your old config and tweak further)
or...
make whatever other type you like (xconfig,gconfig,etc.)

Just exit and save the configuration, then...

make
su -c "make modules_install"
make install


That's it...reboot, take 2 aspirins, and call someone else in the morning :D

ckamheng 12-18-2003 11:08 PM

my kernel compiling Question
 
DaOne,

make oldconfig (to use your old config and choose to add/not add the new options)
make menuconfig (to use your old config and tweak further)
make whatever other type you like (xconfig,gconfig,etc.)

Q1: Why must i must this all at the same time?

Q2: Can i rename my config file to other name beside .config?
can it be found if i rename it to other name?

Q3:Why you didn't do this:

ln -s System.map-ide-2.6.0 System.map

yenonn 12-18-2003 11:52 PM

What is the use of System.map file??? does it important?? or i can just ignore it???

i have a problem... the modules of snd_emu10k1 (soundblaster live) doesnt load automatically, when it is booting...

i have read somewhere that, i have to install modules_init_tools... how can i make use of this...., pls advise???

powadha 12-19-2003 12:48 AM

I compiled all I needed into the kernel following the steps as posted. When rebooting I get a strange (long list) of errors stating that iptables can't be loaded. No clue if that has something to do with the mentionend tools? Why is the kernel looking for modules anyway? I didn't compile any in the new kernel. Final question: should I comment all the uncommented modules in the config file? This wouldn't be nice, since I'd like to keep the 2.4.22 kernel for a while aswell (hate to comment and uncomment all the time when changing)

Regards

DaOne 12-19-2003 06:28 AM

Re: my kernel compiling Question
 
Quote:

Originally posted by ckamheng
DaOne,

make oldconfig (to use your old config and choose to add/not add the new options)
make menuconfig (to use your old config and tweak further)
make whatever other type you like (xconfig,gconfig,etc.)

Q1: Why must i must this all at the same time?

Q2: Can i rename my config file to other name beside .config?
can it be found if i rename it to other name?

Q3:Why you didn't do this:

ln -s System.map-ide-2.6.0 System.map

First, you do not need to do all of the make whateverconfigs I listed...just the one you prefer to use. I always use make menuconfig...don't know why, I just prefer to use the menu.

Second, when you copy your existing .config into the new kernel source tree, the original stays in the old kernel tree. Basically, you are just using your existing kernel config as a starting point for configuring the new kernel. The old config and kernel remains as it was. And...yes, if you rename .config, it will not be found.

Third, I have never created a link to System.map...when you run make install, everything that needs to be copied, renamed, etc. will be done (as long as you properly edit the Makefile)...make install also runs lilo for you.

Hope this helps.

DaOne 12-19-2003 06:34 AM

Quote:

Originally posted by yenonn
What is the use of System.map file??? does it important?? or i can just ignore it???

i have a problem... the modules of snd_emu10k1 (soundblaster live) doesnt load automatically, when it is booting...

i have read somewhere that, i have to install modules_init_tools... how can i make use of this...., pls advise???

As for the sound card...if the module loads when you do

modprope snd_emu10k1

then just uncomment it in /etc/rc.d/rc.modules, or if it isn't there, add the line

/sbin/modprobe snd_emu10k1

As for modules_init_tools...don't know. I didn't install this and had no problems. However...I do believe that this is NOT backwards compatable. So your old kernel may not work if you install this if you are not careful...maybe someone else has more info on this.

DaOne 12-19-2003 06:41 AM

Quote:

Originally posted by powadha
I compiled all I needed into the kernel following the steps as posted. When rebooting I get a strange (long list) of errors stating that iptables can't be loaded. No clue if that has something to do with the mentionend tools? Why is the kernel looking for modules anyway? I didn't compile any in the new kernel. Final question: should I comment all the uncommented modules in the config file? This wouldn't be nice, since I'd like to keep the 2.4.22 kernel for a while aswell (hate to comment and uncomment all the time when changing)

Regards

powadha...it's hard to tell what's going on from what you posted...can you post the exact errors if possible?

Are you refering to the rc.modules file? You only need to uncomment the modules that you know you need if they are not automatically loaded by the kernel. You shouldn't have to uncomment too many if any at all if the kernel is properly configured.

kc00l 12-19-2003 06:50 AM

Quote:

Originally posted by DaOne
As for the sound card...if the module loads when you do

modprope snd_emu10k1

then just uncomment it in /etc/rc.d/rc.modules, or if it isn't there, add the line

/sbin/modprobe snd_emu10k1

As for modules_init_tools...don't know. I didn't install this and had no problems. However...I do believe that this is NOT backwards compatable. So your old kernel may not work if you install this if you are not careful...maybe someone else has more info on this.

From the "Documentation/Changes" in 2.6.0 kernel source:
Quote:

Module-Init-Tools
-----------------

A new module loader is now in the kernel that requires module-init-tools
to use. It is backward compatible with the 2.4.x series kernels.
Anyway if you use Slack9.1 you got "module-init-tools-0.9.14-i486-2" in the a/ directory of CD1.

DaOne 12-19-2003 07:16 AM

kc00l...I didn't see this before. Thanks.

kc00l 12-19-2003 07:39 AM

Thanks for your guide too. It has made me think about using "make install" instead of doing the manual post kernel building procedure.

This is what I love about Linux users community, you don't and you can't afford to stop learning.
OTOH you feel you can't help telling others your way of doing something, maybe just to know this isn't the right way to do that.

Anyway don't listen to me, I'm just a mad doctor! :)

DaOne 12-19-2003 07:49 AM

Quote:

Originally posted by kc00l
Anyway don't listen to me, I'm just a mad doctor! :)
I fear we all are to some extent :cry:

Dodgy 12-19-2003 12:44 PM

DaOne, great guide on how to compile the new kernel. It was my first ever serious attempt to upgrade and get it to work. I now have 2.6.0 on my machine.

To my problems. I encountered a problem with Nvidia drivers after the install...

ERROR: The kernel header file '/lib/modules/2.6.0/build/include/linux/modversions.h' does not exist. The most likely reason for this is that the kernel header files in '/lib/modules/2.6.0/build/include' have not been configured.

Thats one problem. A second problem is the | character. I have a Swedish keyboard and to be able to get | I press a button labelled Alt Gr. It allows me to use a third symbol in Windows. I have read a million pages and newsgroup posts about how to enable it in the console mode but it has never worked. I have tried the 2 Swedish keymaps but not the Finnish - Swedish ones. I guess I should check those first. Anyway, it hasnt been that much of a problem since I havent really needed the key for commands so far. I used the framebuffer mode so I had a 1024x768 resolution in console mode. But after the new kernel install that mode is gone and im limited to the standard resolution. If anyone have any ideas to fix any of my problems, feel free to enlighten me...

I know the last 2 problems doesnt really have anything to do with the kernel deal but I felt its pretty pointless to start a new thread just because of them...

Hcman 12-19-2003 12:50 PM

powadha,

Does your firewall script load the modules explicitly?
I had a problem with a script that errored out while checking for the modules since it was looking for modules with the .o extension whereas in 2.6 the modules have the .ko extension.

Perhaps this helps.

HC

Tino27 12-19-2003 03:26 PM

Dodgy --

The first time I compiled the 2.6.0-test11 kernel and tried to apply the nVIDIA driver update that I had originally downloaded for my 2.4.22 kernel, I got the same error message. I got around this by cheating a little bit and located the modversion.h file for my previous kernel (2.4.22) and copied it to the location indicated by the nVIDIA installer. However, once I did that and tried reapplying, I got a different error stating that the nVIDIA installer was not intended for the 2.6.0 kernel series and it aborted.

Solution? You need to patch your nVIDIA installer package with a patch from this site: www.minion.de

After installing the new 2.6.0 kernel yesterday and applying the appropriate patch, the module compiled and installed correctly and I was once again in the land of 3d acceleration. :)

As for the other problems you mentioned...

I don't have any advice on the keyboard issue.

As for the start-up resolution, that is controlled through /etc/lilo.conf. Perhaps the setting got changed somehow?

karthikrr 12-20-2003 12:02 AM

I have the nVidia problem too... and minion.de 's installer doesnt work yet... I followed the README verbatim, and I end up with some

' /lib/2.6.0/modules/build/xxxx - unable to find file/directory' error.... ok, thats not a quote... but u get what I mean... :-) Anyways, then I tried to do a manual copying of nvidia.ko and stuff, like I woulda done it if it was for a DIFFERENT kernel than the one I was running... but that didnt work either! Not sure what to do...


All times are GMT -5. The time now is 07:28 PM.