LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-06-2005, 12:00 PM   #1
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
kernel compilation problem


Right so either I'm starting to get in the category with incredibly stupid people or then there's something strange at work in my computer preventing me from successufully compiling kernel 2.6.11.

This is actually the third time I've tried to compile a kernel and it has so far been the most successful. But it doesn't seem to be what I wanted it to be.

So anyway I chose which parts I wanted using xconfig... , then this time I noticed something strange when I made the bzImage. The text it was putting out on the screen talked about kernel 2.4.29 not 2.6.11 which I think is a bit weird considering I was in the directory for the 2.6.11 kernel. Oh btw I was following instructions from the web in order not to screw anything up. Well anyway I tested installing it just to see if it worked although I didn't expect it to. And yes it actually worked but it was the 2.4.29 kernel. So I tried to use the so called old kernel and it complaind something about the sound when I started kde.

So either I have made something stupid or my computer has a will of its own. Someone got an idea what I did wrong?

Sirrus
 
Old 03-06-2005, 12:10 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You don't have to be afraid of compiling the kernel 19495454 times until you get one working, it's normal, it's a process to learn how it works and how to configure it.
I just can think of two things:
1) You configured and installed the 2.4.29 kernel.
2) You configured 2.6.11 kernel but you didn't install it (copy to boot dir and updated lilo).

By the way, it would be good if you give more information as what steps you followed.

Last edited by gbonvehi; 03-06-2005 at 12:15 PM.
 
Old 03-06-2005, 01:00 PM   #3
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...i guess you made a mistake by doing " cd /usr/src/linux " instead of
" cd /usr/src/linux-2.6.11" before you started.
are you sure you saw a white xconfig gui ( 2.6 ) or one in system colors with push-buttons. ( 2.4 ) ?

egag
 
Old 03-06-2005, 06:38 PM   #4
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
I don't have the exact instructions before me as I'm writing this but as I remember it was about this way I did it.

Okay so I unpacked it to usr/src/, then made a symbolic link from it to usr/scr/linux. Then went into the folder which the link created. And it was at that point also checked that the fils was belonging to 2.6.11.
After that, make mrproper, then make xconfig. I don't remember checking at this point which kernel it was doing something with but considering I was in the folder with 2.6.11 files I assumed it to be correct.
After that it told me to make dep so i did it.
Then I did make bzImage, it was then I noticed it was talking about 2.4.29.
But I decided to install it anyway to see how it worked, so next was make modules and make modules_install.
After that I copied the bzImage and system.map to the boot folder, and changed lilo.

That should be fairly accurate described what I did.

Then when I rebooted I had either too diffrent 2.4.29 kernels or I had somehow been able to remove the previous one and had too copies of the same kernel. At least when I tried to use the "old" kernel I didn't have any sound in kde which worked before I tried to compile the kernel. But then I have had some problems with the sound in linux in the past so it could be a coincidence but I don't think so. But then I'm not really sure why the sound wouldn't work in the "new" kernel because I'm pretty sure I had selected it correctly in xconfig.

So much more than that I didn't do.

Sirrus
 
Old 03-06-2005, 06:41 PM   #5
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Oh by the way the color of xconfig was some sort of gray if I don't remember too wrong. So I can then probably assume I was in the wrong kernel, right.

Sirrus
 
Old 03-06-2005, 07:04 PM   #6
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
yip ...i guess so..
before you type " make xconfig " make absolutely sure you're in the right directory.

you should see a window with on the left a tree of options, and on the right sub-options,
with, right below , a window with info/advice about the item you click.
selection goes with check-boxes.
very different form the 2.4. -- kernel.

just give it another shot.....

egag
 
Old 03-07-2005, 04:56 AM   #7
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Yep,

the thing is I'm certain that the /linux folder the link made was pointed to 2.6.11. Or atleast ls listed the files from the 2.6.11 folder. And such as I understand the compilations they do it from the current folder, right?
By the way what was is the idea of making a link to the folder and not use it directly, or at least as far as I know it should work as well.

Sirrus
 
Old 03-07-2005, 05:15 AM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
To make sure, open the Makefile in your kernel tree, the first 3 lines should be:
VERSION = 2
PATCHLEVEL = 6
SUBLEVEL = 11
 
Old 03-07-2005, 08:13 AM   #9
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
Quote:
Originally posted by SirrusX

By the way what was is the idea of making a link to the folder and not use it directly, or at least as far as I know it should work as well.

Sirrus
you're right.
that link /usr/src/linux is in many storys on kernel-compiling, but it has no use at all.
just delete it, and forget all about it.
cd to the dir. where you want to be (linux-2.6.11), and start " make xconfig ".

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem during kernel compilation!! vishamr2000 Linux - General 6 11-21-2005 06:08 AM
Kernel compilation problem JJX Linux - Software 4 08-31-2005 06:50 AM
Kernel compilation problem LinuxLover Linux - Enterprise 3 05-11-2005 12:03 PM
kernel compilation problem vishamr2000 Linux - Newbie 2 08-22-2004 05:35 AM
Problem after 2.6.3 kernel compilation frzburn Linux - General 3 03-11-2004 08:12 AM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration