LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-09-2007, 04:28 PM   #1
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Rep: Reputation: 30
KDM Configuration


Hello,

I am currently running KDM. It has the option to change between session types, which is the different Desktop Enviroments and Window Managers. One of my options is FVWM. I installed FVWM Themes and would like to use them, but I need to change the command called on from fvwm2 to fvwm-themes-start. The problem is that I cannot find where the config file I need to edit is. It seems that the normal xsessions and xinit files all point to startkde, so I assume that there is a specific program KDE calls on to start KDM and a script to offer the different session types. That is probably what I need to edit and I need to know where it is located. I found some config files in /opt/kde but I didn't seem to find anything that had the different session commands. Any advice? Does XDM offer a quick change between Desktop Enviroments and Window Managers - if so I may consider switching.
 
Old 03-09-2007, 09:04 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
My KDM offers a pulldown menu which allows me to pick from blackbox, fvwm, Ice, about a dozen in total.
It's KDE 3.5.4.
From the Control Center --> Login manager you should be able to set the login do display that pulldown menu, which itself offers to set the default session as your choice, or as the last type used, etc.
Hopefully this helps, if I've understood you.
Also, have a look in etc/rc.4 for the DM which is started and in which order.
I think you're on the right track by looking in /opt too for settings, and also look through /etc/X11R6/...
 
Old 03-10-2007, 01:02 AM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
al@p3srv:/etc/X11/xinit$ pwd
/etc/X11/xinit
al@p3srv:/etc/X11/xinit$ cat xinitrc.fvwm2
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws
# <snipped>
# start some nice programs
xsetroot -solid SteelBlue
fvwm2
# end

I'm (somewhat) guessing -- but the last line above is your fvwm2 command that you asked "where is it".

So, 1. , KDM probably calls whichever xinitrc.xxxx (in same folder xinit there are more of these xinitrc.xxx for other win managers)

Probably then (next), 2. , that (for fvwm2) xinitrc.fvwm2 is responsible for launching fvwm2

(somewhat of a guess -- in just looking at the setup)
--

al@p3srv:/etc/X11/fvwm2$ pwd
/etc/X11/fvwm2
al@p3srv:/etc/X11/fvwm2$ ls
system.fvwm2rc

That appears to be the settings file itself. (not what launches fvwm2, not the fvwm2 command)

--
Alan.
 
Old 03-10-2007, 07:25 AM   #4
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
It looks like fvwm-themes-start does not exist on a stock slackware install.

Last edited by XGizzmo; 03-10-2007 at 07:35 AM.
 
Old 03-10-2007, 07:28 AM   #5
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
It looks like fvwm-themes-start does not exist on a stock slackware install.
but you can try this command as root
Quote:
root@slacker:/# updatedb && locate fvwm-themes-start
 
Old 03-11-2007, 03:41 PM   #6
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

I already updated the xinitrc.fvwm, but to no avail. It almost seems that KDE is running the other enviroments (FVWM, XFCE, etc.) within a shell of KDE, so that KDE is running in the background and almost like it is emulating the other enviroments. I have tried to find where to change the default window manager (like you do when you first install and it asks for your preference) but to no avail so far.
 
Old 03-11-2007, 03:51 PM   #7
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
Quote:
Originally Posted by JMJ_coder
I have tried to find where to change the default window manager (like you do when you first install and it asks for your preference) but to no avail so far.
Do you mean 'xwmconfig' ? It's listed in /var/log/setup.

I don't know what changes kdm makes to running X, but it always messes up my settings. A lot of programs no longer run under root, like emacs, and I have to sort out mouse settings as well. So I usually give up eventually and go back to run level 3.
 
Old 03-11-2007, 05:08 PM   #8
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

Quote:
Originally Posted by simcox1
Do you mean 'xwmconfig' ? It's listed in /var/log/setup.
Yeah, I finally found it - but it did not do anything.

Quote:
Originally Posted by simcox1
I don't know what changes kdm makes to running X, but it always messes up my settings. A lot of programs no longer run under root, like emacs, and I have to sort out mouse settings as well. So I usually give up eventually and go back to run level 3.
Well, I finally edited /etc/rc.d/rc.4 and commented out all the other dm's except for xdm - so that is what I am running now. It gets me into X, but I will probably try to customize it to my liking later on when I have some free time.

I also manually edited /etc/X11/xinit/xinitrc and commented out startkde and entered fvwm-themes-start. I just have to edit the file when I want to move back and forth, for the time being.
 
Old 03-11-2007, 05:58 PM   #9
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
My /etc/X11/xinit/xinitrc.fvwm2 file ends with this:

xsetroot -solid SteelBlue
fvwm2

Can't you just edit that to the command you want to start with? Also, the file /etc/X11/xinit/xinitrc is just a symbolic link to whatever the default window manager is, as set by xwmconfig. So presumeably you could just change that to link to xinitrc.fvwm2, which you can edit. Wether kdm will take any notice I don't know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDM configuration - greet string nebloof Linux - Software 2 07-29-2006 07:51 AM
KDM GUI choice configuration adds2one Linux - Software 8 03-25-2006 01:29 PM
where is kdm session configuration? npn Slackware 3 12-17-2005 10:32 AM
Adding kdm to init.d so LFS boots to kdm StevePhM Linux From Scratch 4 08-08-2005 10:49 PM
kdm configuration mandrake 9.0 B. Alec Linux - Newbie 1 02-03-2004 04:24 PM


All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration