LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-28-2006, 12:19 PM   #1
bird603568
Member
 
Registered: Aug 2004
Distribution: Slackware current
Posts: 250

Rep: Reputation: 30
kdesysguard cant connect to localhost


kdesysguard cant connect to local host as normal user. but i switch to root and it runs fine. im running -current. im pretty sure its just a premission problem
 
Old 08-29-2006, 05:17 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
As normal user can you ping localhost?

Do you have a file called /etc/hosts? Is that file set for 644 (rw-r--r--) permissions? Does that file contain the entry: 127.0.0.1 localhost?
 
Old 08-29-2006, 08:30 PM   #3
bird603568
Member
 
Registered: Aug 2004
Distribution: Slackware current
Posts: 250

Original Poster
Rep: Reputation: 30
yep its like that
 
Old 09-01-2006, 08:33 PM   #4
bird603568
Member
 
Registered: Aug 2004
Distribution: Slackware current
Posts: 250

Original Poster
Rep: Reputation: 30
anybody? i still cant figure this out
 
Old 09-01-2006, 11:04 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
If you think the issue is a permissions problem, then as root perform a chown username:username on your user home directory. Or, perform a find ~ -user root and find ~ -group root. Sometimes when working as root people accidentally copy files to their user directory but do not modify the ownership permissions.

If that reveals nothing then one trick that often helps me resolve some KDE issues is to exit X/KDE and then temporarily rename the .kde directory to something like .kde-old. Then start X. You have to tolerate all the default KDE settings, but if KSysGuard then runs okay you at least know that there is a KDE configuration issue with your settings. If the KSysGuard problem persists using the default settings then you know the problem lies elsewhere.

Another trick I have used sporadically is to again exit X/KDE and then delete all user related KDE temp files. There are three directories storing this information:

~/.kde/cache-hostname
~/.kde/socket-hostname
~/.kde/tmp-hostname

If you do not want to lose certain files such as favicon files, then rename those directories rather than delete all underlying files. KDE will rebuild the directories and you later can copy files as desired.

Another issue that tends to hit some people are stale or corrupted session files. Those files are stored in ~/.kde/share/config/session. Delete those files outside of X/KDE.

You might want to delete any files found in ~/.kde/share/apps/ksysguard. You also can delete the ~/.kde/share/config/ksysguardrc configuration file.

Lastly, again outside of X/KDE, delete any .DCOP*, .ICEauthority and .Xauthority files in your home directory. KDE and X will rebuild those files.
 
Old 10-15-2006, 02:55 AM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
This thread is a wee bit dated, but today I ran across the same problem described by the OP. I am in the process of testing and updating from KDE 3.4.3 to 3.5.4 and Slackware 11.0.

Somewhere between KDE 3.4.3 and 3.5.4, apparently the KDE developers modified kysguard to require the lm_sensors package. Installing this package eliminates this error message.

The KDE developers could have picked a more useful error message to provide some clues. I discovered the solution only through a lot of surfing. Exactly what does "connection to localhost has been lost" have to do with lm sensors? I don't know. The problem is not connecting to localhost, but not finding the libsensors libraries.
 
Old 04-30-2007, 04:10 PM   #7
Flyen
LQ Newbie
 
Registered: Apr 2004
Distribution: Fedora 5 and CentOS 4
Posts: 21

Rep: Reputation: 15
fyi:
lmsensors is required by ksysguardd <= note the extra d. This is the app that ksysguard connects to for system information. Without lm_sensors installed, ksysguardd doesn't start, and thus ksysguard can't connect to it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to localhost? kwikness Linux - Networking 15 05-22-2006 11:48 AM
printer can't connect to localhost tincat2 Slackware 8 08-06-2005 11:48 PM
Cannot connect to anything on localhost JohnKFT Slackware 17 05-11-2005 02:21 AM
can't connect to localhost acidblue Fedora 0 12-05-2004 07:20 PM
Can't connect to localhost Brendon Linux - Networking 11 07-30-2002 10:13 AM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration