LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2010, 04:17 PM   #1
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
KDE4 Wicd startup - turn off


I once had wicd running at KDE startup as I was just playing around with it. The problem is I now have turned off rc.wicd and don't want to use wicd any more. Every time I start KDE it still asks for the root password which I cancel and it then tells me it can't connect to wicd's dbus. This is getting really annoying as I have been trawling through my ~ looking for the setting that starts this up. I just want wicd turning off completely and this message to go away. Anyone know where this is set?
 
Old 03-13-2010, 04:24 PM   #2
razb
LQ Newbie
 
Registered: Oct 2009
Location: Ukraine
Distribution: Slackware
Posts: 9

Rep: Reputation: 1
Try to delete /usr/share/autostart/wicd_tray.desktop file

Last edited by razb; 03-13-2010 at 04:26 PM.
 
Old 03-13-2010, 04:49 PM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Try to delete /usr/share/autostart/wicd_tray.desktop file
No joy there I'm afraid. I don't think those entries control the user's individual startup as it must be a directory writeable by the user - as in the user's ~ directory.
 
Old 03-13-2010, 05:03 PM   #4
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 421

Rep: Reputation: 45
Quote:
Originally Posted by bgeddy View Post
No joy there I'm afraid. I don't think those entries control the user's individual startup as it must be a directory writeable by the user - as in the user's ~ directory.
No. ASAIK, DEs will scan system configuration and execute them before anything user-specific.
 
Old 03-13-2010, 05:26 PM   #5
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
No. ASAIK, DEs will scan system configuration and execute them before anything user-specific.
Yes - but this was not a system configuration. In other words as far as I remember, (I may be wrong here though), wicd didn't used to start till I set it on and now I can't get rid of it. As far as I'm aware the system defaults are set in /usr/share/autostart and individual settings are under ~/.kde. I can't find the wicd one though.
I any case removing that desktop entry doesn't get rid of it attempting to start.
 
Old 03-13-2010, 05:42 PM   #6
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Also please look into ~/.config

By default (in both KDE 3 and 4) Slackware will start wicd-client if wicd daemon was running before KDE starts. I am not sure why it did not work for you.
 
Old 03-13-2010, 06:23 PM   #7
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Also please look into ~/.config

By default (in both KDE 3 and 4) Slackware will start wicd-client if wicd daemon was running before KDE starts. I am not sure why it did not work for you.
Nope - not there either. This is so strange! I am definitely not running the daemon. Just to make clear - I do not want wicd to run but can't seem to stop it KDE looking for it.
 
Old 03-13-2010, 11:46 PM   #8
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,550

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
kill wicd-client in the system tray, logged out, and login again
that should work
 
Old 03-13-2010, 11:59 PM   #9
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
kill wicd-client in the system tray, logged out, and login again
that should work
Well I can't do that as it's not in the tray. It's not running, just attempting to run when I start KDE - I don't know what's causing this though hence my frustration!

Edit: I've just tried this as an additional test. I restarted KDE and this time gave the required root password that KDE asks for for wicd. Wicd then ran and I killed it from the system tray. Then I restarted KDE and the damn thing tries to start again! I am riddled with this thing and it really bugs the hell out of me!

Last edited by bgeddy; 03-14-2010 at 12:15 AM. Reason: Further information:
 
Old 03-14-2010, 04:13 AM   #10
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 421

Rep: Reputation: 45
Please also have a look at .kde/Autostart/ . And you can try to login with other DE. If wicd will started there, the problem should not be KDE's.
 
Old 03-14-2010, 04:31 AM   #11
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,550

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
maybe a session problem in KDE?
 
Old 03-14-2010, 07:30 AM   #12
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Please also have a look at .kde/Autostart/ . And you can try to login with other DE. If wicd will started there, the problem should not be KDE's.
The directory .kde/Autostart/ is empty.
Oddly - (I have never tried this before) - XFCE also gives the dbus error, the other Slackware desktop environments don't.
Quote:
maybe a session problem in KDE?
I have no idea how to check or remedy this - perhaps you could help ?
 
Old 03-14-2010, 07:30 AM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,408

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Have a look in ~/.kde/share/config/ksmserverrc.
 
Old 03-14-2010, 08:18 AM   #14
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Have a look in ~/.kde/share/config/ksmserverrc.
There's loads of stuff in there which I don't understand however nothing to do with wicd.

Edit: I have just created a new user as a test and set that user to use KDE as the DE. Starting KDE as that user also causes the error. Incidentally the error message ends up telling me to check wicd's error log - I don't know where that is but /var/log/wicd/wicd.log contains nothing relevant - it just seems to record from when it actually starts up.

Last edited by bgeddy; 03-14-2010 at 08:32 AM. Reason: Further Information
 
Old 03-14-2010, 08:41 AM   #15
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 161

Rep: Reputation: 20
Quote:
Originally Posted by bgeddy View Post
I just want wicd turning off completely and this message to go away.
SInce wicd is found in /extra, I'm presuming that you had to manually install it at some point. Check for the pkg name in /var/log/packages and then do
#removepkg wicd-your-version-here.tgz
Once it's gone...it should be gone
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn wireless card off with wicd grissiom Slackware 10 10-08-2010 02:36 PM
How to turn off services that run at startup? in terminal? linus72 Debian 7 12-30-2009 06:16 PM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
Static IP with WICD at Startup rafe101 Linux - Wireless Networking 9 12-10-2009 09:52 PM
annoying wicd message after system startup fastestOS Slackware 12 09-08-2009 10:21 PM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration