LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2010, 11:48 AM   #1
Squall90
Member
 
Registered: Oct 2009
Distribution: Currently several distros :S
Posts: 148

Rep: Reputation: 29
KDE4.4.5 crashes when starting language settings in systemsettings


Hi there,

I am trying to switch to KDE4.4.5 on my main machine. I installed the KDE packages and also the german language file. Everything works fine except the language settings. When I try to start it crash and a KDE crash dialog opens that gives this "developer information":
Code:
Application: System Settings (systemsettings), signal: Segmentation fault
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.2200.5-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[KCrash Handler]
#5  0xb5c83ee1 in strncmp () from /lib/libc.so.6
#6  0xb55ba4dd in __xmlParserInputBufferCreateFilename () from /usr/lib/libxml2.so.2
#7  0xb55ba55a in xmlParserInputBufferCreateFilename () from /usr/lib/libxml2.so.2
#8  0xb558d8a1 in xmlNewInputFromFile () from /usr/lib/libxml2.so.2
#9  0xb55ba983 in xmlLoadExternalEntity () from /usr/lib/libxml2.so.2
#10 0xb55a88e0 in xmlCtxtReadFile () from /usr/lib/libxml2.so.2
#11 0xb310ff10 in xkl_config_registry_load_from_file () from /usr/lib/libxklavier.so.16
#12 0xb311039a in xkl_config_registry_load_helper () from /usr/lib/libxklavier.so.16
#13 0xb3114538 in xkl_xkb_load_config_registry () from /usr/lib/libxklavier.so.16
#14 0xb310fe62 in xkl_config_registry_load () from /usr/lib/libxklavier.so.16
#15 0xb313fae4 in ?? () from /usr/lib/kde4/kcm_keyboard_layout.so
#16 0xb313708d in ?? () from /usr/lib/kde4/kcm_keyboard_layout.so
#17 0xb312a3ff in ?? () from /usr/lib/kde4/kcm_keyboard_layout.so
#18 0xb312e6b4 in ?? () from /usr/lib/kde4/kcm_keyboard_layout.so
#19 0xb3136dad in QObject* KPluginFactory::createInstance<LayoutConfig, QWidget>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kcm_keyboard_layout.so
#20 0xb63d38ce in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib/libkdecore.so.5
#21 0xb745908a in KCModuleLoader::loadModule(KCModuleInfo const&, KCModuleLoader::ErrorReporting, QWidget*, QStringList const&) () from /usr/lib/libkutils.so.4
#22 0xb745e5ad in ?? () from /usr/lib/libkutils.so.4
#23 0xb745f2a3 in KCModuleProxy::realModule() const () from /usr/lib/libkutils.so.4
#24 0xb7439021 in ModuleView::updatePageIconHeader(KPageWidgetItem*) () from /usr/lib/libsystemsettingsview.so.1
#25 0xb743a072 in ModuleView::addModule(KCModuleInfo*) () from /usr/lib/libsystemsettingsview.so.1
#26 0xb743abe6 in ModuleView::loadModule(MenuItem*) () from /usr/lib/libsystemsettingsview.so.1
#27 0xb3fa2030 in ?? () from /usr/lib/kde4/icon_mode.so
#28 0xb3fa27fd in ?? () from /usr/lib/kde4/icon_mode.so
#29 0xb604bbaa in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#30 0xb605a57b in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#31 0xb6b05283 in QAbstractItemView::activated(QModelIndex const&) () from /usr/lib/libQtGui.so.4
#32 0xb6b15720 in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#33 0xb6b2af9f in QListView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#34 0xb70ca198 in KCategorizedView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#35 0xb65cca18 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#36 0xb69c60d3 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#37 0xb6a608e2 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#38 0xb6b161d7 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#39 0xb6a632b5 in ?? () from /usr/lib/libQtGui.so.4
#40 0xb6045b6a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#41 0xb656e7c9 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#42 0xb6575d0b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#43 0xb70e92ca in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#44 0xb60468cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#45 0xb6574c62 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#46 0xb65fff3c in ?? () from /usr/lib/libQtGui.so.4
#47 0xb65ff44b in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#48 0xb662c2e2 in ?? () from /usr/lib/libQtGui.so.4
#49 0xb583a0f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#50 0xb583d990 in ?? () from /usr/lib/libglib-2.0.so.0
#51 0xb583dac3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#52 0xb6072425 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#53 0xb662be45 in ?? () from /usr/lib/libQtGui.so.4
#54 0xb6044ee9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#55 0xb604533a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#56 0xb604a56f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#57 0xb656e887 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#58 0x0805667e in _start ()
I have no idea why this happens. It works on my netbook. I run on both machines Slackware 13.1. The only difference I can think of is that KDE was pre-installed on my netbook and I just upgraded it. On my main machine I installed all packages except the packages of kde and kdei.

Any ideas?
 
Old 12-04-2010, 06:05 AM   #2
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Posts: 650

Rep: Reputation: 141Reputation: 141
Quote:
Originally Posted by Squall90 View Post
Hi there,
On my main machine I installed all packages except the packages of kde and kdei.

Any ideas?
That right there would seem to be the issue. I imagine you are missing a package that is causing the problem
 
Old 12-04-2010, 06:38 AM   #3
Squall90
Member
 
Registered: Oct 2009
Distribution: Currently several distros :S
Posts: 148

Original Poster
Rep: Reputation: 29
Okay, I installed the KDE4 packages from the DVD and then upgraded to AlienBob's KDE 4.4.5. When I try to open the language settings I still get the error.

Any other ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE4: Plasma crashes when laptop is closed and KMS enabled z-kzn-z Linux - Desktop 1 05-18-2010 04:45 PM
[SOLVED] KDE4: Can I customize System Settings? lefty.crupps Linux - Desktop 3 03-29-2010 12:38 PM
Where to get language pack for kde4? Raynus Linux - Software 1 02-05-2009 12:37 AM
kde4.1.2 in current --- AmaroK crashes kded4 grissiom Slackware 5 10-15-2008 05:56 PM
no administrator mode on kde systemsettings Fice Linux - Software 7 03-05-2007 04:47 PM


All times are GMT -5. The time now is 11:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration