LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE won't start; system starts in tty1 (http://www.linuxquestions.org/questions/slackware-14/kde-wont-start%3B-system-starts-in-tty1-622720/)

Jags_FL 02-21-2008 04:45 AM

KDE won't start; system starts in tty1
 
I just installed Slackware Current from the DVD installer. Installation went just fine.


After the first reboot and at each system startup afterwards, instead of KDE, I get this:

::::::

Welcome to Linux 2.6.23.16-smp (tty1)

xpc login:

::::::


And after log in as root, when I type " startx ", KDE loads just fine.


Afterwards I even installed latest nVIDIA drivers ( I've a 128MB nVIDIA GeForce 5200 card ) too but still at each system startup I have to enter startx in order to start KDE.


Any help is highly appreciated, many thanks in advance. - Jags

bathory 02-21-2008 05:18 AM

Edit /etc/inittab and change runlevel (from 3 to 4):
Quote:

id:3:initdefault:
to
Code:

id:4:initdefault:

reddazz 02-21-2008 05:21 AM

You have to edit /etc/inittab and change
Code:

id:3:initdefault:
to
Code:

id:4:initdefault:
Edit: beaten to the answer :)

Jags_FL 02-21-2008 05:44 AM

Thank you Guys !
 
"bathory" and "reddazz"


Thanks a million guys. It worked like a charm :)


You guys were very quick with your replies.


Now, is this normal ( that you have to change " id:3 to id:4 " ) or did I mess something up during installation ?


Thanks again, - Jags

rutgerw 02-21-2008 06:04 AM

It is normal in Slackware to change that line. By default Slackware starts in runlevel 3 (multi-user, text mode), whereas most other distributions start in a runlevel with a GUI.

zordrak 02-21-2008 07:37 AM

Also worth noting that, by default, run-level 4 only loads a console on tty6

I just can't live that way, and so I enable consoles on 2,3,4,5&6 like this:

Code:

$ diff /etc/inittab /etc/inittab.old

24c24
< id:4:initdefault:
---
> id:3:initdefault:
52,55c52,55
< c2:12345:respawn:/sbin/agetty 38400 tty2 linux
< c3:12345:respawn:/sbin/agetty 38400 tty3 linux
< c4:12345:respawn:/sbin/agetty 38400 tty4 linux
< c5:12345:respawn:/sbin/agetty 38400 tty5 linux
---
> c2:1235:respawn:/sbin/agetty 38400 tty2 linux
> c3:1235:respawn:/sbin/agetty 38400 tty3 linux
> c4:1235:respawn:/sbin/agetty 38400 tty4 linux
> c5:1235:respawn:/sbin/agetty 38400 tty5 linux


T3slider 02-21-2008 02:06 PM

Quote:

Originally Posted by Jags_FL
And after log in as root, when I type " startx ", KDE loads just fine.

As a side note, running as root is a bad idea (as stated about 3 million times on these forums and elsewhere). It would be best to add a normal user and use that. You can then "su" to root whenever you need to perform administrative tasks (like installing programs).

Jags_FL 02-22-2008 06:59 PM

Many Thanks
 
hi rutgerw, zordrak, and T3slider


Many thanks for your replies guys.



About Log in as a Root:

Thanks guys I know about that. This PC I have bought purely for experimental purpose, to learn Linux and Solaris, and hence there is not a single byte of data whatsoever on it. Moreover I format both HDs completely, almost every other day and start all over again for one or another reason.


Right now I have like 9 OSes installed on this PC along with Vista Ultimate and few weeks back I knew nothing of Linux / Multi Booting, and I also know I have a looooong way to go. :)



Thanks again guys. I highly appreciate your help. - Jags

T3slider 02-22-2008 08:41 PM

Well, I would still suggest learning to create and use a normal user if you want to learn Linux (in case you ever need to use it for anything non-experimental, whether it's on a machine you own or not).


All times are GMT -5. The time now is 11:38 AM.