LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE Tooltips (http://www.linuxquestions.org/questions/slackware-14/kde-tooltips-4175454541/)

Woodsman 03-18-2013 11:32 AM

KDE Tooltips
 
KDE 4.10.1.

I am trying to disable tooltips/informational popups. The only place I prefer them this at this time is System Settings.

Many apps still have popup tooltips appearing. For example, scrolling the document list in Kate results in a tooltip popup showing the full path, or scrolling the feed list in Akregator shows the feed name. I find the these types of tooltips distracting but I can't find where to disable them.

I'm hoping long time KDE users can help.

I've disabled tooltips in these places:

* Task manager settings
* System Settings->Workspace Appearance->Window Decorations->Configure Buttons
* System Settings->Workspace Behavior->Workspace

I have most of the eye candy desktop effects disabled. I don't know whether any of those are causing the remaining tooltips.

Thanks. :)

pataphysician 03-18-2013 01:40 PM

System Setting>Configure button>Show detailed tooltips to turn off the giant tooltips in System Settings itself

Many apps have the ability to turn on or off tooltips in their Configuration, like for example Dolphin, though I think it defaults to having them off.

Woodsman 03-18-2013 03:05 PM

Quote:

System Setting>Configure button>Show detailed tooltips to turn off the giant tooltips in System Settings itself
Those are the ones to which I referred as wanting to keep for the moment because System Settings is not intuitive to navigate. But even when disabling the "detailed tooltips" there, tooltips still appear like in the other apps.

Quote:

like for example Dolphin, though I think it defaults to having them off.
Yes, I found the config option for Dolphin. I don't see any such option for other apps.

These tootlips are as bad as the notification popups for every little thing that happens. :scratch:

pataphysician 03-18-2013 03:29 PM

Unfortunately if an application doesn't have a setting to turn them off, I think the only way to do it is to recompile Qt and I think there is a flag you can set to turn off all tooltips.

This is one of the many reasons I don't use KDE for regular use, you can turn off all gtk tooltips with a simple gtk-enable-tooltips = 0 in your theme configuration. As far as I've ever been able to determine this is not possible the KDE Qt styles.

jmccue 03-18-2013 05:00 PM

Hi,

These are notes I found and saved when I gave an older kde 4.x a try:

System Settings tooltips:
-------------------------
Open System Settings
Select the Configure button
Uncheck the "Show detailed tooltips" button

Task bar tooltips:
------------------
Open the task bar context popup menu
Select Task Manager Settings
In the General section, uncheck the "Show tooltips" check box


Panel balloon popups:
---------------------
Open System Settings
Select Workspace Appearance and Behavior
Select Workspace Behavior
Select Workspace
In the Informational Tips widget, select the "Do not show" option

Title bar buttons (Maximize, Minimize, Close):
----------------------------------------------
Open System Settings
Select Workspace Appearance and Behavior
Select Workspace Appearance
Select Window Decorations
Select the Configure Buttons button
Uncheck the "Show window button tooltips" check box

Dolphin:
--------
Select the Settings menu
Select the Configure Dolphin¿ option
Select the Behavior tab
Uncheck the "Show tooltips" check box


Actually, I think I got some/most of the above from you (Woodsman), which I saved in a text file over the years :) Not sure if they are still true for 4.8+.

YMMV
John

Woodsman 03-18-2013 06:57 PM

Quote:

Unfortunately if an application doesn't have a setting to turn them off, I think the only way to do it is to recompile Qt and I think there is a flag you can set to turn off all tooltips.
Hmm. Any idea what flag?

Quote:

This is one of the many reasons I don't use KDE for regular use, you can turn off all gtk tooltips with a simple gtk-enable-tooltips = 0 in your theme configuration. As far as I've ever been able to determine this is not possible the KDE Qt styles.
Historically KDE is quite flexible, but seems with the KDE4 release the devs went overboard with the tooltips and forgot to provide a simple way to disable them. They can be useful to new users but once a person learns and acclimates they become a nuisance.

Quote:

Actually, I think I got some/most of the above from you (Woodsman), which I saved in a text file over the years
Yup, those look mighty familiar. :)

pataphysician 03-18-2013 11:42 PM

Quote:

Originally Posted by Woodsman (Post 4914144)
Hmm. Any idea what flag?

From poor notes I have

-DQT_NO_TOOLTIP

But I did this I think in 4.6, and Qt is a very large and long compile.

Quote:

Originally Posted by Woodsman (Post 4914144)
Historically KDE is quite flexible, but seems with the KDE4 release the devs went overboard with the tooltips and forgot to provide a simple way to disable them. They can be useful to new users but once a person learns and acclimates they become a nuisance.

I'm not sure if it was the KDE devs fault completely, I think possibly maybe that Qt 4 handles tooltips in a very different manner than Qt 3, so there was probably no easy way for them to turn off tooltips, especially since I think the compile flag only became available in qt with 4.6

I've also searched for a timer setting which is also available for gtk, but doesn't seem available for qt either, as then you can have tooltips that only go off on a very long hover.

Woodsman 03-19-2013 09:02 AM

I'm willing to be a guinea pig. :)

Where to use the QT_NO_TOOLTIP option? I see a slew of #ifndef QT_NO_TOOLTIP statements in the sources. I don't know where to define QT_NO_TOOLTIP such that those ifndef statements never execute.

I would like to find a hover delay as that would resolve things nicely.

The tooltips seem to last about 10 seconds.

Edit: According to this page, looks like the -D option is added to the ./configure options, like this:

export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
export OPENSOURCE_CXXFLAGS="$SLKCFLAGS"
./configure \
-confirm-license \
-opensource \
-prefix /usr/lib${LIBDIRSUFFIX}/qt \
-fast \
-system-libpng \
-system-libjpeg \
-system-zlib \
-system-sqlite \
-plugin-sql-sqlite \
-dbus \
-webkit \
-no-phonon \
-nomake examples \
-nomake demos \
-no-separate-debug-info \
-D QT_NO_TOOLTIP \
-no-pch

I'm unsure but possibly qt-everywhere-opensource-src-4.8.4/src/corelib/global/qfeatures.h needs to have the //#define QT_NO_TOOLTIP statement uncommented.

I found this discussion the KDE bug tracker indicating a nominal awareness of the problem. The KDE forum has requests to disable tooltips but the general consensus is the tooltip I'm after, as you noted, is generated by Qt and not KDE. I'm unsure, but I think all of the other KDE tooltips will still function after disabling the native Qt tooltips. Only one way to know for sure. :)

thomassisson 04-07-2013 02:40 PM

I find that there is no time delay in the tool tips that I cannot turn off. One must move the mouse to make them go away. I have used the three System Settings options that are available. Ironically, I cannot turn them of in System Settings at all. The configuration available for the System Settings application is extremely limited. It looks to me more like Plasma Widget options than application configuration settings.

Alien Bob 04-07-2013 02:56 PM

Quote:

Originally Posted by Woodsman (Post 4914491)
I found this discussion the KDE bug tracker indicating a nominal awareness of the problem. The KDE forum has requests to disable tooltips but the general consensus is the tooltip I'm after, as you noted, is generated by Qt and not KDE.

The behaviour is indeed hard-coded in Qt4 and KDE software can not change or turn off the tooltips' behaviour.
If you want to recompile Qt4 with "QT_NO_TOOLTIP" then you would have to pass that macro definition in the CPPFLAGS.
Add a line like
Code:

export CPPFLAGS="$CPPFLAGS -D  QT_NO_TOOLTIP"
right before the "export CFLAGS" line for instance.

Eric

Woodsman 04-07-2013 06:09 PM

Quote:

export CPPFLAGS="$CPPFLAGS -D QT_NO_TOOLTIP"
I'm testing right now. Usually the build fails within 14 minutes or so but the build is still cranking a half hour later. Of course, the final test is updating the recompiled package and verifying the tool tips have vanished. :) I'll post again after the package is complete and I update my system.

Woodsman 04-07-2013 08:13 PM

Two hours to compile that, um, pig. I still see tooltips, but at this point I'll take a wild guess that I have to rebuild all KDE apps and not just Qt4?

Bazzaah 04-08-2013 02:19 PM

posted in error.

Woodsman 04-08-2013 02:58 PM

Yes, this not a debate about whether tooltips are valuable. :) They are valuable for new users, but when a user becomes familiar with apps and features the tooltips become annoying (despite Niki's zen ability to not see then). :)

I don't know how much the QT_NO_TOOLTIP compile option affects all KDE apps. Perhaps some tooltips are hard-coded. I haven't yet rebuilt the entire KDE package suite to yet know the answer. :)

BrZ 04-08-2013 04:49 PM

Quote:

Originally Posted by Woodsman (Post 4927771)
Yes, this not a debate about whether tooltips are valuable. :) They are valuable for new users, but when a user becomes familiar with apps and features the tooltips become annoying (despite Niki's zen ability to not see then). :)

I don't know how much the QT_NO_TOOLTIP compile option affects all KDE apps. Perhaps some tooltips are hard-coded. I haven't yet rebuilt the entire KDE package suite to yet know the answer. :)

Perhaps this information could be useful for your project.


All times are GMT -5. The time now is 05:27 AM.