Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-07-2005, 05:22 PM   #1
Registered: Nov 2004
Location: Virginia, US
Distribution: Slackware 14.1 multilib
Posts: 112

Rep: Reputation: 22
KDE thinks it knows better

I'm having a fight with KDE on my slack box and beleive it or not I'm loosing...

In short the problem is that no matter what I tell KDE in Control Center about File Associations it always goes back to the defaults...

For example I change the default player for MPEG files

Control Center -> KDE Components -> File Associations -> video -> mpeg


Xine (first)
Noautn (second) (by default this is the first one)

I click Apply, close CC and now I click on any mpeg file and it opens with Noatun. If I go back to CC the settings are back to the defaults. And yes it happens with all of the file associations.

Any ideas/suggestions will be appreciated.

BTW I'm running KDE 3.3.2 on Slack 10.0, kernel 2.4.29
Old 02-07-2005, 06:33 PM   #2
Registered: Feb 2004
Location: Ottawa, Ontario, Can
Distribution: Slackware, ubuntu
Posts: 391

Rep: Reputation: 31
I have no idea what your problem is, but I can offer consolation in that i've been having similar troubles with KDE.

Any theme I apply NEVER changes the taskbar and Kmenu, it is forevor stuck on the plastik theme. I can't even change the fonts in the menu. All the other widgets are nice and themed but my freaking taskbar appears to be stuck on kartoonish plastik for all eternity. GRRRRRRRRRR!!
Old 02-08-2005, 02:02 AM   #3
Registered: Apr 2003
Location: Northern England
Distribution: Debian Wheezy 64-bit
Posts: 128

Rep: Reputation: 15
Similar glitch here. What works for me is to right-click an .mpg file (or whatever), select "properties" and then click on the little spanner icon. This opens a similar dialogue box where you can change your application priority and suchlike, and it actually seems to remember the settings.

Hope this helps,

Old 02-08-2005, 02:27 AM   #4
Senior Member
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Just a guess "in the dark": are your permissions OK in /tmp? I once managed to screw them up (owner:group all set to root:root) and KDE behaved strangely. I cleaned /tmp altogether and it worked fine again.
Old 02-08-2005, 03:15 AM   #5
Registered: Mar 2004
Location: Darkest Oxfordshire
Distribution: Arch, Slackware
Posts: 184

Rep: Reputation: 31
Try closing all instances of Konqueror (browser or file manager) after making your changes to the file associations (you'll probably have to use the process table to get rid of one of the one it keeps preloaded). I've found Konq doesn't always respond to changes in file associations until it is restarted.
Old 02-08-2005, 10:42 AM   #6
Registered: Nov 2004
Location: Virginia, US
Distribution: Slackware 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 22

/tmp permissions are ok.


no other instances of knonq running... the problem still there even after making changes, exiting KDE and restarting it...


You really have issues... I'm only problems with the file associations, everything else seems to be working OK.
Old 02-08-2005, 10:43 AM   #7
Registered: Nov 2004
Location: Virginia, US
Distribution: Slackware 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 22
forgot one thing...

Where does KDE/konq read the default file associations from?
Old 03-23-2005, 03:02 AM   #8
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 322

Rep: Reputation: 31
I am having the same problem in FC3. the defaults keep coming back to haunt me!

What can be done to fix this.

I am using:

KDE 3.3.0-5 Red Hat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux thinks /etc is a file comex Linux - General 1 09-05-2005 05:13 PM
Help, My Mandrake thinks it's Windoze vdemuth Mandriva 2 10-21-2004 10:38 AM
what do you thinks better out of mandrake and suse coolinuxguy246 Linux - Distributions 1 06-19-2004 09:33 AM
Mandrake 9.1, thinks floppy is cd greenpenguin246 Linux - Hardware 1 01-24-2004 12:55 AM
how they thinks ? amjad General 13 11-13-2003 04:03 AM

All times are GMT -5. The time now is 09:27 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration