LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE thinks it knows better (http://www.linuxquestions.org/questions/slackware-14/kde-thinks-it-knows-better-287409/)

l0rddarkf0rce 02-07-2005 04:22 PM

KDE thinks it knows better
 
I'm having a fight with KDE on my slack box and beleive it or not I'm loosing...

In short the problem is that no matter what I tell KDE in Control Center about File Associations it always goes back to the defaults...

For example I change the default player for MPEG files

Control Center -> KDE Components -> File Associations -> video -> mpeg

to

Xine (first)
Noautn (second) (by default this is the first one)
etc.

I click Apply, close CC and now I click on any mpeg file and it opens with Noatun. If I go back to CC the settings are back to the defaults. And yes it happens with all of the file associations.

Any ideas/suggestions will be appreciated.

BTW I'm running KDE 3.3.2 on Slack 10.0, kernel 2.4.29

sh1ft 02-07-2005 05:33 PM

I have no idea what your problem is, but I can offer consolation in that i've been having similar troubles with KDE.

Any theme I apply NEVER changes the taskbar and Kmenu, it is forevor stuck on the plastik theme. I can't even change the fonts in the menu. All the other widgets are nice and themed but my freaking taskbar appears to be stuck on kartoonish plastik for all eternity. GRRRRRRRRRR!!

Lim45 02-08-2005 01:02 AM

Similar glitch here. What works for me is to right-click an .mpg file (or whatever), select "properties" and then click on the little spanner icon. This opens a similar dialogue box where you can change your application priority and suchlike, and it actually seems to remember the settings.

Hope this helps,

Dave

uselpa 02-08-2005 01:27 AM

Just a guess "in the dark": are your permissions OK in /tmp? I once managed to screw them up (owner:group all set to root:root) and KDE behaved strangely. I cleaned /tmp altogether and it worked fine again.

AxelFendersson 02-08-2005 02:15 AM

Try closing all instances of Konqueror (browser or file manager) after making your changes to the file associations (you'll probably have to use the process table to get rid of one of the one it keeps preloaded). I've found Konq doesn't always respond to changes in file associations until it is restarted.

l0rddarkf0rce 02-08-2005 09:42 AM

uselpa

/tmp permissions are ok.


AxelFendersson

no other instances of knonq running... the problem still there even after making changes, exiting KDE and restarting it...

sh1ft

You really have issues... I'm only problems with the file associations, everything else seems to be working OK.

l0rddarkf0rce 02-08-2005 09:43 AM

forgot one thing...

Where does KDE/konq read the default file associations from?

Ian_Hawdon 03-23-2005 02:02 AM

I am having the same problem in FC3. the defaults keep coming back to haunt me!

What can be done to fix this.

I am using:

KDE 3.3.0-5 Red Hat


All times are GMT -5. The time now is 01:41 AM.