LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE system sluggish the longer it's up (http://www.linuxquestions.org/questions/slackware-14/kde-system-sluggish-the-longer-its-up-4175457526/)

dimm0k 04-09-2013 02:28 PM

KDE system sluggish the longer it's up
 
Been using Slackware64 14.0 on a Lenovo W520 with an nVidia GPU and so far things have been pretty good except for the sluggish performance of KDE if I stay in KDE for more than a few days. Things get worse if I have VMWare running and even after closing it KDE still feels a bit slower than it should. This was with the stock KDE for 14.0, as well as with 4.10.2 from AlienBob. I'm just wondering if anyone else has been experiencing this. Using Xrender the system is a lot more sluggish than with OpenGL and things get back to normal once I restart KDE. Any suggestions?

willysr 04-09-2013 04:37 PM

Starting vmware does consume a lot of resources, especially when your main memory is not big enough or you configured too much memory allocation for your guest, but when you have closed them, the performance should be good
My computer never shut down and the performance is still good using KDE 4.10.2 in current

dimm0k 04-09-2013 07:06 PM

Hi willysr! Problem is even after closing VMWare KDE still runs sluggish until I restart KDE. Switching between open applications seem to take a couple of seconds before they're switched to and this is on a 16GB system.

willysr 04-09-2013 10:01 PM

Mine is only at 4GB and no problem with KDE
Probaby the indexer is still running and not yet completed indexing your files?

slouchfuzz 04-09-2013 11:30 PM

That sluggish pausing sounds like you're dipping into your swap maybe? With 16 GB of memory you shouldn't need to really. Try changing your 'swappiness' setting, the default is 60 so something pretty low like 5 might help (your kernel won't start using swap until your RAM is pushed to 95% usage).

sudo /sbin/sysctl vm.swappiness=5

will change your swappiness from 60 to 5.


less /proc/sys/vm/swappiness

will show your swappiness value

dimm0k 04-14-2013 09:24 AM

Quote:

Originally Posted by slouchfuzz (Post 4928609)
That sluggish pausing sounds like you're dipping into your swap maybe? With 16 GB of memory you shouldn't need to really. Try changing your 'swappiness' setting, the default is 60 so something pretty low like 5 might help (your kernel won't start using swap until your RAM is pushed to 95% usage).

sudo /sbin/sysctl vm.swappiness=5

will change your swappiness from 60 to 5.


less /proc/sys/vm/swappiness

will show your swappiness value

Took a few days to experiment and it looks like this was the magic setting that has prevented the sluggish KDE! Thanks!


All times are GMT -5. The time now is 02:53 PM.