LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2013, 01:28 PM   #1
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Rep: Reputation: 23
KDE system sluggish the longer it's up


Been using Slackware64 14.0 on a Lenovo W520 with an nVidia GPU and so far things have been pretty good except for the sluggish performance of KDE if I stay in KDE for more than a few days. Things get worse if I have VMWare running and even after closing it KDE still feels a bit slower than it should. This was with the stock KDE for 14.0, as well as with 4.10.2 from AlienBob. I'm just wondering if anyone else has been experiencing this. Using Xrender the system is a lot more sluggish than with OpenGL and things get back to normal once I restart KDE. Any suggestions?
 
Old 04-09-2013, 03:37 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Starting vmware does consume a lot of resources, especially when your main memory is not big enough or you configured too much memory allocation for your guest, but when you have closed them, the performance should be good
My computer never shut down and the performance is still good using KDE 4.10.2 in current
 
Old 04-09-2013, 06:06 PM   #3
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Original Poster
Rep: Reputation: 23
Hi willysr! Problem is even after closing VMWare KDE still runs sluggish until I restart KDE. Switching between open applications seem to take a couple of seconds before they're switched to and this is on a 16GB system.
 
Old 04-09-2013, 09:01 PM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Mine is only at 4GB and no problem with KDE
Probaby the indexer is still running and not yet completed indexing your files?
 
Old 04-09-2013, 10:30 PM   #5
slouchfuzz
LQ Newbie
 
Registered: May 2009
Distribution: Slackware, Mythbuntu
Posts: 12

Rep: Reputation: 5
That sluggish pausing sounds like you're dipping into your swap maybe? With 16 GB of memory you shouldn't need to really. Try changing your 'swappiness' setting, the default is 60 so something pretty low like 5 might help (your kernel won't start using swap until your RAM is pushed to 95% usage).

sudo /sbin/sysctl vm.swappiness=5

will change your swappiness from 60 to 5.


less /proc/sys/vm/swappiness

will show your swappiness value
 
2 members found this post helpful.
Old 04-14-2013, 08:24 AM   #6
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Original Poster
Rep: Reputation: 23
Quote:
Originally Posted by slouchfuzz View Post
That sluggish pausing sounds like you're dipping into your swap maybe? With 16 GB of memory you shouldn't need to really. Try changing your 'swappiness' setting, the default is 60 so something pretty low like 5 might help (your kernel won't start using swap until your RAM is pushed to 95% usage).

sudo /sbin/sysctl vm.swappiness=5

will change your swappiness from 60 to 5.


less /proc/sys/vm/swappiness

will show your swappiness value
Took a few days to experiment and it looks like this was the magic setting that has prevented the sluggish KDE! Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE takes longer and longer to load vbisis Slackware 26 10-10-2010 03:28 PM
gtk apps sluggish in kde ganja_guru Linux - Software 28 08-17-2005 07:18 PM
Fedora's KDE very sluggish for me? DaveGallant Fedora 0 07-16-2004 11:41 AM
Fedora Core 2, KDE sluggish? DaveGallant Linux - Newbie 2 07-16-2004 12:53 AM
Red Hat 8.0 system becomes sluggish pdohman Linux - Software 4 11-13-2003 03:10 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration