LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-26-2012, 10:08 AM   #1
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Rep: Reputation: 23
KDE, Slackware 14 and sleepy monitor


Lately my monitor has been acting up where if it goes to sleep it won't wake up until you pull the power, as the power button doesn't even work. I've disabled the option in the "Power settings" for KDE to not put the monitor to sleep, yet it still does. Am I missing a setting somewhere or is this a bug?
 
Old 11-26-2012, 04:50 PM   #2
Beelzebud
Member
 
Registered: Oct 2010
Distribution: Arch & Slackware
Posts: 95

Rep: Reputation: 22
I've had this issue before in Arch, and again in Slack, and I always fix it with a few additions to the xorg.conf file.

Code:
    Option	   "BlankTime" "0"
    Option	   "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"
 
1 members found this post helpful.
Old 11-26-2012, 06:09 PM   #3
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,161

Rep: Reputation: 504Reputation: 504Reputation: 504Reputation: 504Reputation: 504Reputation: 504
Whole story + solution here:
http://www.linuxquestions.org/questi...n-kde4-864104/

jlinkels
 
1 members found this post helpful.
Old 11-27-2012, 08:56 AM   #4
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
Beelzebud, Looks like there's a few ways to solve this. While digging through my xorg.conf I did notice that I had Option "DPMS" under the entry for the monitor in question so I've removed it. Did not have enough time to verify whether or not it would go into sleep, but I'll find out for sure when I get home tonight. Those options you've listed should work on a monitor by monitor basis, as well as for all the monitors on a system correct?

jlinkels, thanks for the link! As you mentioned in your last post to that link KDE gets a little weird when it comes to certain settings and I can't disagree with you more.
 
Old 11-27-2012, 02:13 PM   #5
Beelzebud
Member
 
Registered: Oct 2010
Distribution: Arch & Slackware
Posts: 95

Rep: Reputation: 22
In my xorg.conf those 4 options are under 'Section "ServerLayout"', so I think that would mean they would affect all monitors hooked up. I only have 1 monitor so I can't confirm that. Under my monitor settings I still have the DPMS option in there. For me just adding those 4 lines to the serverlayout kept my monitor from sleeping.

I'm sure there are a few ways to deal with it, and mine might not even be the "best" way, but it's always worked for me.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ubuntu 11.04 Sleepy system RON Howe Ubuntu 2 05-06-2011 01:52 AM
Dual monitor setup with KDE 4.2 Slackware 13 and wallpaper not spanning both screens Moch5.0 Slackware 2 08-29-2009 02:25 PM
Putting harddisk to sleep... and keeping it sleepy crispy_chunks Linux - Hardware 5 01-09-2009 02:33 AM
Slackware is Sleepy SML Slackware 13 03-23-2004 08:04 PM
[REDHAT KDE] Disable KDE boot? Apache down after 10min losing monitor signal bjwesselink Linux - Software 2 08-11-2003 01:52 PM


All times are GMT -5. The time now is 10:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration