LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE, Slackware 14 and sleepy monitor (http://www.linuxquestions.org/questions/slackware-14/kde-slackware-14-and-sleepy-monitor-4175438772/)

dimm0k 11-26-2012 10:08 AM

KDE, Slackware 14 and sleepy monitor
 
Lately my monitor has been acting up where if it goes to sleep it won't wake up until you pull the power, as the power button doesn't even work. I've disabled the option in the "Power settings" for KDE to not put the monitor to sleep, yet it still does. Am I missing a setting somewhere or is this a bug?

Beelzebud 11-26-2012 04:50 PM

I've had this issue before in Arch, and again in Slack, and I always fix it with a few additions to the xorg.conf file.

Code:

    Option          "BlankTime" "0"
    Option          "StandbyTime" "0"
    Option        "SuspendTime" "0"
    Option        "OffTime" "0"


jlinkels 11-26-2012 06:09 PM

Whole story + solution here:
http://www.linuxquestions.org/questi...n-kde4-864104/

jlinkels

dimm0k 11-27-2012 08:56 AM

Beelzebud, Looks like there's a few ways to solve this. While digging through my xorg.conf I did notice that I had Option "DPMS" under the entry for the monitor in question so I've removed it. Did not have enough time to verify whether or not it would go into sleep, but I'll find out for sure when I get home tonight. Those options you've listed should work on a monitor by monitor basis, as well as for all the monitors on a system correct?

jlinkels, thanks for the link! As you mentioned in your last post to that link KDE gets a little weird when it comes to certain settings and I can't disagree with you more.

Beelzebud 11-27-2012 02:13 PM

In my xorg.conf those 4 options are under 'Section "ServerLayout"', so I think that would mean they would affect all monitors hooked up. I only have 1 monitor so I can't confirm that. Under my monitor settings I still have the DPMS option in there. For me just adding those 4 lines to the serverlayout kept my monitor from sleeping.

I'm sure there are a few ways to deal with it, and mine might not even be the "best" way, but it's always worked for me.


All times are GMT -5. The time now is 07:53 AM.